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Introduction

Thank you!
Congratulations on your purchase of Pyramix Virtual Studio. More than just a product, this is a 
gateway to the future of sound recording, editing, mixing and mastering. You have joined a 
worldwide community of users who have already discovered the Pyramix advantage.

Note: IMPORTANT! - The first thing you need to do is register your software to 
acquire your Pyramix key(s) and to be included in our user support list.

Please also subscribe to the User Forum at:

http://www.merging.com/forum/ 

Assumptions
This User Manual and the other Pyramix guides assume you are thoroughly familiar with PCs 
and Windows terms and concepts. If the PC is new, please ensure the machine is working cor-
rectly before attempting to install Pyramix Virtual Studio.

Conventions
Conventions used in this manual:

Names found on Pyramix screens and menus are shown in bold. E.g. Information & Settings

Menu and sub-menu selections are shown like this:

View > Tracks > Show all Tracks

Which means:

Go to the View pull-down menu, mouse down to the Tracks sub-menu and choose Show all 
Tracks.

Where a window has several Pages, Tabs are used to ‘turn’ the pages. Tab page selection is 
shown thus:

Project > Information & Settings : Record

Which means:

Go to the Project pull down menu, choose Information & Settings then click on the Record tab.
mix Virtual Studio User Manual
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Pyramix Guides

User Manual
This manual is intended to enable new users to achieve results quickly. It also aims to introduce 
existing Pyramix users to the multitude of new features in Pyramix 4.1.

Other Pyramix Guides
The other guides listed here may be freely downloaded from the Merging Technologies web-
site.

http://www.merging.com

Pyramix Reference Guide
This is the ‘bible’ for Pyramix users and covers every aspect of the main application in detail.

Installation Guide
An expanded version of the chapter: Installing Pyramix Virtual Studio Hardware  on page 13

Virtual Transport Guide
This is the reference guide for Virtual Transport.

Pyramix Applications Guide
This guide aims to be a useful resource for Pyramix users. It contains set-up examples and prac-
tical hints and tips for using Pyramix for specific applications such as;

Music Recording

Music editing

Mastering

DSD and SACD

Radio Production

Radio Broadcasting

Theatre Playout

Sound for Picture
yramix Virtual Studio User Manual
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Pyramix Virtual Studio Overview

VERY IMPORTANT!

We strongly recommend you consult the other Pyramix guides, the Reference 
Guide and Applications Guide for a more complete understanding of all the 
features and functions of Pyramix.

HOWEVER,

recognizing that most people do not read manuals until they have to, this 
shorter version will enable you to achieve (almost) instant gratification! This 
manual will introduce you to Pyramix Virtual Studio Version 4.1 and lead 
you through a simple set-up, recording and importing audio, simple editing, 
mixing, adding effects, and CD recording.

Pyramix Virtual Studio is a powerful and flexible Digital Audio Workstation (DAW)  integrat-
ing hard disk recording and editing, digital audio mixing, effects processing, machine control, 
video, and CD-R mastering.

The Pyramix software runs on the Merging Technologies Mykerinos hardware platform. Each 
Mykerinos board is capable of up to 128 channels of 24-bit digital audio, 64 recording and 64 
playback. External access to these 128 channels is determined by your choice of physical inputs 
and outputs to the Mykerinos board.

Pyramix Card and Software Set and Pyramix Turnkey
Your Pyramix Virtual Studio will have been supplied in one of two forms:
Pyramix Card and Software Set or Pyramix Turnkey.

Pyramix Turnkey systems are complete, ready to go, rack-mounted PCs with the Pyramix Card 
and Software Set already installed and properly configured at the Merging Technologies fac-
tory. As such, no user installation or configuration is needed. You can launch and run the Pyra-
mix software immediately. 

Pyramix Card and Software Set consists of the Mykerinos hardware and the Pyramix software 
ONLY. You must provide an appropriate computer platform and software environment in 
which to install the board and software, and install these yourself. Guidelines for an appropriate 
Pyramix system environment can be found in the following section.

Future Expansion is of course, possible, whether you start with Turnkey or Card and Software 
Set.

Pyramix Virtual Studio Board I/O

Audio I/O Options
Mykerinos is a modular board which can have any one of several optional audio I/O daughter 
cards attached. When ordering Pyramix Virtual Studio from Merging Technologies or one of its 
distributors, be sure to specify the daughter card appropriate to your specific needs. (Please see 
Appendix II I/O Daughter-card Options  on page 264)
mix Virtual Studio User Manual
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On-board Analog Audio I/O
Regardless of which I/O daughter card is chosen, you can simultaneously use the 3.5mm stereo 
mini-phone jack on the Mykerinos board as an unbalanced, analog stereo audio monitor output 
for all projects up to 384 kHz, with levels programmable from within the Pyramix software. 
Sources at sample rates higher than 96 kHz are automatically Sample Rate Converted to 96 kHz, 
24 bit. This stereo mini-jack connection may be connected to headphones or to a line level audio 
monitor input.

Time Code and Video Sync Option
The Pyramix Synchronization option provides SMPTE / EBU LTC and VITC time code in/out, 
video sync in/out and word clock sync. A multi-pin circular mini-DIN connector, on the back 
plate of the Mykerinos board carries all the system synchronization, time code and video sync 
signals. An optional break-out cable is provided for connections to time code, sync and video I/
O. The Synchronization option allows Pyramix to be configured as a master or slave lock to 
external time code, video or word clock. It also enables VITC and/or a visible time code burn-
in window (BITC) to be added to video output/throughput.

System Requirements For Pyramix Virtual Studio 

Computer
• PC with Intel Pentium PIII 800 MHz or higher, minimum 256 MB RAM.

• PCI 2.1 compliant card slot(s) in which to install the Mykerinos board(s).

• Windows XP, Windows 2000 or Windows NT Workstation (v4.0 SP6 or higher OS

• Graphics Adapter with a minimum resolution of 1024x768 (Dual Head with resolution of 
1280 x 1024 recommended).

• Sufficient HD space and speed for your audio media files. The speed and amount of disk 
space required depends on sample rate, bit depth, number of tracks and length of program 
material. A fast (10k rpm or better 15k rpm) SCSI drive (e.g. Seagate Cheetah) or a RAID 
array is recommended for larger multi-track projects, high sample rate and DSD work. Low 
cost IDE drives are fine for smaller projects of up to 24 channels.

• We recommend disks should be formatted as NTFS volumes.

Hard Disk Space Requirements
A complete software installation will require around 50MB of disk space for the Pyramix soft-
ware itself and approximately 10MB of disk space for the Virtual Transport.

In addition, you will need hard disk storage for any captured audio media files. As a rule of 
thumb, one Gigabyte of disk storage equals:

• 185 track minutes at 44.1 kHz 16 bits

• 125 track minutes at 44.1 kHz 24 bits

• 170 track minutes at 48 kHz 16 bits

• 115 track minutes at 48 kHz 24 bits

• 55 track minutes at 96 kHz 24 bits

For continuous multi-track recording applications, divide total available mono track time by the 
number of tracks you will be using.

Please note that these are very rough estimates, and should be used only as a general indication 
of storage requirements.
yramix Virtual Studio User Manual
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Operating System
Windows XP, Windows 2000 or Windows NT Workstation (v4.0 SP6 or higher) installed (never 
attempt to install Pyramix on NT Server). Windows XP is preferred.

Power Management
N.B. As with all Digital Audio Workstations and Non-Linear Editors, we recommend setting the 
PC to an Always On Power management scheme. (Start > Settings > Control Panel double click 
Power Options. Choose Always On from the Power Schemes drop down list.) This allows the 
monitor to be turned off by the system but disables hard-disk turn off and Standby.

Note: The Mykerinos card is not designed to support Standby modes.

Other Applications
Like all Digital Audio Workstations, Pyramix works best when there are no other unnecessary 
applications or services running.

Video and Pyramix on one PC
To ensure a very smooth system (especially for seeking) playing video with Pyramix on the 
same computer, we recommend a Dual Processor PC, a dedicated hard drive for the video and 
Windows XP
mix Virtual Studio User Manual
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Digital Audio Synchronization and TimeCode

THERE MUST BE ONLY ONE SOURCE OF SYNC FOR AUDIO AND TIME-CODE

Digital audio relies on extremely accurate timing. In any digital audio system there can only be 
one source of sync at one time. This is particularly important when planning multi-machine 
systems. If time-code is not locked to the same sync source as the digital audio then either the 
audio will work properly, or the time-code. But NOT BOTH AT THE SAME TIME.

Ideally, in any system with more than one device, there will also be an independent source of 
sync. E.g. a word-clock generator with multiple outputs. Each device is fed by a single output 
and configured to use this source as its sync reference.

Example:

A location digital recorder records at a nominal 44.1kHz sampling rate generated by its internal 
crystal oscillator and also records time-code derived from the same oscillator. Although the 
machine may be running slightly slow or fast the digital audio and time-code will vary by 
exactly the same percentage. When this location recording is played back on a machine locked 
to a stable sync source, digital audio will play at the same rate as the workstation and the time-
code will be correct.

Consider an alternative scenario:

A digital multi-track is used as a location recorder, synced to its internal oscillator. Time-code is 
recorded on an audio track sourced from, say, a camcorder. When the resulting tape is played 
back on a machine locked to a stable sync source, the audio will be at the correct rate but the 
time-code will ‘drift’ in relation to it. The amount of this error is known as ‘DELTA’. Delta is 
simply the result of the following formula: Internal TC minus External TC minus Offset = Delta. 
Where such a recording exists and it is imperative the time-code on tape is the master reference 
there are several solutions. The preferred options are:

Play back the tape with the machine chase-synchronized to the recorded time-code. Since the 
digital audio is not locked to the time-code the sample rate will drift. If recorded directly, this 
would result in missed or duplicated samples. I.e. unpleasant audible artefacts. Therefore, in 
order to record the audio in Pyramix it must go via a digital audio synchronizer/sample rate 
converter synchronized to the master word-clock source. This will then present Pyramix with 
digital audio at the correct rate.

Alternatively, the audio could be converted to analogue then fed into Pyramix via an analogue 
to digital converter.
yramix Virtual Studio User Manual
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Installing Pyramix Virtual Studio Hardware

Mykerinos Board Installation
The Merging Technologies Mykerinos board can be installed in any free PCI slot in your PC. In 
general, it is best NOT to install the board in the PCI slot adjacent to an AGP graphics adapter; 
and in a PCI slot which may be physically shared with an ISA slot.
Please consult the merging.com website for current compatibility information.

Make absolutely certain the PC power is OFF before installing the board!

With most of the current generation motherboards this means either the mains switch on the 
power supply or the power outlet switch. Where no switch is provided, either on the PC or the 
supply socket, then the PC should be unplugged.

Always observe proper static precautions when handling any PC boards! Use a static strap, 
and/or be sure to firmly ground yourself to the computer power supply, chassis or if the PC is 
unplugged, to a known good earth before handling and installing the Mykerinos board.

Some PCs have batteries, cables, jumpers, etc. which could prevent proper board seating in one 
or more slots. Make certain the board is firmly and fully seated before switching on.

Multi-board installation
Multiple boards must be installed in adjacent slots. To enable multi-board operation, all Mykeri-
nos cards in the PC have to be connected together using a special HDTDM ribbon cable. This 
cable has to be plugged into the multi-pin connectors located on the top edge of the I/O daugh-
ter cards. Please contact your Merging Technologies dealer for information on how to order this 
HDTDM ribbon cable.

HDTDM
The HDTDM cable has the following functions in a multiple Mykerinos board installation:

a) synchronization (to 1/512th of an audio sample accuracy) This enables Pyramix to "see" a sin-
gle system comprised of a large pool of DSP power and I/O resources spread over separate 
cards.

b) transfers all audio signals (Live Inputs, Internal Send/Return Busses, Mix busses, Aux busses, 
Live Outputs, etc. between all the Mykerinos I/O daughter-cards which comprise the multi-
board system.

Daughter-cards
Please see Appendix II I/O Daughter-card Options  on page 264 for a description of the avail-
able daughter-cards.

External Audio D/A-A/D Converter Boxes
Most of the I/O options for the Mykerinos board are digital. Pyramix will often be used with 
external audio D/A (for playback) and A/D (for recording) converters. Many such converters 
are available from Merging Technologies as options: for example, the Merging Technologies 
Dua II and Sphynx boxes. Contact Merging Technologies Sales for more information.

Capabilities of third party D/A - A/D converter boxes are widely variable. Please check with 
the manufacturer to ascertain which sample rates, word lengths and number of I/O channels are 
supported. You will need this information later to appropriately configure the Pyramix soft-
ware.
mix Virtual Studio User Manual
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Cabling Pyramix in your System Environment

Please read this in conjunction with the guide or guides for your specific interface daughter-
cards and external interfaces/converters.

Due to the number of possible I/O options and the variety of user environments it is impossible 
to cover all the variations of cable connections to and from Pyramix. 
However, here are some general rules and examples:

Mykerinos Back-plate

Audio Connections
Many users will have A/D Converters for feeding analog audio sources into Pyramix, and D/A 
Converters for playing analog audio out of Pyramix. In this case, connect your analog audio 
sources to the A/D Converter analog audio inputs, and the A/D digital audio output(s) to the 
Mykerinos digital audio input(s). Similarly, connect the Mykerinos digital audio output(s) to 
your D/A Converter digital audio input(s), and the D/A Converter analog audio outputs to 
your studio monitors or recorders. It may be also be useful to connect the stereo mini-phone 
output on the Mykerinos card to either stereo headphones or a stereo monitor console input. 
The source for this jack can be configured inside the Pyramix software.

3.5mm Mini-Phone Jack for analog monitor output

8-pin Mini-DIN for sync breakout cable

Area where I/O Daughter Card output connectors appear.
yramix Virtual Studio User Manual
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Sync, Video and Time Code Connections
In any digital audio system, it is VERY IMPORTANT all interconnected units are locked to the 
same sync reference. A digital audio signal itself can sometimes be used as the master sync 
source, but a high stability video or wordclock signal is usually preferable.

The Mykerinos board can be configured inside the Pyramix software to act as either a sync mas-
ter, or to slave to a variety of incoming signals.

Decide which device in your system will provide the master sync reference, then ensure that all 
other digital audio devices in your system take their synchronization from it. This will require 
routing appropriate cables --whether digital audio, video or wordclock cables-- to the various 
other devices and may also involve a separate sync reference generator and or distribution 
amplifiers.

If Pyramix is configured as the master (Internal sync), other digital audio devices will probably 
be able to lock to the digital audio output from Pyramix. However, Pyramix can also be config-
ured to output a wordclock signal at the Video output BNC connector (Pyramix Synchroniza-
tion option required).

If Pyramix is configured as a slave to an external device, Various synchronization signals can be 
accepted. 

• To lock to incoming digital audio, connect an appropriate digital audio signal to a Pyramix 
digital audio input.

• To lock to incoming video, connect an appropriate video signal to the Pyramix Video Refer-
ence input (Pyramix Synchronization option required).

• To lock to incoming wordclock, connect an appropriate master wordclock signal to the 
Pyramix Video 2 Input (Pyramix Synchronization option required).

• To set the termination jumpers provided on the Mykerinos board, please see the Mykerinos 
User Guide.

Pyramix can either output or lock to incoming SMPTE / EBU time code.

• If a master LTC time code output from Pyramix is needed, cable the Pyramix LTC time code 
out RCA jack or XLR to any other devices slaving to this output (Pyramix Synchronization 
option required). Pyramix always generates time code when playing.

• To lock Pyramix to an incoming LTC time code signal, cable the LTC time code output from 
the time code source to the Pyramix LTC input RCA jack or XLR (Pyramix Synchronization 
option required).

Pyramix can accept and generate VITC in standard PAL/NTSC formats. It can also provide 
BITC (Burnt In Time-Code) on its video outputs.

MIDI Connections
To use Pyramix MIDI functionality with external equipment, you will require a MIDI interface. 
Many current motherboards include an on-board MIDI interface. If yours does not, it is a simple 
matter to add one. This can be either an internal PCI card or an external unit connected via a 
USB port or an RS232 serial COM port.
mix Virtual Studio User Manual
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Installing Pyramix Virtual Studio Software

Running the Installer
Pyramix Virtual Studio and Virtual Transport software is provided on a CD-ROM. You may 
also receive software updates as a download from our ftp site. In either case, install the Pyramix 
and Virtual Transport software by running the Virtual Transport and Pyramix Virtual Studio 
Installer programs.

Choose the default location to install the software unless you have good reason to do otherwise. 
You will also be asked to a create folders for your media files and for CD Images (these can be 
changed later). If you receive any error messages regarding the Microsoft Digital Signature, 
ignore these and continue on with the installation by clicking ‘Yes’.

Important!  After installation, please reboot the PC before attempting to launch Pyramix Virtual 
Studio. Then open the VS3 control panel application (Start > Programs > Pyramix > VS3 
control panel). The default Tab page is Configuration. Select 8 in the Internal Return Busses 
drop down menu box then click on the Autorouting button followed by the OK button. When 
the VS3 panel, Do you want to save routing? dialogue box appears, click on OK to close the 
VS3 control panel.

Double-click on the Pyramix Virtual Studio desktop icon to launch Pyramix.

Enabling Pyramix Virtual Studio with your Software Key
Pyramix Virtual Studio is protected by a special software Key. Once you have registered your-
software you will be provided with this Key or Keys (depending on the chosen options).

Entering your Key(s)
After the Pyramix installation process you will be prompted to enter your Authorization Key. 
If you click Yes  the MT Security Settings dialog will be launched automatically,  allowing the  
Key or Keys to be entered immediately. If you choose not to enter your Key at this point you can 
do so later by choosing one of the following procedures:

1. Double-click  the  file YourPersonalKeyXXXXX.mtk. This is attached to the email contain-
ing your Key(s).

2. Open the MT Security Settings Control Panel 
(Windows Task Bar  Start >  Control Panel > MT Security Settings),
 click the Import Key button and browse for your Key file called

YourPersonalKeyXXXXX.mtk

3. Open the MT Security Settings Control Panel (as above), in the Registration section select 
the board number corresponding to the serial number for your Keys or HASP Key for a 
dongle, click the Enter Key button and type your User Name, Company Name and Key 
then click OK. Repeat this step for each Keys listed in the email.

Changing or re-entering a Key
Should you need to subsequently change or re-enter a Key, follow the appropriate option 
above.

The key system is "smart". Only one key or set of keys is required regardless of the number of 
boards in a system. Any card can hold this key set as the authorization is processed based on a 
"Logical OR" of all keys present on any and all Mykerinos boards. Of course this Logical OR 
will only process keys with identical User Name and Company Name to the one entered in the 
key enabling window.
yramix Virtual Studio User Manual
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Pyramix User Interface

The Pyramix user interface has evolved into an extremely powerful tool for manipulating audio. 
Commands and functions can be accessed from pull-down menus, pop-up menus, tab windows 
and keyboard shortcuts.

There are generally several ways of accessing any given function in Pyramix. This helps users to 
work in the way they find most comfortable for the type of projects they are undertaking. It also 
means ‘Power Users’ can develop highly efficient operating procedures.

It is perfectly possible to casually use Pyramix without discovering all of the many possibilities 
on offer. However, by looking deeper, a far more rewarding experience awaits.

Mouse Modifier Keys
The range of possible actions resulting from a mouse click are massively extended by the use of 
Keyboard Modifiers. These greatly aid productivity and are well worth learning. Please 
see: Appendix I Mouse Modifier Keys  on page 261

Context Menus
Right clicking over objects on screen such as clips, mixer strips and controls and track headers 
pops up menus with commands and options relevant to the object.

Keyboard Shortcuts
In particular we would encourage users to use keyboard shortcuts and preferably the standard 
Pyramix layout. Keyboard shortcuts can be fully customized and users of other workstations 
will discover we have also provided familiar keyboard layouts to help them on their learning 
curve. 

Macros
The Macro is another powerful feature of Pyramix. Macros are sequences of commands which 
can be invoked by a single key or combination. Some macros are conditional. I.e their precise 
action depends on variables in the project. A considerable library of pre-programmed macros is 
provided together with an editor which enables users to construct their own macros.

Tutorial Project
An introductory tutorial project is provided on the Pyramix software CD-ROM. If you are new 
to Pyramix, please work through the tutorial in conjunction with this manual. Together, they are 
a comparatively painless introduction to many of the concepts and terms used in Pyramix.
mix Virtual Studio User Manual
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Project Templates

Pyramix provides the user with a number of Templates for various applications. A Template is 
a complete Pyramix Project, without any associated audio, specially configured to suit a partic-
ular type of activity. Apart from configuring the appearance of Pyramix, the track layout and 
mixer design, templates also include important optimizations to suit the activity.

Please see: Optimizing Pyramix  on page 259

These templates also offer a good starting point for creating your own customized templates. To 
begin a new project using a template choose Project > New from Template which opens the 
Select a Template file window

.

When a template is opened a dialogue box appears requesting the user to choose a Media 
Folder for the new project. Unless the project is saved using the Save As option, the first time it 
is saved the Save As dialogue will appear.

Further Templates will be added as they are developed. 

To save a new Template choose File > Save as Template, name and save.
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Pyramix Concepts 

Project
A Project is the top level of organization. Projects are saved with the file extension .PMT. A 
Project controls and keeps track of all the various elements you are assembling at a given time. 
A Project always contains a Mixer and a Composition, viewed on the Timeline, or as an Edit 
Decision List (EDL), plus Libraries containing Master Clips, Compositions, Mixer settings, 
and Fade settings.

Mixer
The Mixer, is the nexus of the Virtual Studio. The Mixer routes all audio into and out of a Pyra-
mix Project. It also determines audio sample rates and synchronization. The user configures the 
Mixer as appropriate, for the number and type of inputs strips and output busses needed for a 
Project. Without a properly configured Mixer, no audio can be recorded, mixed, or monitored.

Compositions
A Composition is any number of clips complete with edits and fades, level settings etc. placed 
on a track or tracks in a time relation to each other and to the Timeline.

Timeline
The Timeline shows a graphic representation of the current Composition. and its location in 
relation to the Playhead Cursor, In and Out Marker Cursors and various other Markers. All 
editing is done in the Timeline, EDL or Fade Editor windows.

EDL
The EDL (Edit Decision List), is a textual and numeric representation of the same information 
shown in the Timeline and Fade Editor. Changes made here are reflected in the Timeline and 
vice-versa.

Media Files
These are actual audio data files which can only be seen at the Windows level, e.g. in Windows 
Explorer. In Pyramix, they are represented by Master Clips which reference the raw data files.

Master Clips
The concept of Master Clips is one of the keys to the power of Pyramix. An individual Master 
Clip is a set of pointers that reference one or more Media Files. 

Note that a single Master Clip references all Media Files in a multi-channel audio recording. 
E.g. a stereo recording can have one or two Media Files, (depending on whether there is a check 
in the One file per track box in the Media Option section of the record page of the Project 
Information and Settings window.) (Project > Project Information and Settings - Record Tab).

When One file per track is checked, one invisible Media File is generated for each channel of a 
recording but only one Master Clip. So.a stereo Master Clip references two invisible Media 
Files and a Multi-channel Master Clip references as many invisible Media Files as there are 
channels in the recording. check box ‘One file per track’), but will only generate one Master 
Clip. 

A Master Clip can be mono, stereo, four channels, six channels, 24 channels, in fact there is no 
limit to the number of channels that can be contained within a Master Clip. When a Master Clip 
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is placed into a Composition there is the option to place it where it was originally recorded.

Master Clips also contain attributes which identify parameters such as a File name, time code 
stamp and other information.

Clips
The individual clips shown on the Timeline contain pointers to Master Clips which in turn 
point to audio Media Files.

Media Management - Housekeeping
The Windows hierarchical filing system can easily become confusing and cluttered. Complex 
audio projects generate thousands of more or less enigmatically named files. Keeping track of 
all the files used in a project can become a nightmare even if the user is meticulous.

Pyramix uses the concepts of Media Drives/Folders and libraries to reduce the clutter and pro-
vides management tools specifically designed for audio. This Media Management helps users 
to work in a structured and simple manner whilst keeping track of all the project components.

Media Drives and Folders
Media Drives or Media Folders are Windows folders which contain Media Files. Pyramix 
needs to specifically mount these Media Drives in order to access the Media Files contained 
therein. Once mounted, suitable files are shown as Master Clips.

Provided the sampling rate is the same as the current project, these can be dragged and 
dropped or copied and pasted directly into the Timeline or into a User library from the Media 
Management Window.

Libraries
Pyramix uses libraries to help make project organization tidier. Libraries are used to organize 
project material into logical groupings. However, Libraries are not the same as Windows direc-
tories or folders: they are only meaningful within the Pyramix environment. A Library is a 
database, containing a collection of pointers to different kinds of media objects.

User Libraries
User Libraries can contain Master Clips, Compositions, Mixer Snapshots, Plug-in Snapshots, 
Fades Settings, etc…. Each Project can have an unlimited number of User Libraries open, each 
with an unlimited number and mixture of contents.

N.B. In Pyramix User Libraries, there is no practical distinction between a section of a Compo-
sition (Region) and a complete Composition. Either can be added to a User Library or to an 
existing Composition. This is an extremely powerful feature. A single clip copied to a User 
Library from the Timeline appears there as a Composition.

Automation in libraries
If the menu item Edit > Enable Automation Cut/Copy/Paste is enabled then any operation on 
clips (Cut/Copy/Paste, Auto-Ripple, etc…) brings all automation data with it 

If you drag a clip(s) to a library, all automation over that clip(s) is copied/pasted as well.
yramix Virtual Studio User Manual
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Global Libraries
Project Libraries are kept with the Project, Global Libraries are available to all projects and 
users of the system. This can be helpful for sound effects or where several users need access to 
the same source material to produce different end products.

Project Libraries
When a new Project is created two Project Libraries are also created.

Composition Library
Each Project has a unique, read-only Composition Library. This contains short-cuts to every 
Master Clip placed on the Timeline (present in the EDL) in the current Project. Note that the 
Composition Library may be empty, I.e. nothing is placed on the Timeline but the user 
library(s) may contain Master Clips and Compositions which all form part of the Project.

Default Library
Each new Project also creates an empty User Library named ‘Default Library’. This is provided 
to aid housekeeping and is kept with the project.

TimeCode Entry
TimeCode values in Pyramix can be changed by using Increment Decrement buttons, by using 
the on screen numeric keys or by direct entry from the numeric keypad. an OK button or the 
ENTER key finalizes the entry. In Pyramix numbers are entered in time code fields from right to 
left, a block at a time, progressively overwriting existing numbers.

This makes the most common timecode changes easy, I.e frames or seconds, without having to 
re-enter the minutes or hours.

Clicking in a register inserts a red I-beam cursor and outlines the register in green. Entries must 
be made in Hours : Minutes : Seconds : Frames order. So, to enter 10 Hours and 9 seconds and 15 
frames, key: 1 0 0 0 0 9 1 5. BUT if you only want to change the seconds then you only have to 
enter the seconds and frames E.g. to enter 9 seconds and 15 frames, key: 9 1 5 followed by 
ENTER. However, to change 10:27:10:15 frames to 10:27:09:15 you would need to key, 0 9 1 5 fol-
lowed by ENTER. In practice most operators always enter the leading zero even when it is not 
required, to avoid errors.
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Numeric Keypad

Key  Command

/ Nothing (when in Place-
ment Tool: Done)

* Capture current timecode

- Delete last typed digit (same 
as BACKSPACE)

+ Undo typed timecode and 
restore previous

1 Enters Number 1

2 Enters Number 2

3 Enters Number 3

4 Enters Number 4

5 Enters Number 5

6 Enters Number 6

7 Enters Number 7

8 Enters Number 8

9 Enters Number 9

0 Enters Number 0

. (point) Clear (Set all to zero)

ENTER OK (Accept typed timecode)
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Starting Pyramix Virtual Studio

By default the Installer will put Pyramix Virtual Studio into your Programs folder. It also places 
a Pyramix shortcut icon on the Windows desktop.

To start Pyramix Virtual Studio, double-click on the Pyramix shortcut icon on your Windows 
desktop.

Alternately, choose Start > Programs > Pyramix > Pyramix Virtual Studio.

The first time Pyramix Virtual Studio is launched, you will need to enter in your special Key to 
properly enable the program (see previous section). Upon program launch, you will see the 
main Pyramix Virtual Studio by Merging Technologies window with its Toolbar at the top, 
and transport controls and status displays at the bottom.

You may need to enter further keys if you have purchased extra features.
mix Virtual Studio User Manual
23



User Manual :   Beginning a New Project

P

Beginning a New Project

The Project is the top level of organization in Pyramix Virtual Studio. You need to start a new 
(or open an existing) Project to capture audio, import files, edit, mix or add effects.

Templates
Pyramix has Templates for common tasks and you can save your own. To use an existing Tem-
plate to start a new Project choose Project > New from Template from the pull-down menus 
along the Toolbar at the top of the Pyramix Virtual Studio by Merging Technologies window

.

If you have started a project from scratch (see next section) and would like to save it as a Tem-
plate choose File > Save as Template. The file dialogue will open allowing you to save the tem-
plate with an appropriate name.
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New Project from scratch
To start a new Project from scratch, choose Project > New. This launches the New Project wiz-
ard, which will lead you through the steps to create a new project. 

Step 1: Choose the project type
Choose Editing Project, select the required sampling rate and resolution (number of bits) or 
accept the defaults (44.1kHz, 16 bits), then click the Next button which will lead you to step 2.

Note: A Digitizing Session, DSD Editing Project or DSD Recording Session, the other possi-
ble choices available in the New window, are special kinds of Project described elsewhere.
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Step 2: Setup a new project workspace

Checking the box labeled: Setup a new Project Workspace, allows you to name the new project 
and choose a location for the Project and Media Files. Type in a name for the Project and either 
type in a valid path or use the Browse button to browse to a suitable folder. When you have 
entered the information, click the Next button to get to the next step.

Note: If you uncheck the Setup a new Project Workspace box, when the new project is created 
it will be given the working name Project 1 (or the next available number if Project 1 already 
exists) and the save path will be the default.
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Step 3: Choose a Mixer

A new Project needs a properly configured Mixer. The Mixer, also called the Virtual Studio, is 
used to route all signals into and out of Pyramix; it also determines the sample rate and synchro-
nization source for the Project.

Use Default Mixer

Loads the currently designated Default Mixer preset. N.B. The sampling rate of this preset takes 
precedence over the sample rate set in the Editing Project selected in the Choose Project Type 
dialogue. If no Default Mixer has been defined and Finish is clicked the Blank Mixer window 
opens. Please see: Blank Mixer Window  on page 30

Use a Preset

Choose one of the large number of supplied Mixer Presets (and User Presets if any have been 
created) by clicking on its description. (The Use a Preset Radio button is automatically selected) 
Double-clicking a Preset selects the preset and invokes the Finish function. I.e. opens the new 
Project with the selected mixer.
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Mixer Wizard
If none of the existing presets is considered suitable, or you just want to start from scratch then 
selecting Use Mixer Wizard and clicking the Next button opens this window:

Select the type(s) of busses required using the check boxes and the number needed from the 
drop down lists on the right. Click the Next button to move on to the next page.

Select the type(s) of channel strips required using the check boxes and the number needed 
from the drop down lists on the right. Click the Next button to move on to the next page
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Checking the Connect automatically as many inputs and outputs as possible check-box will 
create the same number and types of Tracks as there are Input Strips and connect as many as 
possible to the available physical inputs in ascending order and output Busses to the physical I/
O attached to the Mykerinos board(s) and Track outputs to Mixer Input Strips, although you can 
easily reconfigure this later. If the box is not ticked, the tracks will be created in the same way 
with Track outputs connected to Mixer strips but no physical Inputs or Outputs will be connected.

Clicking Cancel opens the new Project with a Blank Mixer Window (See below).

Step 4: Open the New Project
Clicking Finish creates the Mixer and opens the new Project.

The Mixer you configured above will now appear on the screen in a separate Mixer window. It 
will contain the number and kind of Input Strips and Output Busses defined. It can be moved 
anywhere on the screen by clicking and dragging on its top bar, or be minimized or hidden.

It is VERY IMPORTANT to ensure the Mixer’s sample rate, synchronization and I/O mode are 
configured correctly. To check or adjust settings, right-click anywhere on the Mixer window, 
then choose Settings > General... which will open the Mixer Settings window. (Or choose Set-
tings > Mixer Settings : General from the main Settings menu.
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Blank Mixer Window
Note: If you click the Finish button before defining a Mixer, the Default Mixer will be used and 
the new Project opened. If no Default Mixer has yet been defined this window opens:

Use right mouse button to configure your mixer

This is the equivalent of right-clicking on a blank area of an existing mixer. We recommend only 
experienced users choose this option. Please see: Creating and Configuring Mixers  on page 52

Creating a mixer in this way can be very time consuming. It is much faster to either:

Click here to use the Wizard

Please see: Mixer Wizard  on page 28

Or, simply:

Double-click on a Mixer preset

Pick one from the list which most closely matches your requirements, then configure it to suit 
when the new Project has opened.
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Getting Audio into Pyramix Virtual Studio

There are two basic methods of getting audio into Pyramix initially: you can record audio 
directly into the program, or you can import previously existing audio files.

Please see also: Digitizing Sessions  on page 144 and External Machines  on page 141

Pyramix audio file format
Unless there is a good reason for using another file format for recordings we strongly recom-
mend using the default .PMF file format. This will give the best performance in a number of key 
areas.

For further information please see: Optimizing Pyramix  on page 259

Recording Audio into a Pyramix Virtual Studio Project
Start a new Project, or open an existing one. Make certain the Mixer sample rate and sync source 
is set as desired. You will need to configure at least the same number of Mixer channels as 
Tracks you wish to record.

Before beginning audio capture, check or select appropriate record settings. Open Settings > 
Information & Settings : Record (alternatively use the keyboard short-cut Ctrl - f and click the 
Record Tab) There are many settings in this window, but for now you need only be concerned 
with; Destination Drive (Media File folder), Resolution (bit depth or word length) and Format 
(file type). As previously mentioned, unless you have a specific reason for using a different for-
mat we recommend using the default PMF format.

Track Record Modes
Each Track has a tri-state Record Ready toggle button, located to the left of the Track itself in 
the Track Information and Setup Area.

Tip: Right clicking on a track arming button opens the Settings > Information & Settings win-
dow immediately on the Record Page.

Play
The Green Dot in the Track Header indicates Record Safe mode, the default when Tracks are 
newly created. When in this state, the Track cannot be recorded to.

Record Ready (Manual)
Click on the Green Dot once to toggle to Record Ready mode. This is indicated by the dot turn-
ing into the Red Dot. The Track will now go into Record mode immediately when the Master 
Record button is pressed in the Transport Strip or Transport window.

Record Punch In (Auto)
Click on the Red Dot to toggle to Record Punch In mode. This is indicated by a Red Dot 
flanked by 2 red vertical lines. In this mode, when the Master Record button is pressed in the 
Transport Strip or Transport window, the Track will stay in Play mode until the current Mark 
In point is reached, then the Track will go into Record mode. It will stay in Record mode until 
the current Mark Out point is reached.
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After Recording
New recordings will be processed according to the settings made in the Settings > Information 
and Settings : Record page. Please see: Record  on page 83

If the Prompt for name after recording box is checked the Record Name window appears when 
the recording is finished and the transport stopped.

Type a name for the recording (or leave the default) then select one of the button options.
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Importing Audio Files into Pyramix Virtual Studio

Importing Audio Files
Different file types with different bit depths (word lengths) can be freely combined in a Compo-
sition. Simply Mount the Media Drive or Media Folder and drag-and-drop the required mate-
rial into the Timeline.

Files with different sample rates can also be freely combined.

Note: If a clip has a different sample rate to the current project the clip will play at the ‘wrong’ 
speed! E.g. in a 48kHz project a 96kHz clip will play at half speed. With most material this will 
be glaringly obvious, however with sound effects, smaller differences in rate (E.g. 44.1kHz - 
48kHz) may well go unnoticed.

Mounting Media Drives
If many audio files already exist in a single Windows directory or folder, it is easy to mount that 
Windows folder as a Pyramix Media Drive. Once mounted, the supported files become avail-
able for use in a Project.

1. Start a New Project or Open an existing one.

2. Click the Media Management Tab in the Project Management Panel to open the Media win-
dow, or double click to open it as a floating window.

3. Select Drive > Mount Media Drive. This opens the Choose a media folder to mount win-
dow.

4. Click the Browse... button, then navigate to the Windows directory containing the audio 
files you wish to import.

5. Click the OK button to mount that Windows directory as a Media Drive. All supported 
audio file types will be seen by Pyramix, and be available for use in the Project. A check in 
the Recursive box means Pyramix will look in sub-directories of the chosen folder as well as 
the root. A check in the Permanent mount box means Pyramix will attempt to mount the 
folder whenever the application is launched. I.e. make it available to all Projects.
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Sample Rate Conversion
Where the sampling rate of a Media File is different to the current Project, Pyramix offers a 
simple means of converting the Media File’s sample rate.

1. Select a Master Clip file or files in the main Media Management window.

2. Choose Convert > Quick Convert > Samplerate Converter. A Samplerate Converter dia-
logue box appears. Radio buttons offer the choice of two text entry fields, New name for the 
file or Add Suffix to the existing filename. A checkbox selects Keep Original File Format 
otherwise the file will be converted to PMF format as well as sample rate converted.

3. Selecting Properties opens the Samplerate Converter Properties window. Choose the 
required target sample rate by clicking on one of the Output Sampling Rate [Hz] radio but-
tons. Conversion Quality defaults to High with the option of Very High. Click OK to close 
the window

4. Choose OK in the Samplerate Converter dialogue box to begin the conversion. When con-
verting multiple files, choose OK to convert the files one at a time with the possibility of 
changing parameters on each file or, if Add Suffix was chosen in step 2, you can choose OK 
all to convert all the selected files in one operation

.

Note that bit depth (word length) is not changed with a sample rate conversion. Options for 
converting bit depth or normalizing can be accessed via the Convert > Quick Convert > sub-
menus. For further information please see the Pyramix Reference Guide.
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Practical Media Management and Libraries

Clips and Compositions
Master Clips can simply be dragged from Media Drives to User Libraries for purposes of clip 
organization, grouping, etc. just as they are dragged into Compositions

User Libraries are not restricted to storing individual clips. Whole Compositions or selected 
Regions of Compositions, including all the clips in a Composition in relation to each other on 
multiple Tracks may be placed in a library. To do this, select one or more clips in a Composi-
tion, hold down the Shift-Alt keys and drag the selection from the Timeline to the Library, or 
hold down the Shift-Alt keys and drag the whole Composition from the Overview panel to the 
User Library.

Media Folders

Managing Media Folders

This window can be opened in several ways. From the Media Management Tab Window Drive 
> Mount Media Drive or by right-clicking a Media Drive or Media Folder entry in the right-
hand pane, and from the New entry in Media Folder drop-down list menus in various Pyramix 
Windows.

The text box allows a complete path to be entered or a Media Folder or Drive can be chosen from 
the drop down list. Alternatively, a new Media Folder can be created by typing its name in the 
text box. The new folder will be created below the current one in the tree.

Recursive

When checked, all sub-folders of the chosen folder will also be mounted.

Permanent Mount

When checked, the chosen folder will be mounted at start up for all future Projects. (Can be use-
ful for sound effects libraries etc.)

Reset List

Clears the drop-down list. The list contains all folders that have been mounted since the list was 
last cleared.

Browse...

Opens the Browse for Folder Window which enables any Windows drive or folder on the local 
machine or across a network to be selected for mounting.

Mount / Create

Mounts the selected Media Drive or Folder or creates a new one if the name and or full path has 
been typed into the text box.
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Editing

The Timeline is the place in Pyramix where audio clips can be edited, faded up and down and 
otherwise arranged into a mono, stereo or multi-channel digital audio Composition.
A Project Editing Panel containing the Timeline will be visible as soon as you open a Project.

The Fade Editor provides elegant alternative methods of viewing and adjusting the parameters 
of edits in the timeline.

Clips and Compositions

Clips in a Composition
As with clips in a Media Drive or Library, clips in a Composition are just pointers to the origi-
nal audio Media File. Any actions performed on a clip in a Composition will affect neither the 
original audio Media File, nor the Master Clip in the Media Drive or Library it came from. In 
the Project Editing Panel, a clip can be edited, shortened, split into 2 clips, moved, level con-
trolled, deleted, etc., and all actions will ONLY affect the Composition.

Once placed in the Composition, each clip by default displays a Waveform of the Media file to 
which it points. This Waveform display can be enabled or disabled by the user.

Anatomy of a Ccliplip
Many  Edit Commands refer to parts of a clip rather than the entire clip.

Once a clip is selected, Trim Handles appear at each end which are used to manipulate the clip. 
If these are difficult to see or get hold of, zoom in on both axes until they are accessible. Each 
Trim Handle consists of 3 Control Points. The Control Points on the left side of the clip allows 
adjustment of the beginning of the clip, and the Control Points on the right side allows adjust-
ment of the end. Click and drag on the middle Control Point to move the head or tail of the clip 
as desired to shorten or lengthen the clip. These can be moved out to the full extent of the origi-
nal audio Media File to which the clip is pointing. Select the menu item View > Show Media to 
view the unused audio (if any) as a grayed out waveform.

Head
The beginning of a clip on a Track is referred to as the Head. The Head may or may not repre-
sent the actual beginning of the Media File for the clip, since the clip is just a set of pointers to an 
area of the whole media file.

Trim Handle

Sync Point

Fade Handles

Tail

Waveform Display

Head

Clip Name

Clip Gain
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Tail
The end of a clip on a Track is referred to as the Tail. The Tail may or may not represent the 
actual end of the media file for the clip, since the clip is just a set of pointers to an area of the 
whole Media File.

Sync Point
The Sync Point is an internal reference point inside the clip. This defaults to the start of a clip 
until moved.The Sync Point may be moved by dragging its handle within the clip. If the Play 
cursor is positioned over some part of the clip, the Sync Point may be snapped within the clip to 
the position of the Play Cursor by choosing clips > Set Sync Point to Cursor. 

Trim Handle
The Trim Handle is the middle handle available at either end of the clip when the clip is 
selected. This handle is used to shorten or lengthen the clip (trim the clip in or out) up to the 
limit of the available media. To trim the clip, drag the handle.

Fade Handles
The Fade Handles are the top and bottom handles available at either end of the clip when the 
clip is selected. The handles are used to create a fade in at the beginning of the clip, or a fade out 
at the end of the clip. To create or adjust adjust a fade, drag one of the trim handles to create the 
desired fade in or fade out. The top handle adjusts the fade within the clip and the bottom han-
dle trims  the clip in or out as you adjust the fade. If the Top Handle is used with the CTRL key 
modifier,  a symmetrical crossfade is created with any adjacent clips, centered at the original end 
point of the selected clip. If no adjacent clip exists, then it extends or shrinks the duration of the 
fade while maintaining the duration of the selected clip.

Waveform Display
Clips can appear either as a block with the clip name inside, or can show the audio waveform of 
the media referenced by the clip.

Clip Name
The name of the clip is shown unless supressed. View > Waveform > Hide Clip Name when 
Waveform Shown.

Clip Gain
The overall Gain applied to the clip is shown. This value is displayed in decibels.

Gain can be adjusted by selecting Clips > Clip Gain. The Gain window appears. If a Region is 
selected the Gain will be changed on all clipclips in the selection.

Locking Clips
Clips can be protected from being displaced during editing by selecting Clips > Lock. A locked 
clip cannot be moved in time or to another track until it is unlocked. Clips > Unlock. If you sim-
ply wish to prevent loss of sync select Clips > Lock Horizontal Drag.

Grouping Clips
To Group multiple clips, whether they are on the same or different Tracks, select the clips you 
wish to Group together. Now choose Clips > Group. When any clip in a Group is selected, cop-
ied, deleted or moved, all clips in its Group will be similarly selected, copied, deleted or moved.
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To ungroup previously Grouped clips to treat them separately, select the Group and choose 
Clips > Ungroup.

Groups can be nested. I.e. one group may be inside another group. For example a stereo or 
multi-channel clip is simply a group of mono clips. Stereo or Multi-channel clips may be 
ungrouped into individual mono ones in the same way as any other group. 

Gain WIndow

The Gain window allows the gain to be set for the current selection. The gain 
value can be typed into the box at the top of the strip or set by clicking and drag-
ging the fader

Mute when checked, mutes the selection but retains the gain value

Sel. box (Selection). When checked, the gain change will be applied to the 
whole selection (default is checked)

Rel. box (Relative) When checked and a series of clips are grouped, the 
gain change is relative to pre-existing levels

When neither box is checked any gain change is only applied to the clip 
which was last right clicked (even if others are selected)

OK button makes any changes selected in the Gain window and closes it
Cancel button cancels any changes selected in the Gain window and closes 
it

Clip and Selection Editing
Master Clips appear in the Timeline as blocks which can be edited on a track (or tracks, depend-
ing on how many tracks the Master Clip contains) The clip can be trimmed, split, crossfaded, 
and have many other operations perfomed on it without ever affecting the underlying media 
file. Each instance of a clip references the entire media file, and can always be "opened up" by 
using the Trim Handles to reveal more of the clip until the complete underlying Media File is 
visible.
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Clip Properties
Clips > Properties opens the Properties window for the selected clip. If multiple clips are 
selected, opens the Properties window for the first clip selected:

Selections and Region Selections

Selection Operations
Many  editing operations in Pyramix can only be carried out if a clip or region is selected.

There are two ways of selecting material in the timeline. Whole Clips and Regions. 

Clip Selection

Clicking in a clip selects it (the color becomes darker and Handles appear). The whole clip is 
ready for editing. Clicking on other clips while holding down the Shift key adds them to the 
selection.  If the clip is grouped with other clips, this will select the entire group. To select a sin-
gle clip in a group,  first ungroup the clips, then select the desired clip.
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Region Selection

A Region Selection is a selected area of the Composition. A Region can include many clips on 
many tracks or only a portion of a single clip. It is indicated as a darker gray rectangular area 
over one or more Tracks. When selecting a clip within a group, the Region is automatically 
extended to the whole group. This can be avoided by pressing the Shift key while selecting. A 
Region can be made by clicking and dragging the mouse across one or more Tracks.

Of course, keyboard shortcuts exist for making Regions, and this is one of the most useful ways 
to mark a region. The Pyramix default method of marking a Region in point is to press [ on the 
keyboard: this selects everything to the right of the current Play Head Cursor location on the 
currently selected track. ] marks a region out point: this selects everything to the left of the cur-
rent Play Head Cursor location, up to a previously marked in point. Once a Region has been 
defined in this manner it can be extended or ‘grown’ across more tracks by using Ctrl +Shift 
+Cursor UP or DOWN arrows. Ctrl +Alt +Shift +Cursor UP or DOWN shrinks. (Assuming the 
standard Pyramix keyboard shortcut assignments are in use.)

Using the keyboard short-cuts, Regions can be easily made on-the-fly while playing or scrub-
bing the Timeline. This is particularly efficient when used in conjunction with the Numerical 
Keypad transport control short-cuts.

Dragging Clips into a Composition
The simplest way to place an audio clip into your Composition is by dragging it from a Media 
Drive or Library. To drag from a Media Drive:

1. Click on the Media Management Tab in the to open the Project Management Panel Media 
window.

2. Under the Media list in the window, click on a mounted Media Drive or subfolder to select 
it. It will turn dark blue. The Master Clips contained in that Media Drive will all be listed 
on the right side of that window.

3. Select a Master Clip from the right side by clicking on it with the left mouse button. It will 
turn dark blue.

4. Drag that Master Clip into a Track. You can place it into any Track, at any point on the 
Track.

The procedure for dragging a clip from a Library is virtually identical to that outlined above for 
Media Drives. However, access the Library using the Global Libraries or Document Libraries 
Tabs in the Project Management Panel.

Copy and Paste
Another way to get Master Clips into a Composition is by copying and pasting them.

1. Select a Master Clip in a Media Drive or Library.

2. Right-click on the Master Clip, and choose Copy from the pop-up.

3. Place the Play Head Cursor where you want to paste the beginning of the Master Clip.

4. Right-click on the Track to which you wish to place the clip, and choose Paste to Cursor 
from the pop-up. The beginning of the clip will be placed at the Play Head in the Track on 
which you right-clicked. Alternatively, simply click the mouse on the track and at the time 
you want the clip to start, right -click and choose Paste to insert the clip where you placed 
the mouse cursor.
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Selecting a Clip
Click on any clip in the Composition to select it. It will change color to indicate selection. Shift-
click to select multiple clips at the same time.

Simple Copy and Paste
1. Left-click a clip to select it.

2. Right-click and choose Copy from the pop-up. (or use menu Edit > Copy or use Ctrl + C)

3. Place the Play Head Cursor where you want to paste the beginning of the Master Clip.

4. Right-click on the Track to which you wish to place the clip, and choose Paste to Cursor 
from the pop-up. (or use menu Edit > Paste to Cursor or use Ctrl + V). The beginning of the 
clip will be placed at the Play Head in the Track on which you right-clicked. Alternatively, 
simply place the mouse cursor on the track and at the time you want the clip to start, right-
click and choose Paste to insert the clip where you placed the mouse cursor.

Selecting a Region
To select a region, click the mouse at one end of the region you wish to select, and drag the cur-
sor to the other end of the region you wish to select. A region can include more than one clip, 
and may extend across multiple tracks. The selected region may also include the area on a track 
where a clip may not be present. Discontinuous regions cannot be selected.

Clip Selection Behavior
The following lists the various behaviors for a selected clip depending on different modifier 
keys.

When a Clip is selected:

No Modifier Key

With no key modifier, the clip can be manipulated in standard Edit Mode.

CTRL Key Modifier (Auto Crossfade Mode)

While a clip is selected, pressing and holding the CTRL key before clicking and dragging auto-
matically creates a cross-fade when the clip is moved to overlap any adjacent clip. The mouse 
cursor changes to a hand with an X over it to indicate Auto Crossfade Mode is engaged. While in 
Auto-Crossfade Mode selected clips can only be moved in time, not to other Tracks.

CTRL Key Modifier Option (Layering Mode)

When in the CTRL Crossfade mode, if the CTRL Key is released (while still holding the left-
mouse button) Layering Mode is entered. This mode allows clips to be overlapped. (Techni-
cally, the result is a crossfade with zero length fades.)

CTRL SHIFT Key Modifier (Slip Media Mode)

While a clip is selected, pressing the CTRL and SHIFT keys will allow the audio contents of the 
clip to be slipped in time. The Media can be slipped to the extent of its availability.
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CTRL ALT Key Modifier (Slip Clip Mode)

While a clip is selected, pressing the CTRL and ALT keys will allow the In and Out point of the 
clip to be slipped together in time while the Media remains where it is in time. Think of this as 
moving a "window"  within the media.

ALT SHIFT Key Modifier

While a clip is selected, pressing the ALT and SHIFT keys will allow the clip to be dropped into 
a Library as a new Composition.

Auto-Crossfade By Default
Auto Crossfade / Layering can be set as the default editing mode. This reverses the functional-
ity described above. When this mode is engaged, pressing the CTRL key enables the Edit mode.

This mode can be engaged  by selecting Edit > Auto-Crossfade or by checking  the Auto-Cross-
fade by Default box in the Editing page of General Settings.

Clip Fade Commands
Fade In

Fade Out

X Fade Each of these three entries on the Clips menu lead to sub-menus which all 
look like this:

New Creates a fade when a region is defined at the beginning (Fade 
In) the end (Fade Out) or across overlapping clips (X Fade)

Edit When chosen from either the Fade In or Fade Out sub-menus, 
opens the Fade Editor with the current fade. From the Cross Fade 
sub-menu opens the Fade Editor only when a region is defined 
across an existing cross fade. (Please see: Fade Editor  on 
page 125)

Default When a clip is selected or a Region is defined which includes the 
clip start or end, Fade In or Out > Default > Complete recalls the 
length and shape of the Default Fade In or Out and applies it to 
the selection.Default > Curve Only recalls only the curve shape. 

When a region is defined on a clip or clips which are cross-
faded X Fade > Default Complete or Curve Only recalls and 
applies the Default Crossfade length and shape or shape only 
respectively.
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Editing Modes
The current Editing Modes are shown at top left of the Editor Window. If either Remove, Insert 
or Snap modes will result in rippling of other clips. I.e. loss of sync, the Editing Modes are 
shown in Red Some of the editing commands which delete clips from, or paste clips into the 
timeline behave differently depending on the current settings of the Insert mode and the 
Remove mode. 

Splitting Clips and Regions

Splitting a Selection
Splitting Clips

Edit > Split (or Ctrl + T) makes an edit on the selected clip(s) at the cursor position splitting it 
(them). If a region is defined within a clip or clips then this region is Split (edited) by using this 
command. Each split portion of the original clip(s) now becomes a new, independent clip in its 
own right.

Splitting Regions

If the Play Cursor is positioned over a selected Region rather than a whole clip or clips, then 
choosing the Edit > Split  command will split the selected Region from the surrounding mate-
rial at the edges of the selection area, not under the Playhead Cursor.

Once a Region is marked on a clip, simply clicking on the Region makes an edit. (same effect as 
the Edit > Split menu command.) This will split the clip or clips at the region boundaries. If a 
Region is across several Tracks,  Edits will be made on all Tracks within the Region.

Cutter
Holding down the C key changes the mouse pointer to a cutter. Edits (cuts) are made wherever 
the user clicks. To make an edit with the cutter on a range of clips at the same position, just select 
them before cutting.

Duplicate Selection
Holding down the D key while clicking on the selection then dragging to a new location dupli-
cates the selected material and moves the copy.

Holding down the F key while clicking on the selection then dragging to another track (or tracks 
if the selection covers more than one track) duplicates the selected material and moves the copy 
locked in time.

Moving a Selection
Simply drag a selected clip move or reposition it to another location on the same track or a dif-
ferent track. If a Region is selected, clicking on it will  split it from the surrounding material. The 
resulting separate clip can then be dragged to a different location or track. To constrain a clip in 
time when moving it to another track, hold down the Alt, Shift and Ctrl keys at the same time 
while dragging the clip to the new track.

Adjusting a Region Selection
Simply position the Arrow Cursor at the edge (beginning or ending) of the region. The cursor 
will change shape to indicate the Region can now be adjiusted by clicking and dragging. You 
may drag the edge beyond the other end of the region. Doing so ensures that the new selection 
region begins (or ends) exactly where the original region ended (or began). This also applies to 
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the top and bottom edges of the region. For example, you can extend the selected region on one 
track up or down to include additional tracks.

Edit Command highlights:
Further Editing commands are to be found on the main Edit menu. Please see: Menus - Edit 
menu  on page 226

Undo Pyramix keeps track of all edit decisions and operations so they can be 
undone if necessary. This menu item shows the name of the last operation. 
To undo this operation, simply click on the Undo(operation) menu item and 
the listed operation will be undone. Whenever an item is undone, it immedi-
ately shows up as the most recent item in the Redo list.

Undo History Pyramix keeps track of the most recent edit decisions and operations and 
shows them here in a sub-menu. These are listed from the most recent at 
the top, to the oldest at the bottom of the list. To undo a whole block of oper-
ations, click on the name of the oldest operation and everything since that 
time (from that point in the list to the top of the list) will be undone. The name 
of the next operation in the list will be shown as the next Undo item, and all 
the items that have been undone are immediately added to the Redo His-
tory list. The size of the undo history is set to 32 steps by default, but it can 
be adjusted in the Settings > General Settings : General page.

Redo If an operation has been undone using the Undo commands in this menu, 
the most recently undone operation will be shown here. To Redo the opera-
tion, simply click on Edit > Redo and the operation will be Redone. When-
ever an item is Redone, it immediately shows up as the most recent item in 
the Undo list in this menu. The next edit operation carried out in Pyramix will 
then purge this item since the operation could cause a conflict with previous 
operations and therefore renders the Redo invalid.

Redo History Pyramix keeps track of the most recent operations that have been undone, 
and shows them here in the Redo History sub-menu. To Redo a whole 
block of operations, click on the name of the oldest operation and everything 
since that time (from that point in the list to the top of the list) will be Redone. 
The name of the next operation in the list will be shown as the next Redo 
menu item, and all the items that have been Redone are immediately added 
to the Undo History list. The next edit operation carried out in Pyramix will 
then purge this list since the operation could cause a conflict with previous 
operations and therefore renders the Redo list invalid.

Delete This command deletes the selected clip or region. When a selection is 
deleted, other material on the track behaves according to the current 
Remove mode setting.

Cut Cuts the current selection from the project and places it on the Clipboard. 
When a Selection is Cut, other material on the track behaves according to 
the current Remove mode setting.

Copy Copies the current selection from the project and places it on the Clipboard

Paste Inserts the contents of the Clipboard starting on the track and at the time the 
mouse cursor is when Paste is invoked. When the contents of the Clipboard 
is Pasted, other material on the track behaves according to the current 
Insert mode setting.

Paste to Cursor Inserts the contents of the Clipboard at the current Playhead Cursor posi-
tion. When the contents of the Clipboard is Pasted, other material on the 
track behaves according to the current Insert mode setting. 
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Paste & Place Opens the Placement Tool with extensive placement options. Please 
see: The Placement Tool  on page 48

Paste to Original TC If the Clipboard contains a single clip, insert this at its original TimeCode *

* Note: Paste to original Timecode works differently with clips and Range Selections. If the 
Clipboard contains a single clip this will be pasted to its original time code. If the Clipboard con-
tains more than one clip or a selection of a clip or clips this will be pasted to the time code at the 
beginning of where the selection was made on the next track(s) where there are no clips which 
would be overwritten.

Paste to Selection Inserts beginning of contents of Clipboard to end of current selection

Paste & Fit Inserts clip from Clipboard stretched or shrunk to fit selected region. 
Requires the optional Timezone Time compression / expansion plug-in. If the 
contents of the Clipboard cannot be stretched or shrunk sufficiently to fit the 
Paste & Fit command will be grayed out like this:

Cut and Ripple Cuts the current Selection and places it on the Clipboard forcing a Ripple to 
occur on all affected tracks.

Paste and Ripple Inserts the contents of the Clipboard to the mouse cursor position forcing a 
Ripple on all affected tracks.

Paste to Cursor and Ripple Inserts the contents of the Clipboard at the current Playhead Cursor position, 
forcing a Ripple on all affected tracks.

Insert Silence Inserts silence (blank space) into the current selection, forcing a ripple on all 
selected tracks.

Stretch Opens the optional Prosoniq Multichannel Time Stretch plug-in window.

The Increment and Decrement buttons allow the In point, Out point or Length of the selection to 
be adjusted. The Ratio of stretch or squeeze is shown as a percentage. Clicking the OK button 
starts the process. Cancel aborts.

Normalize Examines the selected clip or clips to find the highest peak, then increases 
the overall gain of the clip so that this reaches maximum level. All other 
selected clips are raised in level by the same amount.
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Consolidate Opens the Consolidate Project window. Please see: Consolidating 
Projects  on page 207

Waveform Leads to the Waveform sub-menu:

Follow Track Clip displays whatever is selected for the entire Track.

Force Waveform Clip displays Waveform regardless of the overall Track setting

Force Name Clip displays Clip Name regardless of the overall Track setting

Auto Silence Removal
Edit > Automatic Silence Removal

Automatic Silence Removal operates by scanning the Selection and then automatically editing it 
into smaller clips by removing regions which fall below the threshold level and meet the ‘Mini-
mal Sound’ and ‘Silence’ criteria set in the Automatic Silence Removal window

.

Note: This function is non-destructive of the Media file - it edits the clip by breaking it up into 
smaller clips, not by deleting any actual audio from the hard drive.

Threshold [dB]

This field determines the threshold level in dB below which material in the clip will be removed. 

Minimal Silence [ms] / Minimal Sound [ms]

Sets the shortest periods of silence and sound which can be created by removing material that 
drops below the threshold. Some audio material (E.g. speech) contains very short gaps. If all of 
these were removed, the audio would become too "chopped up". On speech the object of the 
exercise is usually to break it into areas where speech is present not remove small gaps between 
words or sentences. Some audio material may have very short transient peaks in the midst of a 
segment that falls below the threshold. If all of these short transients were created as clips the 
end result might well sound worse than the original.

The minimum setting is 10 ms and the maximum is 5000ms (5 seconds).

Fade Out [ms] / Fade In [ms]
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Sets the length of the automatic Fade Out and Fade In that will be applied to all new clips cre-
ated by the Automatic Silence Removal operation. The range for this setting is between 5 ms 
and 500ms (1/2 second).

Once the parameters have been set, click OK.

This process takes into account the current Remove Mode to determine whether to leave gaps 
between the newly created clips, or to join or ripple the clips on the track together.

Note: Automatic Silence Removal cannot be executed on cross-faded clips.
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The Placement Tool
Although the Placement Tool remains an extremely flexible paste option most important oper-
ations are directly available as single commands in the Edit menu. All these commands can be 
mapped to a keyboard key or included in a macro. In most cases, this is a far more efficient way 
to work.

Several different placement options for a Paste action can be chosen from the Edit menu or from 
the pop-up menu which appears if there is something to be pasted and the cursor is over a track 
when you right-click E.g. Paste to Cursor. 

Open the Placement Tool window by selecting Paste & Place... from the right-click Paste 
options above, or choose Edit > Paste Place from the Edit menu.

The Placement Tool window allows the user to customize the placement of a clip in extremely 
powerful and flexible ways. 

The button layout corresponds to the numeric pad on a standard keyboard.

.Select a Paste Place action by choosing amongst the sequence of lit buttons in the window.

For example, you could choose to Send the Sync Point of a clip to a typed Time Code location 
on a Destination Track chosen from a pop-up list; or you could Send the Tail of a clip to the 
Play Cursor. Nearly every permutation of placement is possible. Whatever action you choose, 
the results of your choices will be displayed as text in the lower-right corner of the window 
before you choose to Do It!

Remember to choose an Insert Mode to determine how the surrounding clips will be adjusted 
when the new clip is placed in the Track.

For full details of all the possible modes and actions, please see the Pyramix Reference Guide.
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Markers or User Flags

Pyramix Virtual Studio allows for setting named and numbered User Flags or Markers at user 
defined points in a Composition. Markers can be used as convenient reference points for notes 
or other text, or as locations for Paste operations.

To Set a Marker, press Ctrl-Shift and click anywhere along the Time Scale bar. The Marker will 
appear as a small blue flag with a number in it. Markers are numbered consecutively in the 
order in which they are added. You can also add a Marker at the current Play Head Cursor posi-
tion by choosing Cursors & Marks > Add Marker to Playhead from the Toolbar.

Markers can be selected by clicking on them. The Marker flag turns red to indicate it is selected. 
Shift-Enter moves the Playhead Cursor to the selected Marker

Use the Markers Tab in the Project Management Panel to view, name, GoTo and otherwise 
manage previously created Markers.
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Using the Mixer

Mixer Components

Basic Strip
A basic mono channel strip contains:

Output bus send level / pan pot and On /Off switch. The number and type of 
these is dependent on the number and type of busses specified. Here there is just a 
single stereo mix bus.

Numeric display of held peak level value if fader is at unity, otherwise shows 
fader position value and may be clicked to directly enter a value. If cursor is over 
pan pot shows current pan position.
Graphic display of held peak level value.

Level Bargraph 

Rotary Controls and Faders
Rotary Controls and Faders may be adjusted by grabbing them with the mouse 
and dragging. Rotary controls are adjusted by dragging left or right and faders by 
dragging up or down. Double clicking a Fader or Rotary knob returns the value to 
the default. E.g. unity gain on a channel strip fader.

Buttons
Buttons on the main mixer surface are grey and appear to stand proud of the sur-
face when inactive. When active they ‘light up’ and appear to be flush with the 
surface.

Delay
A delay value can be set in this box.

Physical Input Assignment
Right-click on the XLR icon to pop-up a drop down list of valid assignments. (When in Config-
ure mode)
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Show / Hide
The small, grey arrows on the right of the mixer surface toggle horizontal areas of the mixers 
surface visible or hidden. Show / Hide can reduce clutter by concealing unused controls. This is 
the same mixer with all areas hidden:

Show/Hide

Show/Hide Effects

Show Hide Gain

Show Hide I/O

(Fader)

Stereo Mix 

Show/Hide Mute etc.
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Creating and Configuring Mixers

If one of the numerous mixer presets does not quite suit your application it is simple to modify 
an existing mixer, create one using the Mixer Wizard or design one from scratch. The Wizard 
can be started from an existing mixer by right-clicking anywhere on the mixer surface and 
selecting Mixer > Settings > Wizard... Please see also: Mixer Wizard  on page 28

I/O Busses Explained
The total number of available output busses, regardless of the number of Mykerinos cards, is 64. 
The maximum number of inputs to Pyramix is also 64. However, it is perfectly possible, and 
permissible, to have more than 64 physical inputs and outputs connected to a Pyramix system. 
The PS3 Control Panel Application acts as a router to assign physical inputs and outputs to 
Pyramix logical inputs and outputs. For example: a system containing two Mykerinos boards, 
one with a MADI daughterboard, one with an AES/EBU daughterboard has a total of 56 inputs 
and outputs on the MADI board (64 if MADI X is used) plus 24 channels of AES/EBU. Possible 
total 88. Any 64 of these may be routed to Pyramix inputs and any 64 Pyramix outputs (less the 
number of assigned Internal Return Busses; see below), can be routed to physical outputs.

Internal Return Busses
Some of the time slots on the HDTDM bus can be reserved to convey Aux or Master Output 
Busses back to input strips. In effect, these are internal send/return paths. To change the num-
ber of available Internal Return Busses, close Pyramix (if open) and launch the VS3 Control 
Panel Application. The number of Internal Return Busses can be set using the drop-down list 
box on the right of the screen. Click on the OK button to memorize the setting and exit the Win-
dow.

The number of Internal Return Busses you assign here will be available as possible channel 
strip sources in the mixer.

Input Strips
Input strips have the same function as the input strips of any standard mixing console provid-
ing level control, pan, mute, etc.

The following types of input strips are available:

• Mono input Strips

• Stereo input Strips

• MS decoder Strips - decode a Sum and Difference signal to standard stereo format

Groups
Master Group Strips - allow the grouping of faders of several mixer strips. Analagous to VCA 
grouping. When a group or groups are added (from the mixer contextual menu Settings > Add 
Strip > Group) A group button for each group created will appear below the strip name box on 
each input strip. When selected, the associated Group strip will control the grouped input strips 
if the On button is lit on the Group strip.

Mixing/Monitoring/Aux Buses
These are the summing buses where signals from the mixer input strips can be routed to.
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Mix Bus
A mix bus is the destination for the final product of your mix. The outputs of a mix bus are usu-
ally routed to a master machine to record the final mix. They can also be routed via Internal 
Return Busses. This enables the final mix to be recorded in Pyramix.

Mix Buses are available in several formats:

Mono Mix

Provides a single mono output. Any input strip can be routed to it.

Multiple Mono Mix 

Provides several mono outputs. Any input strip can be routed to any or all of them

Stereo Mix

Provides a single stereo output. Any input strip can be routed to it

Multiple Stereo Mix

Provides several stereo outputs and allows any input strip to be routed to any or all of them

Surround Mix - 5.1 format

Multiple Surround Mix - provides several surround outputs and allows to route any mixer strip 
onto any of them.

Note: Unlike mono and stereo multiple busses, input strips can only be routed to ONE 5.1 desti-
nation of a multiple surround bus. This reflects their normal use. E.g. a common set-up will have 
three surround busses for Dialogue, Effects and Music Stems. A, B and C. Each Input strip is 
routed to the appropriate surround bus by clicking on the A,B or C selector buttons.

When the multiple surround bus is selected as the Surround Monitor Bus source (Its Select Mix 
button is lit) All three surround busses are summed for monitoring.

Multiple Mix Busses
When a mono or stereo multiple mix bus is added to the mixer a routing matrix box appears in 
the input strips with a send level control (mono) or pan control (stereo).
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The 8 by 8 matrix gives access to up to 64 output busses. Routing is shown by lit crosspoints. 
Double clicking the matrix opens the routing matrix window.

Valid choices are shown in gray. Once the window is open, other input channels can be route by 
either selecting them from the drop-down list or using the < and > arrows to step across the 
mixer surface.

Monitor Bus
A monitoring bus provides dedicated outputs connected to the control room speakers. It pro-
vides independent level control and non-destructive solo capabilities.

Mono, Stereo and Surround monitoring buses are available.

Note: The three types of Monitor bus function independently. Mono mix busses route to Mono 
Monitor busses when the relevant Select Mix button is lit. If there is more than one Mono mix 
bus (or Multiple Mono Mix Bus) is present the Select Mix buttons toggle the monitoring 
between the busses. Stereo and Surround Mix Busses work the same way. If no Select Mix but-
ton is lit, input strip signals are routed to all monitor outputs. I.e. if no Select Mix button is lit on 
any Surround Mix bus. A signal from a mono input strip will appear on all six Surround Monitor 
Bus outputs.

Aux Bus
Mono and Stereo Aux busses provide a way to create ‘auxiliary’ mixes which are normally 
used to provide headphone or cue mixes for musicians, or to send signals to effects such as 
reverbs, delays, choruses,etc. 

Dim Switch

The dim switch in Monitor Bus strips attenuates the Monitor Bus ouput(s) by 20 dB active.

Solo In Place/Mono Switch

Toggles between In Place (stereo) Solo when lit or Mono solo monitoring. (Mono and Stereo 
busses only)
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External Effects
Any Pyramix Bus can be routed to any physical output. Thus, an Aux can be routed via a physi-
cal output to an external effect. The output of the external effect is simply brought back into 
Pyramix via one of the physical inputs.

Configuring a Blank or Existing Mixer
Configuration of the mixer control surface is accomplished via contextual menus. The precise 
options available will depend on where you click on the mixer. If you wish to affect the entire 
mixer, right-click on the top bar of the Mixer window. To change options for a Bus, right-click on 
a blank area of the Bus strip. Similarly, for a channel input strip, right click on a blank area of the 
Strip. Right-clicking within a function block adds menu entries to the top of the list, relevant to 
the specific block.

Mixer Configure Mode
To alter the mixer configuration and I/O assignments Configure Mode must be turned on. 
Right-click anywhere on the Mixer window and select Configure. Note the XLR icons and num-
bers which appear near the bottom of each Input Strip and Output Bus.

Adding Strips
Once Configure mode is turned ON, (a tick appears next to Configure in the list) Input Strips, 
Output Buss and Group strips can be added to the mixer as required.
Right-click anywhere on the Mixer window, choose Strip > Add and select the appropriate type 
of strip to add or right-click anywhere on the Mixer window, choose Bus > Add and select the 
appropriate type of bus to add.

Removing Strips
To remove a given input strip, bus or group, right-click directly on it and choose Strip > 
Remove (Strip, Bus or Group) as appropriate.

Mixer I/O Assignments

To or from physical I/O
To change I/O assignments to or from physical I/O or the Internal Return Busses, click on the 
appropriate XLR icon. A pop-up appears with a list of all valid choices.

From tracks
Note that several tracks may be routed to the same mixer input strip. Tracks are assigned to 
mixer input strips either automatically or manually from the Track Header. See: Track Header 
Panel  on page 98
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Adding Plug-ins

Native Plug-ins
These include the eq and dynamics found on a conventional hardware mixer’s channel strip. To 
add a native plug-in right-click with the mouse cursor over the strip where the plug-in is to be 
added. If you right-clicked in the effects area of the strip select Effects > Add. If you clicked 
somewhere else, select Add Effect. Select an effect from the drop down list. It will appear in the 
strip.

Direct X Plug-ins
To add a Direct X plug-in the procedure is the same except select Direct X Plug-In or Add 
Direct X Plug-In.

Note: Plug-ins cannot be added to Monitor Busses and DirectX Plug-ins can only be added to 
Input Strips or used in the FX Rack. Please see: MTRFxRack  on page 209

Further Mixer Configuration Options

Mixer Context Pop-up menu
The entries on this menu vary according to where you right-click on the mixer surface. At the 
top of the menu the entries concern the specific mixer component under the mouse cursor when 
you right click. The next section of the menu has entries which affect the Strip. Entries from 
Mixer to the end of the menu affect the entire mixer and are available wherever the mouse is 
right-clicked.

Mixer > Show

Show All Makes all input strips and busses visible

Show / Hide > Selects Strips and Busses to be shown or hidden. When checked, the 
Busses or strips are visible on the console surface. Both Show and Hide 
access the same lists.

Minimize When checked, Mixer window is minimized

Automation >

Isolate These menu choices toggle the Automation mode for the entire 

Play mixer. Please see: Automation  on page 151

Record

Auto-write

Memory > The choices here enable mixer presets to be saved loaded and managed.

Please see: Storing and Recalling Mixer Presets  on page 58
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Settings >

General... Opens the Mixer Settings window Please see: Mixer Settings  on 
page 87

Enable Delay Compensation Enables Delay Compensation for the mixer

Dithering Opens the Dithering window. Please see: below and Dither  on 
page 204 for an explanation of the need for dither

Remove Select All Strips , All Buses or All to remove groups of mixer compo-
nents or every component.

Auto-connect Automatically connects the Mixer inputs and outputs using the available 
inputs and outputs of the installed daughter card (s) and the Mixers Pre-
ferred Monitoring Outputs

Wizard... Launches the Configuration Wizard. Please see: Mixer Wizard  on 
page 28

Show Distribution When checked, a narrow colored bar is inserted at the bottom of each input 
strip which indicates which card (in a multi-board system) is providing the 
DSP for the strip.

Configure Toggles Configure mode on / off

Dithering

To open the Dithering window, right-click anywhere on the mixer surface and select Settings > 
Dithering... The Dithering window opens. See below:

Word Length
The output word length of the digital audio data can be varied from 8 bits to 24 bits. Click on the 
rotary knob and drag left and right to adjust the value.

PDF (Probability Density Function)
In basic terms, the addition of a dither signal (noise) into the digital audio streams improves lin-
earity in the reproduction of low-level signals. In other words, as signal level drops (such as in a 
fade out) dithering helps to maintain a smooth decay. There are three options:

None

No dither signal will be added to the data.

Rectangular

A rectangle shape dither signal will be added to the data.

Triangular
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A triangle shape dither signal will be added to the data.

Noise Shaping
Noise shaping is a technique that is used to push quantization noise energy, which in linear dig-
ital systems is normally spread over the whole audio spectrum (0 Hz up to half the sampling 
frequency), into higher frequencies where the human ear is less sensitive to its effects. There are 
three noise shaping options:

Off 

No noise shaping added.

Hi Pass

This provides a first-order high-pass filter for the noise transfer function. This type of noise 
shaping takes little computational power to produce, but at the expense of not tracking the 
characteristics of the human ear very accurately compared to:

Acoustic

Psycho acoustically noise shaped dither inserts an FIR-filter in the feedback path. This shapes 
the noise as closely as possible to the characteristics of the human ear. More taps in this type of 
filter allow a closer approximation to the response curve of the ear, but each tap, of course, 
increases the computational instructions required. The filter implemented here is a 9-tap FIR-fil-
ter, which closely approximates the curve of the human ear.

Channel Direct Outputs
.It is a simple matter to add a Multiple Mono Mix Bus with up to 64 outputs. The Bus outputs 
can be routed to physical outputs and the routing button matrix in the channels strip can be 
used in a one to one correspondence so that Channel 1 goes to Bus 1 of the Multiple Mono mix 
Bus, Channel 2 goes to Bus 2 and so-on. Outputs from these busses can be routed to physical 
outputs as required.

Storing and Recalling Mixer Presets
Mixer Presets can be saved in a user folder or added to the main Mixer Preset list either for the 
current user or all users.

Default Mixer
To Save the current Mixer setup as the default Mixer, right click on the Mixing Console and 
select Memory > Presets > Store > Default.

Storing New Mixer Presets
To add a preset to the main list of available Mixer presets I.e. the list which appears when start-
ing a new project, right click on the Mixing Console, select Memory > Presets > Store > New… 
and enter a name for your Mixer Preset. If the Global check box is checked then the preset will 
be available for any user logged on the current machine, if not the preset will be available only 
for the user that created the new preset.

Removing Mixer Presets
To remove a preset from the main list, right-click on the Mixing Console, select Memory > Pre-
sets > Remove > (preset you wish to remove). The Remove Preset window appears with OK 
and Cancel options.
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Saving / Loading Mixer Presets
Mixer Presets can also be stored in Windows folders. Right-click on the Mixing Console, select 
Memory > Save. A Windows Explorer window opens enabling the current Mixer Preset to be 
named and saved to any Windows folder. Similarly, selecting Memory > Load enables a Mixer 
Preset to be loaded from any Windows folder.

Mixer Surround Components
When a Surround Bus is added to the mixer an surround panner appears at the top on the Input 
Strips

Speaker Controls
Double-clicking on any of the Speaker Controls toggles the mute on/off of the selected surround 
channel (also muting any audio routed to that surround channel output). When a channel con-
trol is muted, it is no longer displayed on the Mixer Input Strip.

Joystick Panner
Determines the position of the source within the surround sound space. To position it, simply 
left-click on the control and move it to the desired location. Doubleclicking on this control will 
automatically center it.

Sub Level
Determines the level sent to the Sub (.1) output.

Surround Bus select
If a Multiple Surround Bus has been added to the mixer Select buttons appear here. The same 
number of buttons as there are busses. The buttons toggle between the busses.

Destructive Solo
Solos the input. Will affect the main Surround bus output.

Front Speaker controls

Joystick Panner

Rear Speaker controls

Sub Level

Destructive Solo

Surround Bus Select

Open Surround Control
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Stereo Input Strips
The Surround Sound Panner Position control behaves slightly differently in a Stereo Input 
Strip.

Notice there are now two independent position controls and two independent Sub sends. One 
for each input channel.

Open Surround Control
The Surround Control window offers far more information and a greater degree of control over 
all the surround panning parameters than could be shown on an individual Input strip.

Surround Control window

Options available will depend on whether the Mixer Channel is single source (mono) or 2 
sources (stereo). For an indepth description of all the functions please see the Pyramix Refeence 
Guide.
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Position/Speaker Control
When a single source is used, the Position Control is displayed as a green dot on a grid with 5 
speaker icons. Each speaker icon represents a Surround Speaker Position (L, C, R, SL, SR). The 
position of the Green Dot determines the position of the source within the surround sound 
space. To position it, simply left-click anywhere within the surround sound space. To position it, 
simply left-click on the control and move it to the desired location. Double-clicking on the Green 
Dot automatically centers it. 

Surround Panning Algorithm
The drop down list gives a choice of panning algorithms.

Constant Gain

Allows the surround panning to preserve a constant gain sum on all speakers wherever the 
Position Control is placed.

Constant Power

Allows the surround panning to preserve a constant power sum on all speakers wherever the 
Position Control is placed.
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Configuration - Program and Project Settings Windows

All three main settings windows can be found in the Settings menu.

General Settings is used to set parameters of the Pyramix Virtual Studio environment.

Information and Settings relates to the current Project.

Mixer Settings relates to the current Mixer.
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General Settings

Selecting Settings > General Settings from the pull-down menu in the main window opens the 
General Settings window with the default General tab window open.
This window contains a number of Tabs which enable general Pyramix Virtual Studio configu-
ration.

General Tab

Platform
Audio processing

The drop down list, offers a choice of which audio device to use with Pyramix. The available 
choices are Mykerinos Card or Native Processing. I.e. the computer’s host processor(s) & sound 
card, if you have purchased this option.

Undo
Number of Undo / Redo

Sets the Number of Undo / Redo levels. The default is 32.

Note: Increasing this value uses more RAM.
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Auto-Saving
Pyramix can be set to automatically save a backup copy of the current project at regular inter-
vals. This does not overwrite the existing saved Project File, but creates a temporary backup file 
which will be used only if there is an error or system crash before the project is properly closed. 

Enable

When checked the current Project will be automatically saved at the interval set by:

Auto-Saving. Frequency

Sets the time between saves between 1 and 60 minutes. 

Number of Versions 

Determines how many previous versions will be kept.

Alternate Backup
Enable

When checked, Project files will also be backed up to an alternative location each time they are 
saved. This offers increased security if another drive or network drive is chosen. 

Note: only project files are stored into this directory, not the media files.

Location

Displays and sets the alternative location.
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Editing

Nudge settings
These settings control the amount by which a cursor or clip will be nudged when using the 
leftand right Arrow keys. Five Nudge Settings can be stored. Any one of these can be selected as 
the current nudge setting using Clips > Nudge > Current Setting or Cursors&Marks > Current 
Nudge Setting. 

Nudge #1~Nudge #5

For each nudge preset, enter an numeric value and click the appropriate check box to set incre-
ments to frames, samples, milliseconds, CD frames or the current Bars & Beats grid.
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Audition after Nudge
These options set automatic Audition on for the selected actions.

To

When checked, the playback will start before the selected option and stop when this is reached 
(cursor, mark in or mark out) 

From

When checked, the rehearse will be performed from the selected option (cursor, mark in or 
mark out)

Seperate To and From options are provided for Gate In and Gate Out

Drag & Drop
Auto-Crossfade by default - Control key for Drag & Dr

When checked, dragging a selection or clip over another results in a crossfade. (Cursor changes 
to a hand with an X.) Otherwise, dragging a selection or clip over another overwrites it. (Cursor 
is a hand) Holding down the control key when dragging selects the alternate function.

Fade library location
This is the path for the fade library. The Browse button launches an Explorer window allowing 
any local or network path to be set.
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Playback

Pre/Post Roll Settings
Allows values to be set for the Default and two alternative Pre and Post-roll settings.

Fixed Cursor Settings
The drop-down list offers nine possible positions for the Playhead cursor position on screen 
when scrolling Timeline with fixed cursor is selected. (View > Fixed Cursor while playing)
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Playback Stall
When checked, interuptions to playback will pop-up a message box.

Playback Buffer
Buffer size may be set by typing in a value or by clicking and dragging the slider. Click Set to 
accept the new value or Reset to return to the default value.

Record Block Size
Offers a choice of four possible values. Should be left at the default 64kB in most circumstances.

Automatic Deglitching (Removes glitches at start / end of Clips)
When Enable is checked, a short fade is applied to the start and end of every clip. Ramp Length 
sets the fade duration.

Auto-Monitoring
Toggles between two options 

European Monitoring (All tracks turn to INPUT on stop) or 

US Monitoring (Only Record Ready tracks turn to INPUT on stop)
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Layout

Timeline settings
Waveform follows fades

When checked (enabled) the waveform display is scaled in height during fades and crossfades. 
The original waveform is shown grayed out.

Generate waveform automatically at clip insertion

When checked (enabled) a waveform file is automatically generated for any clip which does not 
already have one when it is placed on the Timeline.

Absolute Sources in EDL view
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Split Editor Vertically

Check this box when using a dual monitor set-up to enable the Timeline to be displayed on one 
screen and all Tab Windows on the other one.

Clip Colors

Shows the current choices for:

• Standard Background Color

• Standard Waveform Color

• Bad Take Background Color

• Bad Take Waveform Color

Clicking on any of the color blocks opens a color picker.

Tool Bars

Toolbars with checked boxes will be displayed on screen.

Locations

Default Projects Location
This path is set when a new Project Workspace is created. It can be changed here either by typ-
ing the path into the box or browsing the Windows filing system using the Browse button
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Default Templates Location
This path is set when Pyramix is installed. It can be change here in the ways described above.

Permanently Mounted Media Folders
Shows a list of Media Folders available to all projects. Clicking Add opens the Choose a Media 
Folder to Mount window. Here you can browse for Folders or create new ones.

Folders are removed by highlighting their list entry and clicking the Remove button.

Time Code
If you are using the TimeCode input /output features of Pyramix, select the TimeCode Tab to 
configure the system. Time code Format, Reference and Source. If an external time code source 
has been physically connected to the Pyramix linear time code or video inputs, you should see 
the current value in the LTC or VITC Reader registers.
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General
These are the general settings on which all other time code parameters are based.

Format

Shows the current timecode format selected from the drop-down list. Pyramix supports the fol-
lowing formats: Film 23.98 fps, Film 23.98 fps Drop, Film 24 fps, PAL 25 fps, NTSC 29.97 FPS, 
NTSC 29.97 fps Drop, SMPTE 30 fps, SMPTE 30 fps Drop.

Reference

The Reference drop-down menu sets the timecode source when TimeCode is selected as the 
digital audio Sync Source in Settings > Mixer Settings : I/O page Sync Source.

The Reference pull-down list allows for choosing between clocking the system's audio engine to 
an Internal reference derived from the audio board's time code generator chip, or a clock 
derived from the time code input port on the optional Video/TC interface. To set the digital 
audio word clock source, see the I/O panel in the Virtual Studio Settings window.

TC Source

Shows the source of time code that will be used to synchronize Pyramix playback or to generate 
the timestamp when an audio file is digitized. Adrop down list offers the following choices: 

Internal uses the code from the internal time code chip on the audio board.

VITC uses code from the Vertical Interval Time Code (VITC) input on the optional Video/TC 
interface bracket / breakout cable.

LTC uses the Linear Time Code (LTC) input on the Video/TC interface bracket to derive

Auto Pyramix automatically uses any valid time code location reference from an Internal, VITC, 
LTC or External time code source.

External uses the code from the External TC reader source.

External TC reader
Shows the current value of the External Time Code reader. The drop-down list offers a choice of 
Virtual Transport and all external machines installed and enabled in Settings > General Set-
tings : Machines page.

LTC reader
Shows the current value of the Linear Time Code (LTC) reader chip. I.e. the external LTC input.

LTC Generator
Mykerinos boards have a Linear Time Code generator .

Output Level (dBV)

Shows the current LTC output level in dBV. The drop-down list offers a choice of output level 
from -24dBV to +9dBV in 3dBV increments, or it can be switched Off.

Off when stopped

When checked Pyramix mutes the LTC output when stopped. If not checked, it continues to 
output it’s actual position. (static TimeCode) Certain video and audio machines cannot handle 
static TimeCode.
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VITC Reader
Mykerinos boards are capable of reading Vertical Interval Time Code encoded in a lines of a 
video signal. VITC has the advantage of being accurate and readable even when the video is sta-
tionary.

Video Input

These check buttons allow the choice of which of the two video inputs will be used for the VITC 
signal.

Line

Show which lines will be decoded. Although VITC code fits into a single line, it is normally 
duplicated to provide redundancy reducung read errors. The drop-down lists allow any two 
lines to be chosen. Different pairs of lines often carry different code. E.g. Time-of-day and Abso-
lute time.

VITC Generator
Mykerinos boards have a Vertical Interval Time Code generator.

Enable

When checked the output of the VITC generator is On.

Video Output

These check buttons allow the choice of which of the two video outputs will be used for the 
VITC.

Line

Show which lines will contain VITC.

Chasing
Stabilization period before locking

Although Pyramix is capable of locking to incoming timecode within 3 - 4 frames, there are cases

where synchronization is more stable if there is a longer waiting time. This is because some 
external devices take a considerable time to stabilize their speed after playback is started. This 
parameter allows a waiting time to be defined before Pyramix will start chasing the timecode.

30 frames is a good starting point if you experience problems with external machines.

Silent Chasing (helps large projects to lock)

When checked Pyramix allows large projects to lock immediately while chasing. In this mode 
locking time does not depend on the number of tracks. The drawback is that sound only appears 
one second after a lock is established.
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Video
If you are using the video sync input/output features of Pyramix, select the Video Tab to con-
figure the video standard or format (e.g. NTSC, PAL or one of the supported HD formats). You 
can also enable or disable a visible time code burn-in window on the Pyramix video output for 
standard PAL / NTSC formats.

General
These controls are for setting the general format of the Video Sync signal.

Format

Shows the current video format. The drop-down list offers a choice of PAL, NTSC and a wide 
variety of TriLevel HD (high-definition) formats.

Burn-in Window
Mykerinos boards can burn-in a Time-code display window into a composite video input sig-
nal.

Enable

When checked the timecode overlay is displayed

Color

Shows the current display scheme. The drop-down list offers a choice of:

• White on Black

• Black on White

• Black on Background
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• White on Background

Large

When checked the timecode display will be the larger of the two possible sizes.

Head Switch Filter

When checked, the clamp circuit ignores head-switch transients and horizontal sync during the 
last six to seven lines before the vertical front porch. Otherwise, the clamp circuit responds as 
always.

Burn-in Location

Simply drag the video burn-in window to the desired location within the color bars screen.

Boards & Keys

Information only. Nothing can be changed here. Shows the Mykerinos board serial number(s), 
the user Name and Company the software is registered to and the Keys which are validated.
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Machines

The following machines are installed: 
Displays a list of all installed machines. Machines in this list will be available as possible 
machine choices in the Transport Control. 

Add

Clicking on the Add button opens the Machine Properties window (see below)

Remove

If a machine is selected (highlighted) in the list, clicking Remove uninstalls the machine and 
removes it from the list.

Properties

Clicking on the Properties button opens the Machine Properties window (see below)

OK

Click OK to accept changes (if any) and close the Machines page.

Cancel

Click Cancel to reject changes (if any) and close the Machines page.

Apply

Click Apply to apply changes without closing the Machines page.
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Machine Properties

When the Machine Properties window is opened by the Add button, the Name, Protocol and 
Port displays are blank. When the window is opened by the Properties button the displays 
reflect the name etc. for the selected machine.

Name
Displays the name of the current selected machine. When adding a new machine, type a suitable 
name here.

Protocol
Displays the current interface protocol from the choice of MMC (MIDI Machine Control) or 
Sony (9-pin P2 protocol) in the drop-down list.

Properties

Opens the Sony 9 - Pin Protocol Configuration window (see below) when SONY is selected. 
There are currently no options for MMC

Port
Displays the current Port used for machine control from the choice of COM422 or MIDI in the 
drop-down list.

Settings
Inhibit Video Record

When checked prevents record arming of video in order to ensure video cannot be accidently 
overwritten.

Pre Roll

Shows the current Pre Roll time for the external machine. Type in the box to change the value.

Post Roll

Shows the current Post Roll time for the external machine. Type in the box to change the value.
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Port Properties

Sony 9 - Pin Protocol Configuration

TimeCode Request
The radio buttons select the source of the timecode from the external machine. Sony machines 
usually respond to all requests, so the Auto setting will probably be appropriate. If necessary 
E.g. where there are several different timecodes present on a tape, you can specify a desired 
timecode source to override the automatic setting. U-Matic machines do not respond to all 
requests, therefore you must specify the timecode source.

Serial Port
Clicking the Configure button opens the COMM422 Configuration window:

Serial Port

Shows the current Serial Port slected from the drop-down list. If not aalready highlighted, 
select the desired serial COM port. Standard choices are either COM1 or COM2.

Click OK to confirm the choice. This automatically sets the selected COM port with the proper 
parameters of the Sony 9-pin communication protocol: 38.4 kBits/s, 1 start bit, 8 data bits, odd 
parity, 1 stop bit.
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Controllers

The following controllers are installed: 
This list shows controllers which have device drivers are currently installed. Controllers in this 
list will be able to control many of the mixer and or transport functions of Pyramix. If you do not 
see the controller you want listed here, you will need to add it. Please see: Remote Controllers  
on page 258
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Virtual Transport 

General
Enable Virtual Transport Communication

When checked, Pyramix communicates bi-directionally with Virtual Transport.

Automatically Set as Clock Master

When checked, the Pyramix Client is set as Clock Master. I.e. Pyramix is the master clock refer-
ence for all Clients

Automatically Set as TimeCode Master

When checked, the Pyramix Client is set as TimeCode Master. I.e. Pyramix provides the master 
Timecode reference for all Clients
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Chasing
Chase Mode - None - Hard - Soft

These radio buttons toggle the Pyramix Chase Mode.

Force TimeCode Source to External / Virtual Transport

When checked, TimeCode source is External / Virtual Transport.

Clients State Saving
Toggles between:

Don’t Save

Save Client’s State on Local Server

Save Client’s State on all Servers

Editing
When checked,

Synchronize Virtual Transport with Editing Moves

Send Song Position and Tempo to Virtual Transport

Please see also: Virtual Transport  on page 160
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Project Information & Settings

Information

The Information Page has fields for displaying and entering information concerning the current 
project. This information is specific to the Project and will always be available in this display.
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Record

Target Settings
Take Name

Type a ‘seed’ name here. This is used to begin the name of new recordings. E.g, if you type 
"Vocal" the next recording you make into a track will be called "Vocal". This field works in con-
junction with the "Increment take number" function (see below). If you leave this field blank, 
Pyramix will apply the name "Untitled" as a default.

Prefix with Track Name

When checked the name of the recording will be prefixed by the name of the track it was 
recorded on.
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Media Folder

Displays the selected Media Folder for recording. Clicking the adjacent button opens the 
Choose a Media Folder to Mount window. This enables folders to be created mounted and 
managed. Please See: Media Management - Housekeeping  on page 20

Resolution

Displays the number of bits per sample for recordings from the choice available in the drop-
down list. (16bps, 24bps or 32bps)

Format

Displays the current recording format from the choice available in the drop-down list. (PMF, 
SD2, AIFF, AVI, WAVE, BWF, CD Image or OMF)

Waveform

Displays the current Waveform generation mode from the choice available in the drop-down 
list. (None, Generate AFTER recording or Generate While Recording)

Source Name

This field allows you to give a name to indicate the source of the material being recorded into 
Pyramix. For example, you might enter "Reel #1" to indicate the first source reel, etc. If the 
MediaType field (see below) is set to "None", the Source Name field will be grayed out and not 
available.

Media Type

Displays the type of media the source material came from, chosen from the drop-down list. 
Clicking on the EDIT button allows existing names to be edited or new ones created. The media 
type chosen here and the source name given in the previous field are saved with the media file 
created by the new recording. This information can then be viewed by selecting a clip and dis-
playing its Properties page.

Media option

One file per track

When checked, each recording on each track of a multi-track recording is recorded into a sepa-
rate file. When this option is off (which is the default), one single media file is created contain-
ing all the tracks.

Flatten track numbers

When a recording is made on a track, Pyramix always adds media number to it. When checked 
on (default), Pyramix starts enumerating at one. E.g. If a recording is made on tracks 5 and 9 of 
a multitrack session simultaneously, the media numbers will be 1 and 2. When this option is off, 
Pyramix adds the real track numbers to the media. In the example above, this would be 5 and 9.

Unique filename extension

When checked, Pyramix will append a random number to the name of each new recording in 
order to avoid duplicate file names.

Quiet if creation failed

Unless this box is checked, Pyramix displays a dialog with an error message when the creation 
of a media file fails. This can be annoying if Pyramix is remotely controlled. Checking the box 
suppresses the error message.
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Post Processing
These options determine what Pyramix will do after each recording is finished.

Prompt for name after recording

When checked, a Record Name dialog box will open immediately after recording is finished and 
playback of Pyramix is stopped. 

If a name was entered in the Take Name field (see above) it will automatically appear in the 
Record Name dialog box when it opens. You can edit the existing name, or replace it completely 
with a new name.

Keep in default library

When checked, new recordings will automatically appear in the Default library of the current 
Project.

Increment take number

When checked, each successive recording will have the name in the Take Name field applied to 
it, plus a number that will increment with each new recording. E.g, if the first recording is 
named "Take", the next recording will automatically be named "Take 2", etc.

Place on new tracks

When checked, Pyramix will place the newly recorded clips on new tracks. These new tracks 
will be added to the Project Editor as soon as playback is stopped following a punch in/punch 
out recording. When first created, these tracks are not assigned to mixer channels, so it will be 
necessary to assign them when you want to output them. If this item is not checked, the new 
clips will be placed on the track(s) set to record them.

Clean up Media after recording

Note: This option is automatically set OFF when a Project is opened.

This mode makes Pyramix work like an analog or DASH multitrack. I.e. All punch-ins are 
highly destructive !! With modern, large hard drives, we would rather recommend: 

View > Used Media > Invert selection > Delete media (after a good archive/consolidate/
back-up has been made) or:

b) Project > clean-up media, etc.

All these functions destroy media on the hard drive, but b & c offer more control over what is 
permanently deleted.

Group Recorded Clips

When checked, clips in a multi-track recording are automatically grouped.

Auto Cross-fade

When checked a cross-fade is automatically applied when punching in or out. The current fade 
shape is displayed form the choice available in the drop-down list (Power, Linear, dB, Cosine or 
Root-Cosine) Duration can be set in frames, samples or milliseconds depending on which box is 
selected.
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Playlists
These buttons toggle between three possible choices:

Don’t create Playlist

Create an empty Playlist for each recording

Create a copy Playlist for each recording

Note: Please see: Playlists  on page 123

Controllers

The Controllers page shows a list of all external controllers currently installed.

Properties

Pops up the configuration window for the selected controller. Please see: Remote Controllers  
on page 258 for further details.
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Mixer Settings

General

Audio
Sampling Rate

Displays the rate set when the project was created or the default Mixer preset loaded. This can 
be changed from the Sampling Rate drop-down list.

Varispeed
Allows either choice of either a pull-up / pull-down sampling rate or running Pyramix in 
Varispeed mode by adapting the sampling rate.

Important!  Typical digital to analog or analog to digital converters (such as Merging Technolo-
gies Sphynx or DUAII do not operate beyond +/- 0.15 ‰ (150 ppm) and therefore will mute in 
any Varispeed mode. It is suggested to route the Mykerinos digital I/O’s through external real-
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time sampling rate conversion circuitry or to use adequate external converters with built-in pull-
up or pull-down support.

Note: Note: Locking to external NTSC video reference is limited to nominal and pull-down 
sampling rates.

Nominal

‘Normal’ mode. Uses the nominal sampling rate as set in the Sampling Rate pull-down menu.

Pull-Up

Increases the sampling rate by 0.1%. Most often used in audio post production for compatibility 
reasons between NTSC frame rates of 30 fps and 29.97 fps.

Pull-Down

Decreases the sampling rate by 0.1%. Most often used in audio post production for compatibil-
ity reasons between NTSC frame rates of 30 fps and 29.97 fps.

Varispeed

The speed of audio playback can be varied within the range of -12.5% to +12.5%. Select this 
option, then enter the required speed change in tenths of percents into the adjacent entry field. 
Values entered outside of the allowed range will be limited to the extent of the allowed range. 
E.g. if 1500 is entered, the value will be set to 1125.

Resulting Sampling Rate

Displays the sampling rate resulting from pull-up or down or Varispeed settings.

Note: The sampling rate display in the Status Bar also displays the resulting sampling rate.

DSP Time Saving
Disable the Punch in/out

When the box is checked, Punch-in and out recording capabilities are disabled.

Important!  Pyramix still will allow you to arm tracks and to start the recording process, but the 
resulting media file will contain digital nulls.

Disable Mix Down

When the box is checked, the digital mixdown function activated with the menu command 
Project->Mix Down is disabled.

Important!  Pyramix still will allow you to start the mixdown process, but the resulting media 
file will contain digital nulls.

Special Modes
Player/Recorder Mode

This mode allows big configurations (such as 48 x 48 channels) to run on a single board. When 
this mode is activated, the mixer only routes the signals (no level controls, no pan, no plug-ins). 
This option is only available in configurations with multiple mono mix buses.
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I/O and Sync
This page contains the settings for the system clock reference and several I/O settings which 
depend on the type of daughtercards currently installed in the system.

Board
In a multi-board system, use the drop down list to select the daughter-card for which you want 
to view or change settings.

Master
In a multi-board system, this check box determines which board is the source of digital audio 
sync. Only one board can be selected as master.
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Sync
Source

This determines the sample clock source for the whole Pyramix system. If an external source is 
selected and no valid signal is detected, the system reverts to Internal until the external signal is 
restored. The following choices are available:

Internal

Selects the board’s internal oscillator as clock master.

Video

Selects an external video input as the reference. The card derives word clock from the video 
sync rate. A valid video signal must be connected to the Mykerinos board chosen as the Video / 
TC master in the VS3 control panel.

Word Clock

Selects an external word clock source as the reference. The word clock must be connected to the 
Mykerinos board chosen as video / TC master in the VS3 control panel.

LTC

In special situations this option enables word clock to be derived from Linear TimeCode

Audio Input

Select this option if you want Pyramix to derive it’s clock from an external audio source con-
nected to any of the daughtercard(s) present. The correct audio input must also be selected.

Input 
Format

Provides input format selection. This is varies, depending on which Mykerinos Daughter card 
is currently selected by the Board drop-down menu.

Range

Shows the number of possible system inputs available depending on the Mykerinos Daughter

card currently selected Board drop-down menu.

Output
Mode

Provides output format selection. This is variable, depending on the Mykerinos Daughter card 
under consideration.

Monitoring
Preferred Outputs

The monitoring outputs defined here will be used by the following system functions:

• The Auto-Connect function

• Monitoring in Media Libraries

• Digitizing Session monitoring
yramix Virtual Studio User Manual
90



User Manual :   Mixer Settings

Pyra
Mykerinos Daughter Card Settings
These settings provide hardware specific configuration for the currently installed Mykerinos 
daughter card(s). Please see the documentation supplied with the card.

Level Meter
This page determines the appearance and behavior of the level meters in the Mixer and track 
Headers. These settings only apply to the current Mixer. This allows each Mixer to have its own 
custom General and Level Meter settings.

To change any of the settings, click the left or right buttons or drag the horizontal scroll bar to 
increment or decrement the selected parameter. Alternatively, type directly into the number 
field for each parameter (these fields will only accept numbers within the permissible range for 
each parameter). The color graphic display of the level meter will respond immediately to show 
the effect of Headroom and Alignment parameter changes.
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Headroom
Sets the amount of headroom displayed as red meter segments before clipping.

Alignment
Sets the alignment level. Displayed by the point on the scale at which the dark orange segments 
begin.

Peak and Overload Hold Time
Sets the amount of time in seconds that the peak segment or overload segment (topmost red 
segment) of the level meter remains illuminated.

Permanent Overload

When the box is checked, the red Overload LED above a track will remain lit, even after play-
back is stopped. To clear the LED, double-click it. When not checked, the Overload LED will 
automatically clear itself after a few seconds and remain off until the next overload occurrence.

Note: The overload LED will go on after one sample with the maximum level.

Permanent Peak

This parameter works in conjunction with the Peak Level Display. When this is on (checked), 
the Peak Level pop-up display will show the value and location of the highest level reached on 
a track up to the time when the mouse was clicked on the meter. The level display will not be 
updated until the next time playback is stopped and re-started. If it is not on (unchecked), the 
Peak Level Popup Display will show the highest level reached in that track from the last time 
the Popup Display is activated (while playback continues). For example, clicking a channel’s 
meter while playing back will display the Peak Level Popup, which will show the peak level 
(and its location) reached so far. Click away from the Popup, and it will disappear. Click on that 
meter again, and the Popup will appear again, this time showing the peak level/location 
reached since the last time the Popup was displayed.

Decay integration time
This parameter sets the rate at which the level meter display decays after the level falls below 
the most recent peak. The slope of the decay is given in terms of milliseconds per decibel (ms/
dB).

Peak level indicator
Show After

When the box is checked, the Fader/Input Level displays located above the faders on each 
mixer strip display the peak level of the signal running through the corresponding mixer strip. 
The value are updated at the interval set by the slider below the check box. If the check box 
Show After is off, the Fader/Input Level displays always show the setting of their correspond-
ing fader.
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DSD Peak Filter
In case of a DSD session this drop-down list offers the choice between two filtering options will 
be applied to the DSD signal before it is measured by the level meter.

This will help enable you to ensure that the DSD signal is compatible with the AES recommen-
dations concerning the high frequency dither noise content. 

20k

Applies a 20 kHz low pass filter to the signal, thus only the audible audio content is measured.

40k-100k

Applies a band pass filter with a frequency range of 40 kHz to 100kHz to the signal. According 
to the AES recommendation the signal level in this frequency range should not exceed -20 dB.
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Pyramix Virtual Studio Window Orientation

Program Window

The main Pyramix Virtual Studio by Merging Technologies program window appears when 
the program is launched. It has dockable Toolbars across the top with a Transport bar and sta-
tus information at the bottom. This main window can be resized, moved, minimized or maxi-
mized with the conventional Windows control boxes.
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Project Window

The Pyramix Project window is always completely enclosed by the main window. A Project 
window only exists if a Project is open, and appears automatically when a new Project is 
started. A Project window can be resized, moved, minimized or maximized within the main 
window. If the Project window is made large enough, two separate panels are visible: the 
Project Editing Panel at the top, contains the Timeline which shows a graphic representation of 
the Composition. The lower section of the screen is the Project Management Panel. The divid-
ing line between these panels may be grabbed with the mouse and moved up or down, thereby 
varying the space allocated to each panel.

Dual Monitors
When using Dual Monitor setups, the main project window can be split vertically to enable the 
Timeline to be displayed on one screen and all Tab Windows on the other one. This can be 
achieved by checking the Split Editor Vertically check box in the General Settings : Layout 
Page This change will take effect the next time a Project is opened.

Project Editing Panel
The Project Editing Panel is where much of the audio editing is accomplished. Here, audio 
Tracks may be created, added or deleted, and audio clips may be edited, moved, copied or 
pasted. Note that the Project Editing Panel will automatically start with the same number of 
audio Tracks as the number of Input Strips configured in the Mixer.
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Project Management Panel
The Project Management Panel has a number of tools for managing, navigating and modifying 
a Project. A single click on one of the tool Tabs at the top of this Panel, opens its window in the 
Panel. Double clicking a Tab opens it as a floating window. Double-clicking the tab of a floating 
window or its Caption Bar returns the window to the panel.

Tabs functions can also be accessed from pull-down menus.

Any or all of the Tab windows can be shown or hidden for a Project, and moved independently 
and outside of the main window.
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Tracks

Each Project has a user defined number of audio Tracks on which audio clips can be placed, or 
audio inputs can be recorded. Blocks representing placed or recorded clips will appear on the 
Track as soon as a clip has been placed or recorded onto it. The Track itself extends horizontally 
beneath the Time Scale bar, and multiple Tracks are stacked vertically.

On the left side of each Track is a Header panel with various controls and information displays. 
Please see: Track Header Panel  on page 98

Some operations only apply to a selected track. A Track can be selected by left-clicking any-
where on the Header which will then appear in a darker shade of gray. However, when select-
ing a Track, be careful NOT to inadvertently click on any of the Track buttons, thereby 
changing a Track function: the Track Name is often a good place to click in order to select it.

Adding and Deleting Tracks
A Project opens with the same number of Tracks as there are Input Strips defined in the Mixer 
for the Project. However, Tracks can easily be added or deleted.

To add Tracks to the Timeline, select Tracks > New Audio Track from the Project window 
pull-down menu. This opens a Create New Track window. Type in the number of new Tracks 
to create and click OK. The chosen number of Tracks will be added immediately above the cur-
rently selected Track.

To delete a Track, first select the Track to delete. Then choose Tracks > Delete from the Project 
window pull-down menu. The Track and all clips placed on it will be deleted. Note that only 
the clip or pointer will be deleted, not the original Media File.

You can also right-click in the Track Header to add or delete Tracks.

Routing Tracks to / from the Mixer
When a Mixer is created, Pyramix will automatically create the same number of Tracks as Mixer 
Input Strips (channels).

Pyramix will attempt to automatically route the output of each Track to a corresponding Mixer 
channel input, so that Track 1 output routes to Mixer channel 1 input, Track 2 to Mixer channel 
2, etc.

Similarly, Pyramix will attempt to automatically route each Mixer channel output to a corre-
sponding Track input, so that Mixer channel 1 output routes to Track 1 input, Mixer channel 2 
to Track 2, etc.

These default Track I/O assignments can easily be changed by the user. See also: Adding 
Strips  on page 55

Virtual Tracks
A virtual track is a "mirror" of another existing track. It has the same output routing and con-
tains the same clips as an existing track, but it appears in the Project Editor as a separate track.

Note: Virtual tracks contain non-overlapping clips - that is, each clip on a virtual track is not 
allowed to overlap with clips on a related virtual track. However, clips on the exact same track 
can still be crossfaded. Virtual tracks can be used for the purpose of visualizing clips that may 
have a logical reason to appear on separate tracks of the editor, even though they will be routed to 
the same mixer channel. An example of typical use is to create virtual tracks to allow the display 
of various automation curves for a single track.
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Track Header Panel
The Track Header Panel contains a variety of buttons and information fields.

This screen shot shows Track Headers in variety of states.

The pale green block shows the number of the Mixer Channel Input it is assigned to. 
Clicking this icon pops up a list to select from all available Mixer Channel Inputs. If 
the pale green block shows a dash, no Mixer Channel Input is selected and recording 
and or replay is not possible.

Clicking the Track Name area opens a text entry box where the track name can be 
typed. Track names default to Mono or Stereo.

View Automation Off - Automation data overlay is not displayed on the track.

View Automation On - Automation data overlay is displayed on the track.

Right clicking the automation icon pops up the Automation Overlay context menu with options 
as to what is displayed. (see Reference Guide)

The Mute icon toggles the Mixer Channel between Un-Muted, as shown here;

and Mixer channel Muted, as shown here.

The Solo icon toggles the Mixer Channel between Solo off, as shown here and;

Solo on as shown here.

The Record icon has three possible states.

These are toggled by left clicking the icon.
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Record Safe - no recording possible.

Record Ready - Recording commences when the transport Master Record button is 
pressed and finishes either when the Stop button is pressed, or when the Play button 
is pressed.

Autopunch Ready - Recording commences when the previously set Record In point is 
reached and finishes when the previously set Record Out point is reached.

Right Clicking the icon opens the Record tab of the Project and Information Settings window.

The Monitor icon also has three possible states.

Note: These icons are only shown when both an input and output connected.

These are toggled by left clicking the icon.

Auto - monitoring switches the associated Mixer channel input automatically 
between input and repro. Behavior depends on the Auto-monitoring setting on the 
Playback Tab of the General Settings window. European Monitoring (All tracks turn 
to INPUT on stop) OR US Monitoring (Only Record Ready tracks turn to INPUT on 
stop)

Repro - The associated Mixer channel is always fed from the track replay.

Input - The associated Mixer channel is always fed from the track’s selected Input 
source.

Input source - the number shows the selected record input. When this area shows a 
dash no record input is selected. This can be also set directly in the Mixer Console win-
dow.

Hide Track - track is removed from view on the Timeline but continues to play or 
record. It can be restored by opening the Tracks Tab in the Project management pane 
and toggling the appropriate YES entry in the Hidden column off. All hidden tracks 
can be display again by selecting the menu item View > Tracks > Show all Tracks

The Waveform icon has three possible states.

 Display Waveform - by default shows clips as blue blocks with yellow waveform 
superimposed.

Display Blocks - by default shows clips as blue blocks.
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Display Envelope - by default shows clips as blue blocks with yellow waveform and 
adds a black line which allows the gain to be adjusted using the mouse by simply 
clicking and dragging. Pressing the Ctrl key enables the drawing tool for envelopes. 
This also applies to Automation curves.

In each Track Header, you will find a pale green box with a number superimposed on it; and a 
pale red box with a number superimposed on it. The green box shows the mixer channel num-
ber the Track output is assigned TO. The red box shows the number of the physical input or 
Internal Return Bus feeding the track input.

To change a Track input or Output assignment, just click on the corresponding Track input or 
output icon, then select the appropriate Mixer channel number or Input number from the corre-
sponding pop-up list. Note: When channel and input numbers are the same, selecting a Mixer 
channel will also change the Input number, otherwise they operate independently.

When Track inputs and outputs are not assigned, the corresponding boxes for that Track will 
have dashes in them instead of numbers.

Many tracks can be assigned to the same Mixer input, they are therefore sub-mixed before 
entering the Mixer. This allows more tracks to be played than the number of Mixer input strips.

Many tracks can be fed from the same physical input.
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Navigation

Pyramix Virtual Studio offers the user a variety of ways of navigating around the Project Editing 
Panel.

Play Head Position
A vertical black line with a left facing triangle at the top indicates the current Play Cursor, Play 
Head or Now position within the Project Editing Panel. When a new Project is started, the Play 
Head is set at Zero (0).

The Playhead can either be static, with scrolling tracks, or moving, in which case the track dis-
play ‘pages’ when the boundaries are reached. (select with View > Fixed Cursor while playing 
or View > Free Cursor while playing. A further option, View > Cursor Return after playing, 
when selected, returns the Playhead to the start point when playback is stopped)

Time Scale Bar
Near the top of the Project Editing Panel is a horizontal gray area with time code numbers (or 
bars and beats if you are in Bars & Beats view). This is the Time Scale Bar. On the left, above the 
track headers, the time range, or length of the visible timeline window is indicated with the cur-
rent edit mode beneath.

The simplest way to move the Play Head Cursor within the Project Editing Panel is to position 
the mouse anywhere along the Time Scale Bar and left-click. The Play Head will immediately 
move to the new position. You can also left-click the Play Head Cursor and drag it along this 
bar.

Fixed or Moving Playhead Cursor
These options are selected via the View pull-down menu. The Play Head Cursor can be static 
with the Timeline moving (choose: Fixed Cursor while playing) or the Play Head Cursor can 
move while the Timeline remains static, ‘Paging’ when the Play Head Cursor hits the screen 
edge. (Choose: Free Cursor while playing).

The third option is Cursor Auto-Return after playing. When this is selected with either of the 
other options, the Play Head Cursor will return to the point at which Play began when Stop is 
selected

Composition Information and Settings Toolbar.

Above the Time Scale Bar and below the Project Editing Panel Toolbar is the Composition 
Information and Settings Toolbar. At the left hand side is the drop-down menu box for Mark-
ers / Tracks Sync. In between are a number of time code register boxes with increment / decre-
ment arrows. From left to right these are;
Cursor, Mark In, Mark Out, In-Out, Selection In, Selection Out and Selection In - Out. All the 
registers accept direct keyboard entry of time-code. When values are typed into the In-Out or 
Set In-Out registers, the In value remains fixed while the Out is adjusted.
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Clicking on the label buttons above the registers changes the view of the Composition in the 
Timeline as follows;
Clicking Cursor moves the view of the Timeline to the current Cursor position with the Cursor 
in the center of the track display. Similarly, clicking on the Mark In, Mark Out, Selection In or 
Selection Out buttons centres the display on the current Mark In, Mark Out, Selection In or 
Selection Out marker positions. Clicking on the In-Out or Selection-In-Out buttons centres the 
display on the area between the Mark In and Mark Out or the selected area, changing the zoom 
factor to make the area almost fill the track display.

Markers / Tracks Sync
At the left hand side of the Composition Information and Settings Toolbar is the Markers / 
Track Sync drop down menu box.

The selection made here determines the behavior of markers when tracks are edited.

Markers Locked (markers are locked to the scale)

Linked to Any Track (markers follow any track operation)

Linked to Tracks without Group (markers follow any track that have no group)

Linked to Group X, Y, Z (markers follow any track of group listed here)

Markers that belong to a group in Free Markers mode follow the tracks in that group only.

Transport Controls

The Play Head Cursor or the Timeline will also move in response to the transport control but-
tons on the strip at the bottom of the main Pyramix Virtual Studio by Merging Technologies 
window, or by using the separate Transport window controls (providing control over the Inter-
nal machine is selected). Note that the Transport Strip disappears when the Transport window 
is open, and reappears when the window is closed.

From left to right along the Transport strip, the controls are as follows: 

The ‘Grow Box’ opens the full Transport Control window

A counter shows the current Play Head position.

The Goto Beginning button moves the Play Head to the beginning of the Composition.

The Goto End button moves the Play Head to the end of the Composition. 
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The Rewind button moves the Play Head at an accelerated speed backward through the 
Composition while it is being pressed. 

The Fast Forward button moves the Play Head at an accelerated speed forward through 
the Composition while it is being pressed. 

The Stop button stops playback.

The Play button plays the Composition at normal speed forward from the current posi-
tion of the Play Head. A subsequent press Pauses playback. 

The Pause button pauses playback of the Composition. Press Pause again or Play to 
continue. 

The Record button puts Pyramix into Record mode, and creates a new recording to the 
disk on the Tracks previously armed for recording. The Play Head moves forward at 
normal Play speed during the recording.

The Loop Play toggle button puts Pyramix into a loop play mode, which continuously 
plays the Composition between the current In and Out points.

The Shuttle Control slider shuttles the Play Head forward (right) or back-
ward (left) at up to 2 X play speed. It Scrubs the audio on all Tracks as it shuttles 
through the Composition.

A pull down menu selects which machine is currently controlled. Select 
Internal from the list to ensure you are directly controlling the Pyramix Composition 
Play Head and not some external device (e.g. an RS-422 or MIDI controlled playback 
machine)

When the Hard Chase toggle button is active, Pyramix will only playback when valid 
time code is detected on the chosen time code input port. If there is a jump in the 
incoming time code, Pyramix will adjust to the new time code and begin playback 
from the new time code position. Pyramix will run on its own internal time code for 
up to 1 frame if there is a drop out in the time code. If no valid time code is detected 
after that time, playback will stop.

When the Soft Chase toggle button is active, Pyramix will only playback when valid 
time code is detected on the chosen time code input port. If there is a jump in the 
incoming time code, Pyramix will not adjust to the new time code, but will continue 
playback from the current Pyramix time code position. Pyramix will run on its own 
internal time code for up to 1 frame if there is a drop out in the time code. If no valid 
time code is detected after that time, playback will stop.
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The Offset button. Click this button to capture the incoming time code and synchronize 
it to the current position of the Play Head Cursor. The amount of time between the 
incoming time code and the current Play Cursor position will automatically be 
entered as a time code offset in the offset field of the main Transport Control window.

The Sync ‘LED’ lights green when the Pyramix ‘Transport’ has synchronized.

To the right of this is an area where any of the Floating Tool Palettes can be ‘Docked’. By default 
this will have the Automation Toolbar docked.

The Automation Palette

Automation Off disables the automation system.

Automation Play plays back any previously recorded automation data.

Automation Write plays back any previously recorded automation data and records 
new automation data whenever an enabled control is altered.

Snapshot records the state of all controls, specified in a list, at the current cursor posi-
tion.

Snapshot Range inserts automation snapshots of all controls, specified in a list, on the 
current Region Selection, if any, or between the Mark In and Mark Out cursor posi-
tions otherwise.
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Transport Control Panel
When the Grow Box button  is pressed the Transport Control bar opens into a larger, 
floating control panel.

Note: The appearance of this window changes to reflect the capabilities and controls of the cur-
rent machine

Zooming and Panning
The Project Editing Panel allows two kinds of zoom: horizontal or Time Scale zooming; and 
vertical or Track Height zooming.

Time Scale Zoom and Pan

Zoom In and 

Zoom Out icons on the Toolbar zoom in or out at the current Play Head location. Mul-
tiple presses continue zooming up to the limit of magnification.

Holding down the Alt key, then selecting an area of the Composition by clicking and dragging 
the mouse to the left or right zooms in horizontally on the selected area.

Similarly, an area of the Composition can be selected by clicking and dragging.

 The Fit in window icon on the Toolbar will automatically adjust the horizontal scale to 
fit the selected area inside the Project Editing Panel with a small margin.
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The Previous zoom icon restores the horizontal scale to the previous size.

Keyboard shortcuts exist for all these zooming actions.

The Scrollbar beneath the Tracks directly below the Time Scale bar allows the user to Pan hor-
izontally left or right in the usual fashion.

Track Height Zoom

The 1, 2, 4, 8, 16, and A buttons at the bottom left of the Project Editing Panel automatically 
scale the vertical Track size so that 1, 2, 4, 8, 16 or All (as many as possible given the vertical 
space) Tracks fit in the vertical space allocated to the Project Editing Panel.

The Scrollbar adjacent to these buttons enables continuous adjustment of the Track height.

Scroll Wheel
It is well worth while using a three button mouse with a scroll wheel.

Scroll Scrolls vertically through the tracks shown in the Project Editing Panel

Scroll + Ctrl Scrolls the Timeline

Scroll + Alt Zooms the Timeline timescale
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The Overview 

The Project Management Panel Overview Tab offers a powerful and simple means of naviga-
tion around the Project Editing Panel.

Overview displays a graphic representation of the entire current Composition, showing the 
location of all clips. A shaded gray box indicates the location and zoom range of the part of the 
Composition which is currently displayed in the Project Editing Panel. clips are shown as rect-
angles in the same color as their background on the Timeline.

Click anywhere in the Overview to center the Project Editing Panel display on that point. Click 
and drag on the shaded gray box to move the section of the Composition shown in the Project 
Editing Panel without changing the current horizontal zoom. The zoom range of the Project 
Editing Panel can be adjusted by dragging the edges of the shaded gray box in the Overview. 
An alternative method for adjusting horizontal zoom is to press the Alt key while clicking and 
dragging across the desired range for the zoom, just as you can do directly in the Project Editing 
Panel itself.
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Project Management Panel Tabs

Overview
Please see: The Overview  on page 107

EDL
The EDL (Edit Decision List) Panel, is a textual and numeric representation of the same infor-
mation shown graphically in the Timeline and Fade Editor. Changes made here are reflected in 
the Timeline and vice-versa The list shows information concerning the clips in the form of a list 
of text or timecode fields, most of which can be edited. This provides an alternate way of view-
ing and editing the composition. To edit a field, click in it to produce a cursor, or drag across the 
text in the field to select it, then type the desired information using normal text entry proce-
dures. Fields available in the Edit Decision List Panel are:

Absolute Sources in EDL View
When View Sources in EDL View is checked on the Layout Page of General Settings the orig-
inal Source In, Source Out and Sync Point times are shown in Absolute Time in the EDL View. 
Absolute time is the incoming timecode recorded at the audio capture. When this mode is dis-
abled, the default start time of timecode for the captured clip is 00:00:00:00.

Field Description Editable

Name Clip Name Yes

Type Type of Clip(e.g. audio, video, midi etc.) No

Dest In Clip’s In time in the Timeline Yes

Dest Out Clip’s out time in the Timeline Yes

Fade In Clip’s Fade In length Yes

Fade Out Clip’s Fade Out length Yes

Length Length of Clip in the Timeline Yes

Source In Media timecode value at Clip’s Head Yes

Source Out Media timecode value at Clip’s Tail Yes

Sync Source Media timecode value at the Clip’s sync point Yes

Track Name of Track Clip is assigned to No

Comment Comments about the Clip from the properties page Yes
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Document Libraries
There is no real difference between Document libraries and Global Libraries. The distinction is 
an organizational one, made to help keep complex projects manageable and to provide security 
features for larger facilities. Libraries designated as Global are available to all projects but can 
be opened and manipulated from the Document Library window. Equally, libraries created in 
the Document Libraries window can be opened in the Global Libraries window. The default 
Project library created with every Project is stored with the Project. It can still be opened in the 
Global Libraries window by looking for the .PMX project file in the Project’s Media Files sub-
folder.

The left hand pane shows Libraries associated with the project. Sub-folders of libraries are 
termed Shelves. The contents of the highlighted Library is shown in the right-hand pane with 
information about the objects in columns.

The Library menu allows new Libraries and Shelves to be created and existing ones to be 
opened and saved. When a library is opened the media used by Masterclips/Composition may 
not be mounted, (E.g. on a removable drive). Mount Referenced Media automatically mounts 
the most recent location where these media were found.,

Library Menu
New Library Create new user library

Open Library Open existing user library

Save Library as Save a copy of the current library with a new name or in a new location

Close Library Close current library
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Mount Referenced Media Automatically mounts the most recent location where media in the current 
project were found

Export to Akai DD series Exports the contents of the current library to Akai DD format disk

New Shelf Creates new Shelf (subfolder) below the current level

Open Shelf Opens selected shelf

Up one level Go up the tree one level (if available)

Properties Opens the properties window for the current library

Edit Menu

The Edit menu allows the usual cut, copy and paste operations between the Timeline and 
library and between libraries. objects can also be Opened/Auditioned/Viewed depending on 
their type
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.

Place opens the Place Window. The selected object(s) will be placed in the Timeline according to 
the rule chosen here.

Compositions in the library can be Consolidated. Please see also: Consolidating Projects  on 
page 207
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Consolidate

The Consolidate function makes a selective backup of the media segments in the selected Com-
position. I.e. instead of backing up the whole of every media file referenced by the clips in a 
composition, Consolidate backs up only those parts of the media files that are referenced by the 
clip segments in the Composition. Extra media, beyond the clip boundaries can be added using 
the Handles option. This allows further manipulation of the Composition within the limits of 
the handle length.
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..View Menu

The View menu determines how library information is displayed.

Filter, when ticked, filters the items displayed in the right-hand pane of the Document Libraries 
Tab Window according to the filter parameters set under the Filter Options menu selection.
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Options.

Selecting Options opens the Library Settings Window with two Tabs, General and Columns.

General is self explanatory. Columns controls what is displayed in the right-hand pane of the 
Library Tab Window. The columns displayed and their order are all customizable.

Please see also: Libraries  on page 20

Media Management
Opens a window with two panes. 

The left hand pane shows mounted Media Drives and Folders available for use with the 
project. The contents of the highlighted Media Drive or Folder is shown in the right-hand pane 
with information about the object in columns
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Media Management Menus

Drive.

Mount Media Drive Make visible to the Pyramix media filing system 

Unmount Media Drive Remove from the Pyramix filing system 

Refresh Media Drive Refresh works in the same way as Explorer Windows and makes visible files 
which have been added since the Media Management Window was opened 

Open Drive Opens the Media Management Library for the selected drive and directory. 
Double clicking on the name of the media directory has the same effect

Show All Drives Opens a list of all mounted drives and directories

Properties Opens a Proeprties window showing the number of currently mounted drives

Edit

Most options are the same as the Document Library Edit Menu with one major exception:

Important!  Delete Media does what it says. This command:

PERMANENTLY REMOVES AUDIO from the drive.
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Convert

Quick Import Enables sound files in any supported format to be imported into a Pyramix 
Media Drive or Folder in either their original format or converted to the Pyra-
mix native PMF format.

Note: Files in supported formats do not need to be converted to be used in Pyramix, a big time-
saver.

Quick Export Enables Pyramix Master Clips to be exported in any of the supported file for-
mats

Reverse Reverses the selection so it plays backwards

Quick Convert > Enables one or more Media files to be converted in a variety of ways.

All the options produce new media files on disk. Whichever conversion option is chosen, this 
Window will pop-up with a title reflecting the selected process. Either a new name may be cho-
sen or the existing one kept with a new suffix. If you wish to process multiple files in one opera-
tion the Add Suffix button must be selected. When multiple files are selected and this option 
chosen the OK All button is available. The Keep Original File Format checkbox does what it 
says. The Properties... button opens a Window specific to each conversion type.
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:Samplerate Converter Properties

Output Sampling Rate [Hz] select the desired sampling rate by clicking the relevant radio but-
ton.

Conversion Quality Select the desired quality. Very high offers better conversion but takes 
longer.

Normalize Properties

Level dBFS

Here you can select from four preset values, or use the slider to specify the maximum level for 
the new file.

Options

Group Normalize

When checked, the level of the highest peak in any group of clips is raised to maximum and 
level of the other clips is increase proportionally.
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DC Removal

When checked, D.C. offsets will be removed.

Prosoniq MPEX2 Properties .

Select the required conversion factor from the four options.

Wordlength Converter Properties

Destination Wordlength

Select the desired wordlength using the radio buttons.

Noise Shaping

Select the require quality of Noise Shaping. A higher quality setting will produce better results, 
but the processing time will also increase.

Dithering When checked, If dithering is required, dithering will be applied.
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Tracks 
The Track Tab opens a table where each row contains information about a single track and each 
column contains information and function selection fields. New tracks can be created or existing 
ones deleted and the order of tracks changed. All track parameters are accessible and modifi-
able.

New tracks can be added by clicking on the first line of the Tab Window and typing a suitable 
name then pressing Enter.

Tracks can be deleted by selecting them and pressing the Delete key.

The order of the Tracks can be changed by selecting and dragging tracks. Click on the symbol at 
the far left of the Name field and drag to the desired row.

Track Column Fields
Name

The name of the Track. Up to 29 characters are visible in this field but longer names are 
accepted.

Repro Connection

Shows which Mixer Input Strip the track is connected to. Clicking in this column field drops 
down a list box with all available Mixer Input strips. Strip number on the left, Strip Name in 
brackets. 

Input Connection

Shows which Input is feeding the track. Clicking in this column field drops down a list box with 
all available physical inputs.

Track Group

Shows which Track Group (if any) the track belongs to. (see below) Clicking in this column 
field drops down a list box with all available Track Groups.

Solo

If YES track is soloed.Clicking in this column field toggles between YES and blank. 

Mute

If YES track is muted.Clicking in this column field toggles between YES and blank. 

Record Ready

Shows the current record ready state. Clicking in this column field drops down a list box with  
the three possible states, Safe, Record Ready and Auto-Punch.
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Monitoring

Shows the current monitor mode. Clicking in this column field drops down a list box with  the 
three possible modes, Auto, Input and Repro.

Hidden

If YES the track is not visible in the Timeline but continues to operate normally. Clicking in this 
column field toggles between YES and blank.

Always Visible

If YES the Track will always appear on screen (if there is sufficient  room) even when scrolling 
other tracks.

Collapse/Expand

If YES the track is a member of a Track Group currently collapsed. (see below)

Display Mode

Shows the current Clip Display Mode mode. Clicking in this column field drops down a list box 
with  the three possible modes, Block, Waveform or Envelope

Show Automation

If YES the automation envelope is displayed. Clicking in this column field toggles between YES 
and blank.

Show Peak-Meter

If YES a Peak meter  is displayed in the Track Header. Clicking in this column field toggles 
between YES and blank.

Size

Shows the current track display Height. (in pixels) Clicking in this field allows a numeric value 
between 24 and 511 to be entered.  

Background Color

Shows clip background colour. If blank  color is set to Standard. Clicking in this column field 
pops-up a color picker.  

Waveform Color

Shows clip Waveform colour. If blank  color is set to Standard. Clicking in this column field 
pops-up a color picker. 

Recording Media Folder

Shows the Media Folder where new recrdings will be stored. Clicking in this column field 
pops-up a list of all mounted Media Folders

Making Settings Changes to Multiple Tracks
Changes to Tracks settings can be made on a multiple selection of tracks. Press Ctrl and Click 
on a track to add it to the selection or press Shift to select a range of tracks.
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Track Groups
Track Groups, as the name implies, enable a number of logical function linkages between tracks 
and several other useful methods of improving efficiency. The Track Groups Tab opens a table 
where each row contains information about a single track group and each column contains 
Information and function selection fields.

The first two rows enable new Track Groups to be created and existing ones to be duplicated by 
clicking on the Name field.

To create a new Track Group, click on Click here to add a new Track Group. A text entry box 
replaces the Name. Enter a suitable name and press Enter. A new track group will appear at the 
bottom of the list.

To duplicate an existing track group, click on the Track Group you wish to duplicate then click 
on Click here to duplicate a Track Group. A text entry box replaces the Click here to duplicate 
a Track Group. Type a suitable name and press Enter. The duplicate Track Group appears in 
the row below the Track Group you have just copied. Subsequent rows are moved down the 
table. The Track Group entries can be re-ordered by clicking on the symbol at the far left of the 
Name field and dragging to the desired row.

When tracks are assigned to a Track Group a small group track is shown in the Timeline imme-
diately above the first assigned track.

Track Groups can be collapsed/expanded by clicking the little [-] or [+] on the Track Group 
track header.

Track Group Column Fields
Name

The name of the Track Group. Up to 29 characters are visible in this field but longer names are 
accepted.

Type

Clicking in this column field drops down a list box with current choices of Free, Source, or Des-
tination.

Free is used to create General purpose Track Groups
Source is used for grouping Tracks to be Sources in the Source/Destination model.
Destination is used for grouping Tracks to be Destinations in the Source/Destination model.

Collapsed

Track Groups can be collapsed, so only one of the tracks of the group is displayed. When set to 
Yes, only the track chosen and shown in the Collapsed Display field is displayed in the Time-
line unless this track is selected. If selected, all tracks in the group are displayed. This field has 
the same function as the little [-] or [+] on the Track Group header.

Collapsed Display

Clicking in this column field drops down a list box which contains the names of all the tracks in 
the group. The selected name determines which track will be displayed when the display is col-
lapsed.
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The rest of the fields
All the other column fields toggle when clicked, either displaying Yes or a blank. The functions 
described below apply when the fields are set to Yes.

Keep Cursor

The Group ‘remembers’ the position of the cursor and restores it each time one of its tracks is 
selected.

Free Zoom

The group has its own zooming factor, independent of the general zoom factor.

Free Markers

Track Groups can have their own list of markers that are displayed on the Track Group Scale or 
on the main TimeCode Scale if the Track Group Scale is hidden (see below).

Markers Locked

Locks the Markers. For the particular Group. Free Markers must be ON

No Selection

Clicking on clips placed on tracks of the group does not select anything, the cursor is simply 
placed at the position where the mouse is clicked. Clicking with the Q key held down allows 
clips to be selected on these tracks.

Auto Solo

If any track of this group is selected, the whole group is automatically Soloed.

Auto Mute

The whole group is automatically muted unless one of its tracks is selected.

Auto Record Ready

When a track of this group is selected, the whole group goes into Record Ready mode.

Auto Collapse

When none of the tracks of this group is selected, the group is automatically collapsed to dis-
play a single track. When this track is selected, the whole group is expanded.

Auto Hide

When none of the tracks of this group is selected, all tracks of the group are automatically hid-
den. When any track of the group is selected, the whole group is shown.

Exclusive Show

When any track of this group is selected, all tracks that are not part of this group are hidden. 
This is the equivalent of a Solo for the Display.

Show Scale

Toggles show/hide an independent scale for TimeCode if the Track Group is on Free Zoom and 
Markers if it is in Free Markers mode. If OFF then the Scale and Markers are displayed in the 
main Scale of the Timeline when any of the Tracks of this Group is selected.

All other columns of the Tab Window (Solo, Mute, Record, Monitoring, Display, Show/Hide, 
Size, Color, Sync, Automation Display) define which of the parameters set in the Track Header 
or in the Tracks Tab window are affected by the group, I.e. which of these parameters are 
changed in the whole group when a change is made to an individual track of the group.
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Playlists
Playlists enable different versions of the content of a selection of tracks to be easily stored and 
any stored version to be recalled.

Playlists have a name (and can be renamed). A Playlist shows the list of tracks it keeps versions 
of. By selecting a Track Group or one or more Tracks in the Playlist Tab Window, you can:

• Create a new empty playlist for these tracks

• Create a new Playlist for these tracks containing a copy of their current content

You can also:

• Create a new empty Playlist for all tracks in Record Ready mode

• Create a new playlist for all tracks in Record Ready containing a copy of their current con-
tent

Double clicking on a Playlist icon replaces the content of the tracks it references with the version 
it contains.

Modifications done on the tracks referenced by a Playlist are updated in the last recalled Playlist 
when an other one is recalled. A new Playlist can be automatically created for each recording for 
every recorded tracks by checking this option in the Document Information & Settings / Record 
Page.

The Playlist icon displayed on each track header enables:

• The creation of an empty Playlist for each track in Record Ready Mode, all Tracks in Group 
or Strip, or the selected Track

• Creating an copy Playlist for each tracks in Record Ready Mode, all Tracks in Group or 
Strip, or the selected Track

• Recalling a Playlist. A list of Playlist that reference the selected track is proposed for recall-
ing.

• Merging a Playlist with the current content of the tracks. A list of Playlists that reference the 
selected track is proposed for recalling.

Work Spaces
Workspaces provide a powerful means of storing and recalling the state of a number of parame-
ters of the Project Editing Panel, especially Track Header Panel switches. In effect a Workspace 
is a snapshot which enables the operator to quickly switch between set-ups for a variety of com-
mon tasks.

• New Workspaces can be added by clicking on the first line of the Tab Window and typing a 
name.

• Workspaces can be deleted by selecting them and pressing the ‘Delete’ key.

• Applying a Workspace is done by double-clicking on the Workspace icon.

• Parameters remembered by Workspaces are selectable per Workspace by clicking in the 
appropriate columns.

• The last column allows a stored Workspace to be automatically updated to the current val-
ues before switching the another one.
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Selection
The Selection Tab Window groups together Selection Properties, Clip Properties and Media 
Properties fields in a table.

When choosing Selection Properties or a Properties Menu item, this Tab Window is displayed. 
If the Tab Windows section is hidden, then the Selection Tab Window is undocked to ensure it 
is visible. Parameters that can be modified are marked with a ‘>’ sign. Click on the ‘>’ sign or on 
the parameter itself to change/edit it.

Selection and Clip Modifiable Fields
Name

This field shows the name of clip as it appears in the composition. This name will also be dis-
played in the clip block when the clip is set to Show Text.

Comment

This field shows a user comment concerning the clip. The information displayed here will also 
be shown in the Comment field in the EDL Tab window

Level

Available in both 

Pops up a window with a fader and numerical entry box for level, and two check boxes, 
Sel.ection and Rel.ative. When neither box is checked any gain change is only applied to the 
clip on which you last right clicked (even if others are selected). If Sel. is checked, the gain will 
be applied to the whole selection (selected by default). If Rel. is checked and you have a 
grouped series of clips the gain change is relative to pre-existing levels.

If you click on the > in the “selection” part gain is applied to the whole selection, and if you click 
in the “clip” part, the gain is applied only to the clip which was under the mouse when you 
clicked. 

E.g: Three clips are selected, the first at -1 dB, the second at -2 dB and the third at -3 dB. You 
wish to increase the gain of all the selected clips by 1dB. Check the Rel. box and add 1 dB either 
with the fader or in the numeric box. This will result in the first track at 0 dB, second at -1, third 
at -2.

Phase Invert

Toggles between No and Yes (Phase inverted)

Mute

Toggles between No and Yes (Muted)

Auto Deglitching

Drops down a list box with choice of None, Follow General Settings or fade settings between 
1.0 [mS] and 5.0 [mS] in 0.5[mS] increments. This feature avoids the necessity to manually make 
short fades when quickly making cut edits. On any clips that do not already have a fade a small 
ramp is automatically applied to avoid clicks at the beginning and end. Any clips with fades 
previously applied bypass the Auto-Deglitching feature.

Clip Information Only Fields
Apart from the modifiable fields listed above, clip also shows the following information fields:

Length

This shows the total length of the selected clip segment.
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Media Offset

This field shows the amount by which the start of the selected clip segment is offset from the 
beginning of the entire Master Clip.

Original Timecode

This field shows the original timecode stamp at the head of the clip.

Peak Level

This field shows the highest level (in Decibels Full Scale) reached by any sample within a clip. 
This is only shown for clips which have had a Waveform display generated.

Media Information Only Fields
Name

This field shows the name of the media.

Format

This field shows the media format as either PMF or OMF.

Author

The Selection Tab Window is automatically updated when the selection changes and can there-
fore remain floating.

Fade Editor
The Pyramix Fade Editor offers several methods for creating fades and cross-fades. Fades can be 
made graphically by simply clicking and dragging appropriate points on the display or by using 
a specialized set of faders and buttons or by directly entering numeric data. A comprehensive 
set of auditioning options is provided together with libraries for user defined fade shapes and 
fades.

The Fade Editor always displays the fades for the current selection in the main Editor. The nearest 
fade to the click point is automatically selected.:
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Toolbar 
Contains these buttons:

Accept & Close Editor (Close the Fade Editor and keep the changes, in effect an ‘OK’ 
button)

Restore & Close Editor (Restore the fade to its state prior to opening the Fade Editor or 
selecting a new fade, effectively a Cancel button)

Undo last fade change

  Select/Edit Previous Fade

  

  Select/Edit Next Fade

  Zoom around the current Fade (Reset Zoom)

  Zoom In

  Zoom Out

  Xify (Reset the current fade to a standard Power X fade)

  Show/Hide Faders & Control Section

  Show/Hide Parameters & Options Section

  Audition whole X Fade with Pre-Roll and Post-Roll set before and after the X Fade 
boundaries

  Audition whole X Fade with Pre-Roll and Post-Roll set around the Reference Point

  Audition Fade Out up to its End with Curve

  Audition Fade Out up to its End without Curve
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  Audition after the End of Fade Out

  Audition Fade Out up to the Reference Point with Curve

Audition Fade Out up to the Reference Point without Curve

  Audition after the End of Fade Out from the Reference Point

  Audition Fade Out without stopping at its End

  Audition Fade In from its Start with Curve

  Audition Fade from its Start without Curve

  

  Audition before Start of Fade In

  Audition Fade In from the Reference Point with Curve

  Audition Fade from the Reference Point without Curve

  Audition before Start of Fade In from the Reference Point

  Audition Fade In before its Start

The Graphical Display
Consists of the following elements:

• The TimeCode scale displaying the Zoom range on its left.

• A Reference Point which is set by default at the edit point or in the middle of the (X) Fade. 
This marker can be moved by clicking in the TimeCode Scale and is just a Reference Point 
for Auditioning (see above) or for Auto-Center (see below)

• All tracks or a selection can be displayed (see Parameters & Options below)

• At the left of each track display The Track name of each clip is shown, with a toggling Edit 
On/Off selector. This allows one or more Clip’s/Fades to be excluded from further modifi-
cation.

• A Vertical Scrollbar navigates through hidden tracks if any

• An Horizontal Scrollbar navigates before and after the Fade position

• The outgoing and incoming clip fades are displayed with curves
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• The Fade Position can be moved by clicking and dragging within the Fade area 
(Cursor changes to hand)

• The Fade Length can be changed by clicking and dragging on the left or right side 
of the Fade area. (cursor changes to <|>)

• The Media of the clips can be moved by clicking and dragging outside the Fade 
area. (Cursor changes to hand with tape reel)

• The Fade Curves can be modified by clicking and dragging on the Bezier Control Point Han-
dles in the Fade black box

The Faders & Control Section
Has the following controls and displays:

• The Fade Safe check box in the Fader section ensures (when checked) that all following 
fades to the right of the one being edited are left intact while editing the current fade. This 
enables Auto-Ripple to be used without Auto-Ripple while keeping Fade synchronization 
clean.

• Six Memory Set and six Memory Recall buttons store and recall all the settings in the Fade 
Editor. The recall buttons are only numbered when there are stored parameters to recall.

• Gain Faders, Nudge buttons and Manual Entry Value Box (in dB) for both Fade Out & Fade 
In

• Intercept and Asymmetry Faders, Nudge buttons and Manual Entry Value Box (in dB)

• Length Faders, Nudge buttons and Manual Entry Value Box (in milliseconds. Type an s 
after any numeric entry to obtain a value in seconds) for both Fade Out & In

• Length of Fade Out & In can be linked by clicking the Link button

• Length of Fade Out and In can be changed symmetrically (centered) by clicking the 
Mirror button.

• Position Faders, Nudge buttons and Manual Entry Value Box (in millisecond, type an s 
after any number entry for a value in seconds) for both Fade Out & In

• Position of Fade Out & In can be linked by clicking the Link button

• Media Position Faders, Nudge buttons and Manual Entry

• Value Box (in millisecond, type an s after any number entry for a value in seconds) for Fade 
In

Parameters & Options Section
In this table parameters and options may be modified by clicking on >.

There are these sections and fields:

Control

• Link Length (see above)

• Mirror Length (see above)

• Link Position (see above)

• Fade Safe (see above)

Display

• Shown Tracks offers these choices:
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• All tracks

• Follow TimeLine Display

• Choice of tracks. The number of tracks selected in the TimeLine controls the avail-
able choices. So, if 4 tracks are selected, there will be the option of 1, 2, 3, or 4 tracks

• Auto-Center, enables automatic re-centering of the display around the Fade or Reference 
Point after certain operations

• None

• Fade

• Reference Point

• Zoom, can be one of the following:

• Free, follows only Zoom Reset, In and Out

• Auto-Zoom, automatically Zooms around the current Fade after some operations

• Auto-Zoom / Free, automatically Zooms around the current Fade but only when it 
enters the Fade Editor, thereafter, the Zoom is Free

• Timeline, follows the Timeline Zoom factor

• Choice of User defined Zoom Presets (see menu View > Zoom) 

Audition

• Pre-Roll from the choices defined in the General Settings : Playback Page

• Post-Roll from the choices defined in the General Settings : Playback Page

• Solo, when On only the edited tracks are auditioned, when Off all tracks of the composition 
are auditioned as well

• Loop, any audition operation is repeated until Stop is pressed

• Speed, allows choice between 100%, 50% and 25% of normal play speed for auditioning

• Audition after Nudge, to automatically audition the Fade after nudging any parameter

Memory

• Set, allows saving up to 6 temporary Fades for comparison

• Recall, allows recall of one of the 6 temporary saved Fades

X Presets / Out Presets / In Presets

• Load Curve, allows loading the Curve SHAPE only from a choice of:

• Default

• Power

• Linear

• dB

• Cosine

• Root-Cosine

• Any User-defined curves

• Load Preset, allows loading a Fade from a choice of:

• Default Fade

• Any user defined Fades

• Save Preset, 
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• Default Fade

• New opens the Save X Fade or Save Fade pop-up window (See below)

Save X Fade

The window opens with the cursor in the X Fade Name box. Simply type a name for the new 
preset or choose an existing one to over-write using the dropdown list. Choose appropriate 
options and click OK or hit the Enter key to save the preset.

Apply Mode Options

A number of options are provided which affect the way the Fade will be applied when recalled.

Curve Only

When this box is checked only the curve shape will be recalled and applied to the overlapping 
tracks for the duration of the existing cross-fade. If left unchecked, the original duration and 
positions of the start, end and reference point will also be applied to the existing cross-fade.

Preserve Fade In Attack 

Fade will be aligned to the left , relative to the edge of the clip, when recalled.

Center

Fade will be centered , relative to the edge of the clip, when recalled

Preserve Fade Out Release

Fade will be aligned to the right , relative to the edge of the clip, when recalled.
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Save Fade

The window opens with the cursor in the Fade Name box. Simply type a name for the new pre-
set or choose an existing one to over-write using the dropdown list. Choose appropriate options 
and click OK or hit the Enter key to save the preset.

Apply Mode Options

A number of options are provided which affect the way the Fade will be applied when recalled.

Preserve Attack or Release

Center

Preserve Length

Markers
Different Markers lists can be edited by selecting the desired Track Group or the main Markers 
List. Markers are numbered in ascending order by their position in time. If a Marker is moved 
before or after another Marker, the affected markers are automatically re-numbered.

Clicking on the first entry in the Name Field ‘Click here to add a new Marker’ Adds a new 
Marker at 00:00:00:00 This value can be edited in the usual way.

The color of Markers is user selectable. Clicking in the Color field drops down a list box with all 
the available colors.

Double clicking on a Marker’s Name Field jumps the Playhead Cursor to the Marker.

Double click with CONTROL pressed plays from the marker TimeCode

Double click with SHIFT pressed plays from the marker TimeCode with the first Preroll. This 
also applies to CD markers

Right-click to open a menu that enables Markers to be Cut / Copy / Pasted between Groups or 
Projects.
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CD
·All the mastering features are grouped in the CD View; in two sections.

In the Left Pane there are three window tabs:

CD Properties, All Markers and Table of Content

CD properties: 
allows all the CD properties and default parameters to be set.

• Disc Title CD Title

• Label CD Production Label

• Date CD Date

Customer

• Name Customer Name

• Contact Customer Contact (name)

• Phone Customer contact phone

Code

• Master ID Code CD Identifying code (if one is required)

• Ref Code CD Reference Code (if one is required)

• UPCEAN Code CD Code Bar (13 digits). This field has a validation routine. So you 
can enter the code bar as you want and it will be automatically validated. (exp. 123-
123456789-1 gives 1231234567891).

CD Text Info

(Global – CD Header). In addition, there are similar fields for each track in the CD Track grid.

• Title CD Title

• Performer CD General Performer

• Song Writer CD General Song Writer

• Composer CD General Composer

• Arranger CD General Arranger

Edition default params...

These parameters are used when the offset of a PQ marker is set to zero and you enable it. All 
these parameters are stored in the project. If you want to define the value as Default value, right 
click on the value and select “Set as Default”.

• Offset before first track: negative offset applied to the first PQ start marker only.

• Offset before start: negative offset applied to PQ start marker except the first one.

• Offset after stop: positive offset applied to PQ stop marker except the last one.§ 
Offset after last stop: positive offset applied to the last PQ stop marker.

• Offset before Index: negative offset applied to PQ index marker.

ISRC default params

These parameters are used to automatically create or increment ISRC with the function ISRC > 
Create & ISRC > Inc Selection in the track grid popup menu. (Right-click anywhere in the 
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right-hand pane) All these parameters are stored in the project. If you want to define the value 
as Default value, right click on the value and select “Set as Default”.

• Country Code: 2 characters (exp. GB, SW, FR etc…)

• Producer: 3 characters (exp. W01).

• Year of Reference: 2 digits (exp. 02).

• Designation Code: 5 digits (exp. 00012, 80010).

• Increment by: used to auto increment the designation code part of the ISRC. The 
default value is “1”.

All Markers:
to show and edit all the PQ markers. Here only the PQ is modified, not the audio edit.

Name

Name of the PQ Marker. When the markers are automatically created with the function “CD 
Mark Group”, the stop marker gets the same name as the start marker + “Stop” at the end. The 
“*” tells you that this marker was auto generated.

# (Number) 

(Read only) Number of the PQ Marker. The stop marker has the same number as the start. The 
index markers begin at 2 then Inc… This is a Read only property; it depends on the position of 
the marker in relation to the others.

Type

Type of the Marker.

TimeCode

TimeCode position of the Marker.

Offset

Offset of the Marker.

Use Offset

Enable or disable the Offset of a marker.

Table of Content:
to view, in real time, the final Table of Content, including the offsets.

Right section
The right-hand pane is the CD Tracks List which enables viewing and editing the content of the 
CD; by track. All modifications applied here automatically affect your edit. For example, if 
you modify a track pause from 4 to 6 second, all the clips (from the first one in the selected track 
to the last clip of the last track), markers and automation will be rippled to the right to add 2 sec-
ond to the pause.

All operations can be undone.

To access further functions, right click on the grid to display a popup menu.
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The fields are:

Name

Name of the CD Track

Number

Number of the Track. Click on the Value to display a drop-down list with all available track 
position numbers, then you can select a new location for the track (E.g. Send track 9 to 2).

Pause

Pause of the CD Track: Time between the start of the track and the stop of the previous one. The 
pause of the first track is always 0 (the 2 second pause required by the RED Book standard are 
automatically added for you in the final TOC) except in case of a Ghost track (see the Ghost 
Track section for more detail).

Start

Start of the CD Track in the timeline. Modify this value to ripple the track and all the tracks 
after.

End

Stop of the CD Track in the timeline. Modify this value to ripple all the tracks after (performs a 
similar function to Length).

Length

Length of the CD Track. Modify this value to increase or decrease the length of the track and 
ripple all the tracks after.

Start Offset

Negative Offset for the start marker of the track.

Use Offset

Enable or disable the offsets of the track (start, stop, and index). To individually apply offset to 
start, stop and index, go the All Markers page in the left-hand panel.

ISRC

International Standard Recording Code. See the CD Properties section in the left-hand panel to 
get a complete description of this code. See the Extra Functions section to see how to automati-
cally create this code. This field has a validation routine. The code may be entered as you wish 
and will automatically be validated. (E.g. “(FR) W01 - 02 / 1” gives “FRW010200001”).

Copy

Toggles the Copy Protection bit.

Comment

General purpose comment. For ‘in house notes’.

CD Text fields
All the remaining fields can be copied from the CD Properties page, see the Extra functions sec-
tion, after this:

CD Text Title

CD Text Performer

CD Text Song Writer
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CD Text Composer

CD Text Arranger

Extra Functions
(popup menu display with a right click on the grid):

Add
> CD Mark Groups

Generate PQ markers automatically from clips or clip groups.

> Start Marker

Add a Start Marker to the cursor position.

> Stop Marker

Add a Stop Marker to the cursor position.

> Index Marker

Add a Index Marker to the cursor position.

ISRC

> Create
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Create ISRC for the selected track(s) using the ISRC default parameters in the CD Properties 
page. If there is more than one selected track, the ISRC are first created on the first selected track 
then incremented for the other(s).

> Validate

Check if the ISRC code is correct and correct it if it’s bad.

> Inc Selection

Increment the designation code part of the ISRC for the selected track(s).

Show Offset
Move the PQ marker to reflect the final position of the markers with offset. The Table of Con-
tent page always displays the final PQ code with offset; so this function is useful to show the 
real position of the marker on the timeline or when you want simulate the final CD with the CD 
player.

Offset

(from CD Properties

Each of these four menu choices copies value settings from the Edition default params... section 
of the CD Properties page in the left hand pane and applies them to the selected track(s).

> Copy First Start 

Apply the Offset before first Track value

> Copy Last Stop

Apply the Offset after last Stop value

> Copy Start 

Apply the Offset before start value

> Copy Stop

Apply the Offset after stop value.
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Show CD Player

Display an “always on top” small CD Player which enables simulation of the CD playback (like 
a “real” CD player). The CD can be simulated with or without the markers offset. Choose Show 
Offset in the Track list pane pop-up menu to take care of the offset The player has standard 
playback functions (play, stop, next, previous, scan etc…) and some special functions:

Play transition

Play the current track pause from the previous Stop marker minus pre-roll to the current Start 
marker plus post-roll. Pre and Post roll can be edited directly on the CD player interface.

Play all transitions

Has the same functionality as Play transition but for all the CD tracks.

Time Display

Right clicking on the display allows a choice between these different time displays.

Time Display: All Displays time from the start of the CD, to the End (from 0 to the end of the 
CD).

Time Display: All - Remain Similar to All but time remaining.

Time Display: Tracks Display time for each track; from the start of the track, to the End (from 0 
to the track Length).

Time Display: Track - Remain Similar to Track but time remaining.
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CD Text

> Copy All Copy all the CD Text information from the “CD Text Info” in the “CD Properties” 
page to the selected track(s).

> Copy Title Copy the CD Text title from the “CD Text Info” in the “CD Properties” page to the 
selected track(s).

> Copy Performer: Copy the CD Text performer from the “CD Text Info” in the “CD Proper-
ties” page to the selected track(s).

> Copy Song Writer Copy the CD Text song writer from the “CD Text Info” in the “CD Proper-
ties” page to the selected track(s).

> Copy Composer Copy the CD Text composer from the “CD Text Info” in the “CD Properties” 
page to the selected track(s).

> Copy Arranger Copy the CD Text arranger from the “CD Text Info” in the “CD Properties” 
page to the selected track(s).

> Copy Title from Track Name Copy the track name to the CD Text Title for the selected 
track(s).

Validate Name Remove the “*”, which are included in the name of an auto-generated marker 
and copy the name of the start marker to the stop, with “stop” at the end.

Delete Selected Track(s)

Deletes selected track(s) complete with clip, Markers, Automation etc.

Clear All markers

Clear all the PQ markers

Ghost Track
Normally a CD begins from the first track which has a 2 second pause. Pyramix allows you to 
modify this and create a ghost track; a track before the first track. To accomplish this simply add 
a CD Index Marker at the beginning of your ghost track, before the first start marker. You can 
also edit the pause of the first track then this will create or move the ghost marker index for you.
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Multiple CDs or versions in one Project
All CD Information and CD Markers can be either "global" or per Track Group. Each Track 
Group that has the Destination type and Free Markers enabled has its own CD Information and 
CD Markers. This enables multiple versions of PQ editing for an album to be handled and for 
multiple CD albums in the same document. The CD Info and Markers displayed in the CD Tab 
Window follow the currently selected Track Group.

Red-Book Validation
 “Validate PQ”: (right click on the CDTrackList and choose Validate PQ) This will ensure  the 
PQ conforms to the Red Book specifications by carrying out the following checks and correc-
tions.

• When a pause is less than 1 second, the pause is removed. (The offset is automatically dealt 
with).

• Track Length is set to 4 second if it is less. (The offset is automatically dealt with).

• Track count is reduced to 99 if greater

•  ISRC is removed if it is incorrect

•  UPCEAN is removed if it is incorrect

This function an be undone if necessary.

Notes
The Notes tab opens a text editor where notes about the project may be typed. Font type and size 
are chosen from drop-down lists. Justification, Bold, Italics and underline are selected with but-
tons.
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Machines
The Machines tab shows a control and information panel for each machine defined, installed 
and active in the General Settings : Machines page. A panel is always shown for the Internal 
Machine I.e. Pyramix. When undocked, the panel(s) appear(s) in a window.:

Active Machine
The transport control bar or window controls whichever machine is currently set to Active

The Machine drop-down list in the transport control window shows the active machine and 
can be used to switch between installed and enabled machines. Alternatively you can toggle 
through the currently enabled machines. Machines > Active Machine > Toggle machines

Auto-chase
To make Pyramix automatically chase an active external machine, enable the menu setting: 

Machines > Active Machines >Auto-Chase External Machine

Global Libraries
This window is the same as the Document Libraries window but deals with libraries available 
for use in all Projects Please see: Document Libraries  on page 109 also: Libraries  on page 20

Cue Sequencer
Please see: Cue Sequencer  on page 266
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External Machines

Connection for the Sony 9-Pin protocol
Please see: Appendix IV 9 - Pin connection  on page 268 for a description of the physical con-
nection between the PC's COM port and the RS-422 connector of the external machine.

Setting up an external machine
• Select Settings > General Settings : Machines

• Click the Add button.

• Enter a suitable name for the external machine in the Name field, such as “Betacam”.

• Choose the protocol for the machine from the drop-down list of protocols. Either MMC 
(Midi Machine Control) or Sony 9-pin

• Choose the port over which the machine will be controlled. Either MIDI or COM422 Serial.

• Check the Enable field.

• Adjust the Protocol Properties, the Port Properties and the Settings according to your needs. 
Please see: Machine Properties  on page 77

• Click OK to confirm all the entries and to add the new machine to the list.
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Virtual Multi-track

Templates
A number of Templates suitable for multi-track recording are provided with Pyramix. These 
Templates have all the required settings already in place. If none of the supplied Templates is 
exactly suitable for your task it will save time if you modify the one closest to your needs and 
save it as a Template for future use. Please see also: Project Templates  on page 18

Settings for Multi-track recording
Multi-track recording can be demanding on disk performance, DSP and the host CPU. In order 
to optimize Pyramix for the purpose if not using one of the supplied Templates the following 
settings should be made in the Record Page:

• Flatten Track Numbers: OFF

• Quiet if creation failed: ON

• Prompt for name at end of recording: OFF

• Keep in default library: OFF (Should always be OFF)

Suggested Settings

• Group Recorded Clips: ON

• Increment Take Number: ON

• Prefix with Track Name: ON

To Record audio directly into the Tracks of a Project, using Pyramix Virtual Studio as if it 
were a tape machine:

1. Set the Destination Drive, Resolution and Format.

2. Arm each Track on which you wish to record. In this case, set each Track to Record Ready 
mode (simple Red Dot).

3. Check your input levels using the Mixer, and adjust as appropriate.

4. Position the Play Head Cursor in the Composition where you wish the recording to start.

5. Click the red Master Record button in the Transport Strip or Transport Window. The 
recording will begin, and display a red bar in those Tracks you have armed for recording.

6. Press the Stop button in the Transport Strip or Transport Window to stop the recording. A 
Record Name window will appear.

If you are satisfied with the recording, type an appropriate name into the Record Name box and 
click the Good Take button. This will save an audio Media File of the selected type onto the 
selected Media Drive, with the name you just chose and place a clip in the Timeline, also with 
the same name. If you are not satisfied with the recording, click the Delete Take button and the 
recording will not be saved. The third option is Bad Take. A Bad Take is saved and a clip 
placed in the timeline just like a Good Take, but the clip’s color is set to a specific color (defin-
able in the View > General Settings / Layout Page) and are numbered the following way: Take 
1, Take 2, Take 3 (Bad 1), Take 3 (Bad 2), Take 3 (Bad 3), Take 3, Take 4, Take 5 (Bad1), Take 5, 
and so on… This helps manage takes where there are mistake(s) but the user wishes to keep 
them anyway.
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To Punch In audio directly into the Tracks of a Project, using Pyramix Virtual Studio as if it 
were a tape machine with punch in capabilities:

1. Set the Destination Drive, Resolution and Format as above.

2. Arm each Track on which you wish to punch in. In this case, set each Track to Record 
Punch In mode (Red Dot with 2 vertical bars).

3. Check the input levels using the Mixer, and adjust as appropriate.

4. Mark a punch in record In and Out point. This can be done either by marking a selection 
area on a Track, or by setting a Mark In and Mark Out on the Time Scale bar. The simplest 
way to mark a selection area on a Track is to click and drag in the Track: a darker gray rect-
angle indicates the selected area. The simplest way to set a Mark In is to Shift-click on the 
Time Scale bar: a movable red triangle and vertical line indicates the Mark In. The simplest 
way to set a Mark Out is to Ctrl-click on the Time Scale bar: a movable green triangle and 
vertical line indicates the Mark Out. A selection takes precedence over Mark In and Out for 
punch in.

5. Position the Play Head Cursor before the marked In point or Selection area.

6. Press the red master Record button in the Transport Strip or Transport Window. The Play 
Head will begin moving through the Composition, and Tracks will begin playback. Record-
ing will begin on the armed Tracks as soon as the selection area or Mark In point is reached 
during playback. A red bar will be displayed in those Tracks which are recording.

7. The recording will stop automatically when the selection out or Mark Out point is reached. 
The Play Head Cursor will continue playing through the Composition.

8. Press the Stop button in the Transport Strip or Transport Window to stop playback. A 
Record Name window will appear with the same options as a normal recording.
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Digitizing Sessions

A Digitizing Session is a special type of Pyramix Project which is intended for efficiently load-
ing audio material into Pyramix. One advantage to using a Digitizing Session for capture is 
that Master Clips referencing the audio Media Files can be generated and saved directly into a 
specified Library for later placement..
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Manual Digitizing
1. In the Media section, choose an appropriate Media Folder to which to your captured files 

will be saved. If you wish to simultaneously save Master Clip references to these Media 
Files into a previously created Library, select that Library from the Library drop-down list.

2. In the Data section, choose the appropriate Resolution (bit depth or word length) and For-
mat (file type) for the saved audio files. Check One File per track ON to generate a separate 
file for each Track recorded. I.e. two files for a stereo source, six for a discrete 5.1 source and 
so on.

3. In the Input radio button matrix, check ON for each Input you wish to record from. Also set 
the Sample Rate, Input Format and Sync Source as appropriate.

4. Type in a New Take Name to name the captured files. If the Auto Increment Take Name 
box is checked all subsequent takes will use the name typed in the New Take Name field as 
a ‘seed’ with a numerical suffix to denote the individual takes. E.g. Enter ‘Vocal’ as the New 
Take Name, check the Auto Increment Take Name box and record a few seconds, stop then 
record another few seconds. The first take will be called ‘Vocal’ and the second ‘Vocal 2’

5. You can monitor incoming audio through the Mixer. Click on the Show/Hide Mixer icon to 
display the Mixer, and set levels as appropriate.

6. Any external machine can be used as the source. However, it is much more convenient to 
use a machine which can be controlled by Pyramix. A machine can be selected from the 
Machine drop-down list. It’s control panel appears below the list.

7. Locate the required material on the source tape.

8. Click on the red Record button to begin recording. The system will remain in record until 
the Stop, Pause or Cancel button is pressed.

9. Press the Stop button to stop recording.

10. You can press the Audit button to audition the recording just made.

11. Press the Accept button to save the recording to the destination Media Folder, or press the 
Cancel button to delete the recording without saving it.

Autoconforming
1. Pyramix can record audio selectively according to an EDL (Edit Decision List) in the CMX 

format.

2. Follow the set-up suggestions above and ensure the source machine is working correctly 
under 9-pin control.

3. Click the Load EDL button, navigate to the directory containing the EDL you wish to load 
the audio for.

4. If the list is not already in Reel order, click the Optimize button. This will sort the list so that 
audio is digitized with the minimum of reel changing and spooling.

5. Load the first reel in the list, click the Capture button and Pyramix will automatically con-
trol the source machine. All the required audio in the reel will be digitized.

6. Change the reel when prompted until all the required audio has been digitized.

If you know the audio is not available for certain edits in the list, or you wish to digitize only cer-
tain edits, uncheck the box(es) in the Status field for the relevant entries before clicking Cap-
ture. The Status filed will show when clips have been captured which match the edits.

Enable All

Checks all the boxes in the Status Field for capture.
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Disable All

Un-checks all the boxes in the Status Field. I.e. no edits are selected for capture.

Reset Status

Restores the Status Field check boxes to their previous state.

Export Report

Exports an .rtf file detailing the edits which were captured and those which were not.

Handles

Sets an extra amount of audio to be captured at each end of the edits. This allows greater free-
dom in editing but may cause problems in some circumstances.
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Source - Destination Editing

Concept
Source - Destination Editing is a powerful method of viewing and editing material especially 
applicable to editing multiple, multi-track, takes into one, ‘ideal’ take. Special Source and Desti-
nation Track Groups allow multiple Timelines to be visible simultaneously. Each Source and 
destination Timeline has its own zoom level and Playhead cursor. By taking advantage of the 
‘Collapse’ feature, editing 48 track source material becomes almost as simple as editing mono or 
stereo.

Source - Destination editing can also be extremely useful in broadcast and tracklaying applica-
tions. Pyramix can have as many clip editors as you wish. Just create some tracks, group them, 
set the group as a Source. Set the clip editor track or tracks as ‘always visible’ (in the Tracks Tab 
Window, so each clip editor always stays on top of the composition and that’s it.

If there’s no Destination group in your composition then the section between the Gates in the 
Source Group/Clip Editor is sent to the positions delineated by the Mark In/Mark Out on the 
selected track(s) in the composition.

Setting up a Source - Destination  environment

Templates
The quickest and easiest way to get started with Source - Destination editing is to use one of the 
supplied Templates. Choose the one which most closely matches your requirements, modify to 
taste and save as a Template for future use.

Starting from Scratch
In the Track Groups window, Create as many Source groups as there are alternate versions of 
the  material  you are editing and select their type as Source.

Tip: Create a Group, select its type as Source then choose Tracks > Duplicate Selected Track 
Group repeatedly until you have the required number of Source groups.

Create as many Destination groups you want to edit to (generally only one) and select its (their) 
type as Destination.

Create as many Tracks for each source take as you need for your editing and associate a Group 
to each of them.

Set these groups as Keep Cursor, Free Zoom, Auto-Solo and No Selection.

Select the option "Auto Select Tracks" in the Tracks menu. Tracks > Auto Select Tracks

Show the Source - Destination Toolbar, View > Scales > Toolbars > Source - Destination.

You are now ready to proceed with the Source - Destination Editing the following manner:

Source and Destination Groups have special markers called Gate In and Gate Out which can be 
set, nudged and auditioned:

Set the selected Track Group Gate In/Out of the selected Track Group to Cursor with the menu 
Cursor & Marks > Gate In/Out to Cursor

To remove a Gate set it again in the same position
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Gates can be dragged with the mouse by clicking on them and moving.

Gate colors:
By default, Gates are displayed in Grey.

The Source Gates currently selected for the next edit operation are displayed in White.

The Destination Gates currently selected for the next edit operation are displayed in Black.

The current Source and Destination Gates for the next edit operation are the selected group 
Gates or if no groups are selected the last group where Gates have been set/removed/modi-
fied. 

In 3 point editing, the “virtual” missing gate of the group that has only one gate set is displayed 
in Grey.

Set the Cursor to the selected Track Group Gate In/Out

Cursor & Marks > Cursor to Gate In/Out

Zoom to the selected Track Group Gate In/Out.

Cursor & Marks > Show Gate In/Out

Nudge the selected Track Group Gate In/Out with the menu selection

Cursor & Marks > Nudge Gates > Nudge Gate In/Out to Left/Right.

Each nudge operation can be auditioned automatically by setting 'Audition

after Nudge' in the View > General Settings / editing Page.

Audition the selected Track Group Gate In/Out Pre/Through/Post with the

menu selection: Machines > Internal Machine > Audition > Audition Gate In/Out

Pre/Audition/Post.

The space between Gate In and Gate Out can be selected with the menu

Selection > Select between Gates.

Positions of Gate In and Gate Out for each selected groups can be displayed and manually 
modified with the Source-Destination Toolbar (If not already visible show with View > Scales 
> Toolbars > Source-Destination)

Once Gates In and Out have been set, Source - Destination operations can be applied FROM 
either the selected Source Track Group or the last Source Track Group whose Gates have been 
set TO either the selected Destination Track Group or the last Destination Track Group whose 
Gates have been set.

Both Source and Destination Gate In and Gate Out can be set or removed

(by setting them twice at the same position) to perform any combination of Source - Destination 
editing operation described in the table below.
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When Gates are set the following Source-Destination operations available in the Edit menu can 
be applied:

• Auto-Edit Source to Destination

• Overwrite Source to Destination

• Insert Source to Destination

• Replace Source to Destination

• Fit Source to Destination

When the Source has only 1 Gate then the region to edit can be automatically adjusted to the end 
(or beginning in case of a single Gate Out) of the clip under the Gate when the edit operation is 
performed. This is available by choosing the menu item:

Edit > Source – Destination Settings > Limit 1 Gate Sources to End/Beginning of clip.

When the Source has 2 Gates set and the Destination has 1 Gate set, then the behavior of the 
Auto-Edit Source to Destination operation can be chosen between Overwrite or Insert by choos-
ing the menu item:

Edit > Source- Destination Settings > 3 Gates Auto-Edit does Overwrite/Insert

The menu item:

Edit > Source - Destination Settings > Auto Set Destination Gate In after Edit

allows the Destination Gate In to be set to the previous Destination Out point after any Source-
Destination operation. This automatically prepares the Destination for the next operation. The 
Destination is also automatically centered around the new Gate In.

The menu item Edit > Source - Destination Settings > Auto Set Destination Gate In after Edit 
allows the Destination Track Group to be automatically selected after any Source-Destination 
operation.

All these operations works independently of the Auto-Ripple mode (they have their own over-
write/ripple modes described in the table on the next page) but follow the Auto-Crossfade set-
tings accessible in the menu Edit > Auto-Crossfade.

Keyboard Shortcuts
Note:  Most Source Destination operations are available as Keyboard Shortcuts.
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Source-Destination 
operations

 Source
Gate In OR Gate Out Only

Source
Gate In & Gate Out

Destination
Gate In OR Gate Out Only

Auto-Edit: Performs 2 points 
editing by doing the following 
Overwrite operation.

Overwrite: Copies material 
FROM Source Gate In to the end 
of the Track or from start of Track 
to Gate Out
TO Destination Gate In or Desti-
nation Gate Out by overwriting 
Destination material

Auto-Edit: Performs 3 point editing by 
doing the following Overwrite or Insert 
operation depending which one is selected 
in the menu Edit > Source-Destination 
Settings.

Overwrite: Copies material between 
Source Gate In and Source Gate Out to 
Destination Gate In or Destination Gate 
Out by overwriting Destination material

Insert: Copies material between Source 
Gate In and Source Gate Out to Destina-
tion Gate In or Destination Gate Out by rip-
pling Destination material

Destination
Gate In & Gate Out

Auto-Edit: Performs 3 points 
editing by doing the following 
Overwrite operation.

Overwrite: Copies material from 
Source Gate In or Source Gate 
Out to Destination Gate In and 
Gate Out by overwriting Destina-
tion material

Auto-Edit: Performs 4 point editing by 
doing the following Replace operation.

Overwrite: Copies material between 
Source Gate In and Source Gate Out to 
Destination Gate In by overwriting Destina-
tion material.

Insert: Copies material between Source 
Gate In and Source Gate Out to Destina-
tion gate In by rippling Destination material

Replace: Replaces material between Des-
tination Gate In and Gate Out by material 
between Source Gate In and Source Gate 
Out by rippling the Destination material 

Fit: Replaces material between Destina-
tion Gate In and Gate Out by material 
between Source Gate In and Source Gate 
Out by stretching or squeezing the Source 
material
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Automation

Pyramix Virtual Studio is equipped with an extremely powerful automation system, including 
both dynamic and snapshot automation of levels, pans, effects, etc. 

Automation Modes
Every control in the mixer can be set to one of four dynamic automation modes. The automation 
mode can be set for individual controls, for channel strips, for busses, for groups of controls or 
for the whole mixer. The current mode is shown by the absence, presence and color of small 
indicators.

Isolate
Black triangle indicator.

The control(s) are isolated from any automation moves already recorded. Controls can be 
moved without affecting existing automation data.

Play
Green triangle indicator.

The control(s) follow the last automation data recorded for them or maintain their default posi-
tion where no previously recorded automation data exists.

Record
Red triangle indicator.

With the transport in Play, and the Master Automation Controls in Write mode, the current 
state of all controls in Record mode is recorded as automation data.

Auto-Write
No indicator.

(This is the default for all controls)

With the transport in Play, and the Master Automation Controls in Play or Write modes, the 
control(s) play back previously recorded automation data. When a control is moved new auto-
mation data is written until the control is released. Behavior when the control is released, or the 
transport stopped, is governed by the choices made in Automation > Automation Settings.
mix Virtual Studio User Manual
151



User Manual :   Automation

P

Automation Settings
Select Automation > Automation Settings from the Toolbar.

If the Write to End radio button is selected, any control in Record or Auto-Write modes which 
has had its value altered since the transport was started will, when released or when the trans-
port is stopped, retain its current value and this will be written to the end of the Composition. If 
the Auto Release radio button is selected any control will, when released or when the transport 
is stopped, return to its value or state in the previous automation pass or the default where no 
previous pass exists. This occurs either immediately if the control only has two states (e.g. a but-
ton) or over a period of time if the control is a fader or knob. The time period is determined by 
the value entered in the Release Time box.

The Refresh Rate setting determines the rate at which the automation data is recorded. By 
default the refresh rate is the same as the actual time code frame rate, e.g. 40 ms at a frame rate 
of 25 fps.

The possible range of the refresh rate is 10 to 100 milliseconds. Please note that your setting is 
rounded to entire frames, so that the effective refresh rate will be either one, two or three times 
the actual frame rate. 

One reason to choose a slower setting for the refresh rate would be to save the processing power 
required to calculate the automation movements in case of complex mixes.
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Selecting Automation Modes

Entire Mixer
The entire mixer can be set to the same mode by right-clicking in a blank area of mixer panel 
(E.g. under the bus strips) and selecting the desired mode from the popup menu. Mixer > Auto-
mation > Isolate.

Block, Strip, Bus or Entire Mixer
Right-clicking in a mixer channel strip function-block, e.g. as shown here in the fader area, pops 
up a contextual menu. Selecting Automation opens a sub-menu offering a choice of the four 
automation modes.

This contextual menu also enables the automation mode for the whole strip, one or more busses 
or the entire mixer to be set by choosing Strip, Bus or Mixer.
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Selecting one of these opens a sub-menu. The last choice in each case is Automation. selecting 
this opens a further sub-menu offering a choice of the four automation modes.

Master Automation Controls
The Master Automation Controls are in a dockable Tool Palette, by default located at the bot-
tom right side of the main Pyramix window. There are Off, Play and Write buttons plus two 
buttons with camera icons which deal with Snapshot automation.

When the Off button is pressed, no existing automation data is played back and no new data is 
recorded when controls are moved.

When the Play button is pressed it ‘lights’ green. Controls set to Play, or Auto-Write, play back 
existing automation data, otherwise they maintain their default values. Controls set to Isolate 
or Record maintain their current values and no new data is recorded.

When the Record button is pressed it ‘lights’ red. Controls set to Record record their current 
values. Controls set to Auto-Write only record when they are moved. Controls set to Play play-
back existing automation data (if any). Controls set to Isolate maintain their current values.

The Snapshot button inserts an automation event (key frame) which records the state 
of all enabled controls at the current cursor position.

The Snapshot Range button inserts automation snapshot key frames of all enabled 
controls at the Mark In and Mark Out cursor positions. In effect this sets all enabled 
controls to the current state throughout the range defined by the marks.
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Display and Editing of Automation Data
The automation data recorded for any control can be viewed and edited on any track in the 
Timeline. 

Clicking the  Show/Hide Automation button in the Track Header displays or hides auto-
mation data as a black line when being replayed and a red line when being written. Right-click-
ing the Show/Hide Automation button pops up the automation menu for the track.

Virtual Tracks
To view more than one automation parameter for a track, create Virtual tracks for each parame-
ter you wish to view. Please see Virtual Tracks  on page 97

Connected Strip
Enables automation data for any control on the mixer strip to be selected for display via sub-
menus. In this illustration the gain of band 2 Eq of the strip-tools plug-in will be displayed.

Mixer
Functions in the same manner as Connected Strip but enables display of automation data for 
ANY control on the current mixer. Auto Display should normally be left unchecked when using 
this option. (see below)

Auto Display
When Auto Display is checked the automation data displayed will be from the last control con-
nected to the track which has changed state. 

Note that, if Auto Display is used when a control has been selected for display using Mixer then 
if a control on the strip connected to the track is moved display of the control selected using 
Mixer will be lost. The automation data is retained. For this reason Auto Display should nor-
mally be off when any control not on the connected strip is displayed.
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Trim
When automation Trim is invoked a dialogue box opens which enables the automation points 
values in the currently selected range to be trimmed:

Values can be increase by simply typing the number of dB required or decreased by typing - 
before the number in the Trim box. The Fade box allows a value in ms to be entered. This 
defines the length of fade which is automatically applied at the beginning and end of the 
selected range from and to the original values.

Note: dB applies to level changes. If the automation curve is displaying frequency, values will 
be in Hz and so on.

Show Versions
Opens the Automation Tracks window

Controls
The Controls pane displays all the automatable controls in a tree structure. The last control 
write is automatically selected. The Automation Tracks Versions pane shows all the automa-
tion passes for the selected control in a tree structure. Double-clicking a version makes it cur-
rent. If a previous version is made current and a further automation path written, a 
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sub-branch results. In the example above four passes were made then version 3 was recalled by 
double clicking it. Two further passes were made labelled 3.1.1 and 3.1.2 The times when the 
passes were written reflects this.

Delete Current Version
Deletes the selected version. Subsequent passes are re-numbered as necessary.

Clean Up Versions
Deletes all versions except the most recent.

Delete All Versions
Deletes all the automation passes for the selected control.

Clean Up All Tracks
Deletes all versions except the current one for all tracks.

Delete All Tracks
Deletes all automation information for all tracks.

Undo/Redo
The menu item Edit > Undo/Redo also reacts to Automation actions providing a shortcut to the 
Automation Tracks Window.

Editing Automation data
Automation data can be edited directly with the mouse. When the mouse is over the of automa-
tion curve, the cursor changes into a hand. When the mouse is over a node of the automation 
curve, the value and timestamp of the point is displayed.

The value can be adjusted by clicking on the node and dragging. If you click anywhere on the 
automation curve, a new node will be inserted.
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If you hold the Ctrl key while dragging on the automation curve, the mouse pointer will turn 
into a pencil. The curve can then be drawn freehand.

Automation in editing and libraries
You can use the Automation menu Cut/Copy/Paste functions to copy data (even between 
projects). Just select a region and select Automation > Copy Selected Points, then choose which 
list(s) to copy, then go into another project (or the same) and select Automation > Paste Points 
to Cursor or Paste Points to Original TC.

If you enable the menu item Edit > Enable Automation Cut/Copy/Paste then any editing oper-
ation on clips also applies to all associated automation data (cut/copy/paste, Auto-Ripple, 
etc…)

If you drag a clip(s) to a library, all automation over that clip(s) is copied/pasted as well.

Mixer and Plug-in Snapshots
Note: Mixer Snapshots as described here use the dynamic automation mechanism.

Mixer Snapshots
Snapshots of the entire state of the mixer surface may be easily and quickly saved and recalled.

Saving Mixer Snapshots

To save a Mixer snapshot hold down Alt and Shift then Click anywhere on the Mixer surface 
and drag to a user library. A new item of the type Mixer Snapshot will appear in the library. 
The snapshot is named Mixer Snapshot by default. To accept this name just hit Enter. Other-
wise, type a suitable name then hit Return.

Recalling Mixer Snapshots

To recall a mixer snapshot simply click on it in the library, drag it over the mixer surface and 
release. All parameters will be reset to the values stored in the snapshot.

Note: A Mixer Snapshot includes all Plug-in Parameters.
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Effects Snapshots 
Effect Settings can be easily stored and recalled by dragging them to/from libraries. 

Creating Effects Snapshots 

Hold Alt + Shift, then click and drag from a Plug-in window to the library where you want to 
store the settings, then release. A new item, of the type Mixer Snapshot, is stored in the library. 
The snapshot is given the name of the plug-in by default. The new item is automatically high-
lighted so, if you wish to change the default name, simply type the new name and hit Enter to 
confirm. The name of the snapshot can be subsequently changed by clicking on the name in the 
library, then entering the new name.
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Virtual Transport

What is Virtual Transport?
Virtual Transport is a separate application that enables various applications to communicate 
with each other through a common interface and to be synchronized to the same timecode. I.e. a 
Client Server architecture. The synchronization can be between two or more applications on the 
same machine or between applications on different computers. This is transparent to the user 
regardless of the location of the client applications.

The server application is launched automatically when Pyramix is started if:

Enable Virtual Transport Communication is enabled in the:

Settings > General Settings : Virtual Transport Page

When the server application is running, the VT icon appears in the task bar notification area on 
the right side of the task bar near the clock display. 

Please see the Virtual Transport Guide for a full description of Virtual Transport.
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Strip and Bus Tools - Plug-ins

Eq, Comp/Limiter/Expander
Strip and Bus Tools are a quick and efficient way of adding the Equalization and Dynamics 
(compression and expansion) functions commonly found on hardware consoles to channels and 
busses. Strip and Bus Tools are particularly economical with DSP processing power. Each pro-
cessing block may be switched ’into circuit’ individually. Blocks which are not ‘in circuit’ do not 
use DSP resources.

Difference between Strip Tools and Bus Tools
There is only one difference between Strip and Bus Tools. Bus Tools have a sophisticated Limiter 
with Look-ahead and Delay Compensation where Strip Tools has a Compressor.

Both may be freely used in Strips or Busses if the need should arise for a limiter in an Input Strip 
or a Compressor in a Bus. 

Modules
The Strip and Bus Tools plug-ins consist of several Sections or modules. Each Section has a title 
bar at the top containing an On/Off switch for the section and a control triangle which toggles 
between showing or hiding the section.

Display Options
Multiple instances of the Bus Tools plug-in are displayed in one large window. Right-click onto 
the window title bar of the plug-in to open a menu offering some general display options for the 
Strip Tools plug-ins:

This menu allows you to either directly select the number of strips displayed in the plug-in win-
dow, or to increment/decrement this number by one.
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Linking Strip-Tools controls
Any choice of Strip Tools controls can be linked together. When you move any of the controls 
which is a member of a link group, all the other members of the group also move. There are 48 
link groups for linear/rotary controls and 48 link groups for switches. 

To add a control to a link group, right-click on the knob or button to display its Link Status and 
Automation Status pop-up window. E.g. this is the pop-up for an input gain control.:

Group assignment mode buttons

These four buttons define the link mode of the control. Four choices are available:

None The control is not a member of any group.

Group The control is a member of the selected group. When you move (or 
switch) this control or any other control which is a member of this 
group, all the members of the group will move (or switch) along with 
it.

Exclusive This mode is only available for switches. With this mode selected, 
when this switch is on, all the other members of the group will be 
switched off.

Group Exclusive This is a mode which has a superior effect on all groups which are set 
to Group Exclusive. When any of the groups which are set to Group 
Exclusive is switched on, all the other groups set to Group Exclusive 
will be switched off.

Grouped controls are indicated by a yellow L in the corner of the con-
trol ‘block’.
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Factor X Slider Works only on continuous (rotary or linear) controls. It determines the 
gearing of this control in relation to other members of the group and 
vice versa. E.g, assume the input gain of strip tools #1 and the input 
gain of strip tools #2 are both assigned to group one. The scale factor of 
the gain of strip tools #2 is set to 2. Now when you change the gain of 
strip tools #1 by 1 dB, the gain of strip tools #2 will change by 2 dB’s.

Invert Also works only on continuous controls. It inverts the effect of the 
movement for this control caused by another group member or vice 
versa. E.g, assume the input gain of strip tools #1 and the input gain of 
strip tools #2 are both assigned to group one. The invert button of the 
gain of strip tools #2 is on. Now when you increase the gain of strip 
tools #1 by 1 dB, the gain of strip tools #2 will diminished by 1 dB.

Automation mode switches
Please see: Automation  on page 151 for a description of the automation mode switches.

When a grouped control is clicked, all other members of the group are shown with a yellow box 
around them. 

Offset

If controls are offset when grouping is turned on, they retain the offset as shown here.

The red bar at the top of the strip indicates it is selected. The grayed out knob is the one which 
was right-clicked.
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Sections
From top to bottom, Strip Tools contains the following Sections:

Input Level
This section contains the input level control and shows the name of 
the mixer strip this instance of the plug-in is assigned to.

Dynamics
This section contains a compressor. It can be switched, as shown 
here, to act as a decompressor. 

Expander
This is a downwards expander. It can also be switched to act as an 
upwards expander.

Equalizer
This is a five band fully parametric equalizer. Each band can be 
switched to high or low pass, shelving or peaking characteristics.

Output
This section controls the output level of the strip tool and also offers 
automatic gain make up for the compressor.

Common Features
Each Section or module of Strip and Bus Tools has a number of controls in common.

Title Bar

A text description of Section’s function, e.g. Input, Dynamic etc. Also contains:

Show/Hide triangle

At top left of every Section a grey triangle toggles between showing or hiding the section. Click-
ing a triangle with Shift held down opens the Section (If hidden) and hides all other Sections. 
Clicking a Section with Ctrl. held down opens all Sections.

Note: Sections remain active when hidden.
yramix Virtual Studio User Manual
164



User Manual :   Strip and Bus Tools - Plug-ins

Pyra
Section On/Off Button

Between the Show/Hide triangle and the Section Title is the On/Off button for the Section.

Input Section

Strip Name

Displays the name of the strip the plug-in is assigned to. The name for the plug-in can be 
changed by double-clicking on the strip name, then typing in a name and hitting the Return key 
to confirm. If a plug-in name is changed in this way, subsequent changes to the parent mixer-
strip name do not affect the plug-in strip name. To recover the name of the parent strip, simply 
remove the strip name.

The strip name is saved with presets and within Pyramix projects.

Activate/deactivate plug-in

This button switches the entire Strip plug-in on or off. Note that when the plug-in is switched 
off, it doesn’t consume any DSP power.

Show/Hide input section

Input section on/off

Input level control

Adjusts the input level over a range of -48 dB to +48 dB.

Show/hide Routing

By default Routing buttons are hidden. This button toggles between Showing and Hiding the 
Routing Buttons. Routing remains active when hidden.

Routing Buttons

Determine which audio streams running through the strip will be processed by the plug-in. The 
number of buttons depends on the number of steams controlled by the strip. Currently this 
means one for a mono input channel or two for a stereo input channel but will be 8 for a 7.1 
input channel. Streams which are not selected will be left untouched.

Strip Name

Show/Hide Input Section

Input Level Control

Activate/De-activate Plug-in

Input Section On/Off

Show/Hide Routing

Routing Buttons
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Dynamics section

Show/Hide Dynamics section

Dynamics Section On/Off

Gain reduction display

The bar graph shows the gain reduction/increase generated by the Dynamics Section or by the 
Expander. The range of the display can be switched between +-10 or 20 dB by clicking on the 
bar graph. Scale markings in 1dB increments on the right-hand side of the bar graph make it 
easy to see if the range is 10 or 20 dB. 

Colors are used to denote a gain reduction or increase generated by either the compressor or the 
expander:

• Gain reduction by the Compressor is displayed in Red from top to bottom.

• Gain increase by the De-Compressor is displayed in Pink from bottom to top.

• Gain reduction by the Expander (normal or inverse) is displayed in Green from bottom to 
top. With the compressor in inverse mode, the gain reduction of the expander is displayed 
in Green from top to bottom

Threshold Level Control

Sets the level at which the compressor begins to act. If the input signal level exceeds the Thresh-
old Level, the gain is reduced (or increased in De-Compressor mode) in proportion to the set-
ting of the ratio control.

Ratio Control

Determines the proportion of gain reduction (or increase) for signals above the threshold level. 
If, for example, the ratio is set to 2.00:1, in Compressor mode, if the input level rises by 2dBs 
above the threshold level, the output level will only rise by 1 dB.

Attack Time Control

Controls the time the compressor takes to react when the input level exceeds the Threshold 
Level. The lower the attack time, the faster the reaction.

Release and Hold Time controls

These two parameters work together and control the amount of time the compressor takes to 
react when the input level is above the threshold level and starts fall. During the hold time the 
gain of the compressor remains constant. After the hold time the gain of the compressor is 
changed at the rate set by the release time. The lower the release time, the faster the reaction.

Show/Hide Dynamics Section

Gain Reduction Display

Threshold Level Control

Ratio Control

De-Compress Switch

Dynamics Section On/Off

Attack Time Control

Release Time Control

Hold Control
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De-Compress Switch

Switches the compressor between the compress and the de-compress modes.

In compressor mode, when the input level exceeds the threshold level, the gain is reduced 
according to the setting of the ratio control. In de-compressor mode, when the input level 
exceeds the threshold level, the gain is increased according to the setting of the ratio control.

Expander Section

Show/hide Expander section

Dynamics section on/off

Threshold Level Control

If the input signal level falls below the threshold level, the gain of the expander is reduced (or 
increased in inverse mode) according to the setting of the ratio control.

Ratio control

Determines the proportion of gain reduction (or increase) for signals below the threshold level. 
If, for example, the ratio is set to 2.00:1, in normal mode the output level will be decreased by 2 
dB if the input level is decreased by 1 dB below the threshold level.

Threshold

Input level

Output level

Threshold

Input level

Output level

Compressor mode De-compressor mode

Show/Hide Expander Section

Threshold Level Control

Expander Section On/Off

Ratio Control

Inverse Switch
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Inverse switch

Switches the between normal and inverse expander modes.

Attack/Release/Hold controls

The Expander Section uses the settings of the Attack/Release/Hold controls in the Dynamics 
Section to control it’s timing.

Equalizer section
A fully parametric five band equalizer. Each band covers the entire frequency range from 20 Hz 
to 20 kHz (or higher, depending on the sampling rate of the project) and can be switched 
between peaking, high or low shelving and low-pass or high-pass characteristics. Each of the 
five bands can be switched off. De-activated bands do not consume DSP power.

Show/ Hide EQ Section

EQ section on/off

Pre Dynamics Switch

This switch offers the option to the switch the EQ before the dynamics section. By default the 
EQ is after the dynamics section.

Threshold

Input level

Output level

Threshold

Input level

Output level

Expander normal mode Inverse mode

EQ Section On/Off

Band Filter Type

Band Selector

Gain Control

Frequency Control

Show/Hide EQ Section Pre-Dynamics Switch

Graphic Display Window

Selected Band On/Off

Q (Bandwidth) Control
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Graphic Display Window

This small window displays the settings of the currently selected EQ band in blue color and the 
resulting curve of the whole EQ section in gray color. You can click and drag directly onto the 
handles (the small blue or gray points) of the EQ bands to change the settings within the graph 
window. 

Double-click anywhere in the window to open a bigger version. Please see The Big Graph 
Window  on page 170.

Band Selector

Click onto one of these five buttons to select the band to be manipulated by the Gain, Frequency 
and Q control underneath. A band gets also selected if it is manipulated in the small or big 
graph window.

Selected band characteristics

These five buttons determine the characteristics of the selected EQ band. The choices from left to 
right are High-Pass Filter, Low Shelving, Peak, High Shelving and Low-Pass Filter.

Selected Band On/Off

Switches the selected EQ band on or off. By default the five bands are switched off in order to 
economize DSP power, so don’t forget to switch an EQ band on before you can hear what it is 
doing.

Gain Control

-24 dB to +24 dB, boost and cut.

Frequency Control

The range for each band is depending on the sampling rate of the project:

• For sampling rates up to 48 kHz the frequency range of each band is 20 Hz to 20 kHz.

• For sampling rates up to 96 kHz the frequency range of each band is 20 Hz to 40 kHz.

• For sampling rates up to 384 kHz (e.g. DSD editing) the frequency range of each band is 20 
Hz to 80 kHz.

Q (bandwidth) Control

The range for the Q parameter is 0.2 up to 100. A Q of 0.2 results in a very wide bandwidth, a Q 
of 100 will give an extremely narrow notch.

Output Section

Show/ Hide Output section

Output section on/off

Output Level control

Adjusts the output level over a range of -48 dB to +48 dB.

Output Level Control

Show/Hide Output Section Output Section On/Off

Auto Gain Make-Up Switch
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Automatic Gain Make Up switch

When lit, Output gain is automatically adapted according to the settings in the Dynamics Sec-
tion. In this case the Output Level Control will be grayed out and inaccessible.

The Big Graph Window
The big graph window opens when you double-click the small graph window inside the EQ 
Section. The current settings of the selected EQ band are displayed as a blue line and the result-
ing overall EQ curve is displayed as a gray shaded area. Frequency and Gain parameters of 
each of the five bands can be altered by clicking on a band’s handle and dragging with the 
mouse. Handles of bands which are not selected are displayed as small gray squares. Grabbing 
and drag a handle selects the band.

The frequency response display uses two separate gain scales. The left hand, blue scale shows 
the scale used for individual bands. The right hand, gray scale shows the scale for the overall 
EQ curve. Both scales automatically adapt their range according to the settings of the curves 
they apply to. The range of the left and the right scale my be different. The ranges for the indi-
vidual bands can be either +/- 6 dB, +/- 12 dB or +/- 24 dB, but the scale for the overall curve 
may go up to +/- 72 dB.

The upper area of the Big Graph Window provides an On/Off switch and buttons to select and 
indicate the characteristic (High-Pass, Low Shelf, Peak, High Shelf or Low-Pass) for the selected 
EQ band together with numeric displays of Gain, Frequency and Bandwidth.

Frequency and Bandwidth setting.

Shortcuts

• Double click on a handle to reset the gain of this band to unity.

• The Tab key switches between EQ bands.

• Clicking and dragging a handle with the right mouse button alters the Q (bandwidth) of 
this band.

• Hold the Ctrl key while dragging with the left mouse button to lock the gain parameter and 
only change the frequency.

• Hold the Shift key while dragging with the left mouse button to lock the frequency param-
eter and only change the gain.
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Bus Tools
Bus Tools are very similar to Strip Tools but are specifically designed to be inserted into busses 
rather than channels. Bus Tools combine the most frequently used ‘mastering’ processing 
blocks you find on the output busses of a mixing console in a single plug-in, including an 
advanced limiter. Like Strip Tools multiple instances of the Bus Tools plug-in are displayed in 
one large window. The number of instances displayed is user selectable.

IMPORTANT! Pre-Anticipation (PA) and Delay Compensation (DC)
 Delay compensation adds a delay determined by the Pre-Anticipation delay setting to all chan-
nels passing through a Bus Tools plug-in NOT selected for processing.

If two or more Bus Tools are inserted in a Bus with  PA & DC on, the delay times of each Bus 
Tools will add together for all channels:
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Sections
The Input, EQ, and Output sections are almost identical to the ones found in Strip Tools. 
Please see the relevant paragraphs in the Strip Tools section for a full description. Where there 
are differences, these will be dealt with here. Shortcuts, Linking and Automation functions are 
the same as Strip Tools.

From top to bottom, the Bus Tools plug-in contains the following sections

:

Input Level
This section contains the input level control and shows the name of 
the mixer strip this instance of the plug-in is assigned to.

Limiter
This section contains the limiter, which either acts as a standard lim-
iter, but it can also work in conjunction with Limiter DRC section 
below.

Limiter DRC
This section adds a Dynamic Release Compensation (DRC) to the 
Limiter section. This enables very musical control of the release time 
of the limiter.

Equalizer
This is a five band fully parametric equalizer. Each band can be 
switched to high or low pass, shelving or peaking characteristics.

Output
This section controls the output level of the Bus Tool and also offers 
automatic gain make up for the Limiter.
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Main and Input Level Section

Strip Name

Activate/Deactivate Plug-in

Show/Hide input Section

Input Section On/Off

Input level control

Adjusts the input level over a range of -48 dB to +48 dB.

Show/hide Routing

By default Routing buttons are hidden. This button toggles between Showing and Hiding the 
Routing Buttons. Routing remains active when hidden.

Routing Button Matrix

The buttons determine which audio channels running through the Bus will be processed by the 
plug-in. The number of buttons shown depends on the number of channels controlled by the 
Bus. In the case of a multiple surround Bus this may be up to 64. A single instance of Bus Tools 
can process up to 8 channels selected from this matrix.

A 5.1 surround bus will have six buttons. The order of the channels selected by the buttons is 
(from left to right): Left, Center, Right, Left Surround, Right Surround, Subwoofer.

This enables, for example, the Left, Center and Right channels of a surround Bus to be indepen-
dently processed from the surround channels by adding two Bus Tools plug-ins to the Bus and 
selecting L, C, R in the first and LS and RS in the second.

Using Bus Tools on multiple surround busses

Although a single instance of Bus Tools can process 8 channels it is simple to use multiple 
instances to process many more with linked parameters. E.g. with four surround Busses you 
could use 3 instances. Assign the L & R channels of each Bus to Bus Tools A, the Centers of each 
bus to Bus Tools B and the Surround Ls and Rs of each Bus to Bus Tools C. The 3 Bus Tools can 
then be linked as you wish by right-clicking and creating control groups in the yellow matrix. If 
Delay Compensation (see below) is activated all channels will remain time-aligned, even when 
using Pre-Anticipation.

Delay Compensation
Delay Compensation

When the DRC section is active, the plug-in introduces a small delay to the audio signal. Since 
some signals of a bus may not be selected for processing using the routing buttons, these signals 
would not be delayed, and there would be a time misalignment at the output of the bus. When 

Strip Name

Show/Hide Input Section

Delay Compensation

Input Level Control

Activate/De-activate Plug-in

Input Section On/Off

Show/Hide Routing

Routing Button Matrix
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Delay Compensation is on, the same delay is applied to all signals whether selected for process-
ing or not. This results in correct time alignment for all the signals of a bus.

Limiter section
This is a straightforward ‘brick-wall’ limiter with simple Threshold and Release parameters. 
However, the DRC (Dynamic Release Compensation) feature described in the next section can 
be activated to allow very musical control of the release time.

A brickwall limiter is a limiter which guarantees that the output level will never exceed the 
threshold level. On a normal limiter, a high level signal with very fast  attack might cause an 
output higher than the threshold level, with a brickwall limiter this will not happen.

Show/Hide Limiter section

Limiter section on/off

Gain reduction display

The bar graph shows the gain reduction generated by the Limiter Section. The range of the dis-
play can be switched between 6 or 12 dB by clicking on the bar graph. Scale markings in 1dB 
increments on the right-hand side of the bar graph make it easy to see if the range is 6 or 12 dB.

Threshold control

If the input signal level rises above the threshold level, the gain of the limiter is reduced. This 
limiter guarantees that at no time will the level of the output signal exceed the threshold. 

Release control

This parameter controls the amount of time the limiter takes to release. I.e remove the gain 
reduction) when the input level was above the threshold level and starts fall. During the hold 
time the gain of the compressor remains constant. The lower the release time, the faster the reac-
tion.

Limiter DRC Section
DRC stands for Dynamic Release Compensation. In short, this means the release time of the 
limiter is altered depending on the dynamic nature of the signal routed through the processor.

Show/Hide Limiter Section

Gain Reduction Display

Threshold Control

Limiter Section On/Off

Release Control
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Show/hide DRC section

DRC section on/off

Release Acceleration or Modification Display

Shows a curve which illustrates the relationship between the change in dynamics of the input 
signal and the variation of the release time. The curve can be adapted between linear and power 
function characteristics (see also the description of the Curve Control parameter). During play-
back the display will also show a small red ball moving along the curve. This shows the range 
the algorithm is working in.

Gain reduction bargraph
Displays the gain reduction of the limiter while the DRC circuit is active. The scale is fixed at 6 
dB.

Dynamics bargraph
Displays the dynamics of the input signal, which is the basis for the DRC algorithm.

Velocity control
Determines the speed of the DRC algorithm. The lower the value, the faster the algorithm reacts 
to changes of the dynamics of the signal and the more it reacts to dynamics the more the release 
time will remain constant.

Offset control
This parameter basically sets the minimum release time. In this sense the release control of the 
limiter defines the maximum release time, so the release time determined by the DRC algorithm 
will vary between these two times.

Curve control
This parameter controls the characteristics of the relationship between the dynamics of the sig-
nal and the resulting release time 

Show/Hide DRC Section

Release Acceleration or
Modification Display

Velocity Control

DRC Section On/Off

Gain Reduction Bargraph

Dynamics Bargraph

Curve Control

Lookahead Delay Control

Offset Control
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Pre-Anticipation (Lookahead delay) control
This parameter changes the integration time for RMS detection and thus changes the effect of 
the DRC circuit.

The delay setting here also determines the delay that will be applied to signals passing through 
the plug-in NOT not be selected for processing when Delay Compensation is switched ON 

Note: Please note that this parameter delays the all signals running through the Bus Tools plug-
in, so phase or other timing errors may occur when the plug-in is used in places other than the 
mix bus.

EQ and Output Sections
These are identical to the Strip Tools versions.

It is worth noting that, since the Limiter is in this case a brickwall design, the Automatic Gain 
Make-up function compensates for the same amount as the value set by the Threshold Control 
of the Limiter. The resulting signal will be close to, but never exceed OdBFS. If Gain Make-up 
is Off the Output Level Control will act as a ‘ceiling’ control, setting the absolute level of the 
resulting output signal.

Delay Compensation / Pre-Anticipation

Example

In this table Bus Tools Instance 1 is IN circuit for the Left and Right channels of the mix and Bus 
Tools Instance 2 is IN circuit for the Left Surround and Right Surround channels. For the Center 
and Sub-Woofer Channels both Bus Tools are OUT of circuit. BUT  Pre-Anticipation and Delay 
Compensation is switched ON for the channels selected for processing. To ensure proper time 
alignment all channels are automatically delayed by the same total amount. (the 8.71 and 5.8 
figures are arbitrary)

If all channels are selected for processing (in circuit) with linked Pre-Anticipation then there is 
no need to activate Delay Compensation. 

5.1 Surround Mix Bus using two Bus Tools

Channel BUS 1 BUS 2 BUS 3 BUS 4 BUS 5 BUS 6

Routing L C R SL SR SW

Instance 1 IN OUT IN OUT OUT OUT

Delay 8,71 (PA) 8.71 (DC) 8,71 (PA) 8.71 (DC) 8.71 (DC) 8.71 (DC)

Instance 2 OUT OUT OUT IN IN OUT

Delay 5.8 (DC) 5.8 (DC) 5.8 (DC) 5.8 (PA) 5.8 (PA) 5.8 (DC)

Total Delay 14.51 ms 14.51 ms 14.51 ms 14.51 ms 14.51 ms 14.51 ms
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Plug-Ins

Common Master Section
Several of the following Pyramix plug-ins share a common Master Section.

On/Off (Bypass) Switch 
The On/Off (bypass) switch activates and deactivates the effect.

Auto Gain Compensation
When this switch is lit Auto Gain Compensation is in circuit. The function is intended to keep 
the output level of the plug-in approximately equal to the input level.

Output Gain
Manually adjusts the gain applied at the output of the plug-in. The value is shown in dB.

Channel List 
Shows which channel has the plug-in that the window is currently controlling. Clicking the 
arrow drops down a list of all channels that have this plug-in assigned to them. Click on a name 
to selected a channel from the list. The control values will change to reflect the current state of 
the plug-in on the selected channel. This feature enables all instances of a particular plug-in to be 
controlled from the same interface window without opening duplicate windows for each chan-
nel.
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Effects Presets 
Right-clicking in the Plug-in window pops-up a contextual menu which enables the plug-in to 
be Reset to its default values. Presets can be Recalled, Stored or Removed and Imported or 
Exported to and from libraries.

Choosing Presets 

Click on the desired preset from the list. The plug-in's parameters will be set to the values 
stored in the preset. 

Storing Presets 

Creating a new preset stores a snapshot of the current values. Store > New opens the New Pre-
set Name window.
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If the Global box is checked, the Preset will be available in all future Projects.

Default

Choosing Presets > Store > Default makes the current parameters the default. These can be 
from new values or a previously recalled Preset

Modifying an Existing Plug-in Preset 
To modify or update an existing preset, set the effect's parameters to the desired new settings. 
Right-click and select Presets > Store then choose the Preset name in the list to update or mod-
ify. A Store preset dialogue box will appear asking if you wish to replace the chosen Preset. 
Click OK to accept or Cancel to reject. The new settings will overwrite the previous preset 
parameter settings. 

Deleting Presets 
To delete the current preset, right click in the effects window. Then choose Presets > Remove 
then choose the preset you wish to remove.
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Parametric EQ.

The Parametric Equalizer is a four band fully parametric EQ with independent control of boost 
and cut, frequency, and bandwidth (Q factor) for each band. The master section at the top of the 
window behaves as outlined earlier. The equalizer can be operated using the rotary controls at 
the bottom, by directly entering numerical parameters in the boxes below the knobs or by click-
ing and dragging on one of the four colored nodes. Left-clicking enables level and frequency to 
be adjusted, right-clicking then dragging left or right allows adjustment of Q.

All bands are full range. Boost and cut of up to 24dB is available. Q can be set anywhere from 
0.2 (wide) to 20 (narrow).

This button shows or hides the rotary controls.

Peaking / Shelving When lit, the lowest (red) band is switched to shelving response. 
In this mode the Q control for the band is unavailable.

Peaking Shelving When lit, is switched to shelving response. In this mode the Q con-
trol is for the band unavailable.
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10 Bands EQ
This ten band graphic equalizer offers +/-24dB of boost or cut in any or all of ten bands, one 
band per octave, ranging from 32Hz to 16kHz. As with all rotary controls double-clicking on a 
slider knob restores it to zero.

Three Band Tone Control 
A simple three band equalizer which offers a boost or cut of +/- 24dB in any or all of three 
bands.

The Low LPF is a shelving EQ with a slope of 6dB/Octave and a turnover frequency of 100 Hz, 
the Medium BPF has a Q (bandwidth) of 0.8 with a center frequency of 2 kHz, and the High HPF 
is a shelving EQ with a slope of 6dB/Octave and a turnover frequency of 8 kHz.

Dynamics Processing 
A comprehensive dynamics processing module. Functions available include one gate, one 
expander, two compressors, one limiter, and a de-esser. The operation of each of these effects is 
interrelated in this comprehensive dynamics processor, and the user interface shows the opera-
tive dynamic range where each process takes effect
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Thresholds 
Threshold controls set the level above or below which the plug-in will affect the dynamics of the 
input signal. All the threshold settings are on the right of the window. From the bottom up, 
Gate, Expander, Compressor 1, Compressor 2, Limiter, and Input Reference Level.

Reference Level 
Sets the input level reference. E.g, setting the reference level to -20 would mean an input level of 
-20dB is considered to be the equivalent of unity gain for purpose of calculating the input 
threshold levels for all dynamics processes. The reference level value is variable between 0dB 
(unity gain) to -30dB. 

Ratios / Slope
Limit and Gate have fixed ratios, tending to infinity. Ratio settings for the Expander and Com-
pressors are to the left of their respective Threshold controls.

Compression Bar Graph Meter 
The Compression bar graph indicator, above the ratio controls, shows the amount of overall 
gain reduction or increase applied to the input signal. No change is in the middle of the scale. 
Green ‘leds’ above the middle indicate gain increase, red ‘leds’ below indicate gain reduction. 
The display range of the indicator can be toggled between +/-10dB, +/- 20dB, and +/-40dB by 
clicking on it. 
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Time 
The speed at which the dynamics processor responds when signals go above or below any of the 
threshold settings are in this section. Careful setting of these parameters make dynamics pro-
cessing more subtle and less obtrusive. 

Delay

Allows the main program signal to be delayed by 0.01ms to 10ms. Allows ‘brick-wall’ limiting 
since the processor has time to respond to fast transients.

Attack 

Attack Time sets the response speed of the processor when a threshold level is reached within 
the range of .01 milliseconds to 600 milliseconds. 

Release 

Release Time sets the rate at which applied gain change returns to unity after the threshold is no 
longer exceeded. Range is 5 milliseconds to 5 seconds. 

Equalizer 
The equalizer is in the side-chain. I.e. it affects the key signal which triggers the effect of the 
dynamics processor, but does not alter the tonal balance of the main signal. This enables the 
response of the processor to be made more sensitive to certain frequencies than others. This is 
typically used to produce a de-essing effect, used to control excessive sibilance. E.g. boosting fre-
quencies 3kHz to 8kHz range so that a compressor acts when the signal has components in this 
range thus reducing signal level and making the sibilance less obtrusive. 

Q 

Sets the bandwidth of the eq. 

Frequency 

Sets the equalizer center frequency in the range 20Hz to 20kHz. 24dB of Boost/Cut are available. 
The Test button toggles the output of the EQ between side and program chains. When On, the 
output of the EQ is heard. This can be useful when identifying sibilance etc. On/Off toggles the 
equalizer on and off in the side chain. When Off, the program material triggers the processor. 
When On, the signal is in effect, split. The portion sent via the equalizer is used to trigger or 
‘key’ the operation of the dynamics processor on the normal program material.

X/Y Dynamics Response Display 
This shows the threshold and ratio settings for the gate, expander, compressor 1, compressor 2, 
and limiter processes, and the Dynamics Processor's reference level. These are shown as a series 
of colored lines with control handles on a grid representing input level in dB below unity gain 
(0dB) on the horizontal axis, and output gain in dB below unity gain (0dB) on the vertical axis. 
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The legend for this display is as follows: 

Adjusting Dynamics Parameters 
Parameters can be altered by clicking and dragging on the control knobs or by clicking and 
dragging the control handles in the graphic display. Handle controls are affected by other 
parameter settings. In some instances dragging a handle will change more than one parameter.

Dancing Star Real-time Response Indicator 
A red "dancing star" inside the graphic display gives a useful indication of how the processor is 
affecting program material. It shows the output level in real-time when signal is present at the 
inputs. 

Delay
The delay Plug-in provides four delay-based effects. ‘Plain-vanilla’ Delay, Echo, Comb Filter 
and All Pass Filter. The interface is slightly different when Delay is selected

.

Process Line Color Handle Color
Line Slope 
Function

Handle Function

Gate Red *** Gate on/off ***

Expander Green Red Expander Ratio Gate Threshold, 
Expander Ratio

Linear Yellow Green Linear response 
between Expander 
and Compress 1

Expander Threshold

Compressor 1 Green Green Compressor 1 Ratio Compressor 1 
Threshold

Compressor 2 Blue-Gray Blue Compressor 2 Ratio Compressor 2 
Threshold, Com-
pressor 1 ratio

Limiter Red Red Shows Limit Limiter Threshold, 
Compressor 2 Ratio

Reference Red *** Limiter Threshold
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Delay

uses a straight-through signal path at unity gain with no direct (un-delayed) signal present at 
the output. The length of delay can be set in milliseconds, meters or samples. The range of delay 
available is 0 to 800 ms. Delay time can be set with the knob, or by typing in the desired delay 
amount in the text box.

Echo

Echo adds a set amount of delay to the signal passing through it and then mixes this delayed sig-
nal with the direct audio source signal. The delayed signal is always at unity gain. The level of 
the direct signal relative to the delayed signal is set by the Delay Gain control as a factor 
between 0 (full attenuation of the direct signal), 1 (unity gain of the direct signal), and -1 (unity 
gain of the direct signal phase reversed).

Comb Filter

Delays the signal then feeds part of the delayed signal back to the input of the delay. Comb Fil-
ter has the same control parameters as Echo, but the audible effect is quite different because it 
uses a feed backward rather than a feed forward signal path. The name Comb Filter comes from 
the fact that signals with a wavelength which is an odd multiple of half the delay time are can-
celed by the process. This result gives a frequency response chart which looks like a comb, with 
some frequencies (depending on the delay time) missing, like the gaps between the teeth of a 
comb.

All Pass Filter

Combines the processes used in the Echo and Comb Filter effects. The result is a multiple ech-
oed signal with a flat frequency response. The control parameters are again the same as in the 
Echo and Comb Filter effects. Delay Gain has a quite different effect. It doesn’t affect the overall 
level of the output signal. It primarily affects the phase of the signals at different frequencies. If 
set to 1, it inverts the phase of the input signal and there will be no echo. With a gain of -1, the 
input signal there is no phase shift. A gain of 0 means that there is no direct signal component 
and the delayed signals are phase shifted by an amount dependent on their respective frequen-
cies.

Flanger
The flanger produces the characteristic sound which was first produced by playing two copies 
of something, in sync but varying the speed of one copy by holding the flanges of the tape spool.

Pyramix Flanger plug-in simulates this effect by time modulating the signal and feeding it back 
to the input either in phase (positive) or phase reversed (negative). Feedback type toggles 
between Positive and Negative. Depth of modulation can be varied between 0 and 100%, Fre-
quency between 0.05Hz and 5Hz and the Amplitude of the modulation between 0 and 100%
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Angudion
Interesting! Three buttons labeled Stooge, Angel, and Tricky, one knob calibrated from 0 - 100

You work out what it does!
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Mastering Peak/Vu Meters

A precise measuring instrument. The VU meter displays the audio level on every strip where it 
is activated in a common window. It can serve as a master level display replacing expensive 
external hardware metering units. Clicking on a VU meter plug-in opens the meter window. The 
plug-in offers three different level displays, each with the option of Dynamic range display.

Peak VU Both Both+Dynamic
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Peak-Meter
This measures the peak value of the audio signal. 
Peak metering is very useful to check the absolute 
digital level of the audio signal. The Peak meter bars 
are blue and it has a default release time of 16 dB/
second.

VU-Meter
The VU (Volume Unit) meter displays an average 
amplitude level. The VU meter is displayed in 
orange/yellow color, has a default integration time of 
60 ms and a release time of 10 dB/second.

Dynamic-Meter
This display measures the instantaneous dynamic 
range of the audio signal. Basically this is the differ-
ence between the Peak and the VU display. If a pure 
sine tone is measured, the dynamics would be zero. 
The Dynamics meter is displayed in yellow and has a 
default release time of 12 dB/second.

Activating the VU-Meter
The VU-Meter can be added like any other plug-in on 
any strip by choosing Add Effect > VU-Meter from 
the context menu within the mixer strip. The only dif-
ference compared to other plug-ins is that when mul-
tiple instances of the VU-Meter are activated they are 
always displayed within a single window frame.

Display options
The Peak and the VU meter can be displayed individ-
ually with a middle mouse click anywhere within the 
window area of the VU meter. Each click with the 
middle mouse switches between the options Peak 
and VU, only Peak and only VU.

The Dynamics display can be activated by clicking on 
the switches at the top of the meter bargraphs. On 
multi-channel meters (stereo strips, surround mixes, 
etc.), the dynamics are summed together into one 
bargraph, allowing for example to display the 
dynamics of the L, R and C channels of a surround 
mix without the rear channels.
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VU-Meter controls

Most of the display parameters of the VU-meter can be adjusted individually. Click with the 
right mouse button anywhere on the VU-meter to display a dialog allowing to control almost 
any parameters of the VU-meter.

The left side of the control window contains global settings and several predefined presets, while 
the right side has four tab panels.

Switch Display

Clicking on this area cycles through VU, PEAK and BOTH. 

Double VU 

When this button is lit, the peak meter switches to VU characteristics, thus enabling you to run 2 
VU-meters with different settings at the same time.

Level Mark

When lit this inserts a gray bar into the meter display at your desired “nominal” level. When the 
input signal exceeds the mark level, the bar will become light green.
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Global settings and presets
Eight presets are defined which allow you to quickly select a set of parameters which fit best to 
your application.

Double VU

When this option is activated, the peak meter switches to VU characteristics, thus enabling you 
to run 2 VU-meters with different settings at the same time.

Level Mark

This option allows you to set a mark at your desired “nominal” level, which will be displayed 
as a gray bar. When the input signal exceeds the mark level, the bar will become light green.

Timing parameters
These parameters are accessed by clicking onto the Timing tab at the right side of the settings 
window (see also picture above).

Peak integration

This parameter adjusts the integration time of the peak meter for rising levels measured in mil-
liseconds.

VU integration

This is the integration time of the VU meter for rising levels measured in milliseconds.

Peak Release

This is the speed at which the peak meter falls, when the level is decreasing, expressed in dB’s 
per second.

VU Release

This is the speed at which the VU meter falls, when the level is decreasing, expressed in dB’s per 
second.

Dyn Release

This is the falling time of the dynamics display. It is expressed in dB’s per second.

Max Level Hold Time

Preset Name Description

Def. (ref -16) Default preset with a VU reference level of -16 dBFS

Def. (ref -18) Default preset with a VU reference level of -18 dBFS

Fast (ref -16) Preset with fast response times and a VU reference level of -16 dBFS

Fast (ref -18) Preset with fast response times and a VU reference level of -18 dBFS

Slow (ref -16) Preset with slow response times and a VU reference level of -16 
dBFS

Slow (ref -18) Preset with slow response times and a VU reference level of -18 
dBFS

BBC VU (ref -16) Preset with BBC standard settings (slower VU release time settings) 
and a VU reference level of -16 dBFS

BBC VU (ref -18) Preset with BBC standard settings (slower VU release time settings) 
and a VU reference level of -18 dBFS
yramix Virtual Studio User Manual
190



User Manual :   Plug-Ins

Pyra
The highest segment reached will remain lit for a specified time after the level decreases, making 
it easy to see what the maximum level was. This parameter adjusts the length of time the seg-
ment remains illuminated.

Alignment parameters
The alignment parameters affect the scale of the peak and VU meter. They are accessed by click-
ing the Align tab.

VU Ref

This parameter sets the level of the 0 VU point in relation to 0 dBFS (0 dBFS is the value at which 
the maximum value of a sample word is reached. Anything above this level means that the sig-
nal is clipped).

If, for example, the VU Reference level is set to -16 dBFS, the VU meter would display 0 dB when 
the signal is at -16 dBFS.

Peak Color A/B alignment

The peak meter uses three colors depending on the magnitude of the displayed level. Below the 
A point, the color is blue. Between the A and B point, the color is a lighter blue, and above the B 
point, the color is red.

These two parameters adjust the level of the A and B points.

VU Color A/B alignment

The VU meter uses three colors depending on the magnitude of the displayed level. Below the A 
point, the color is dark orange. Between the A and B point, the color is a lighter orange, and 
above the B point, the color is red.

These two parameters adjust the level of the A and B points.
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Scale parameters
These alignment parameters affect the rulers of the peak and the VU meter and also the dB 
range of the display. They are accessed by clicking the Scale tab.

Rulers Max

This sets the maximum level of the range displayed by the peak meter. Usually you would set 
this to 0 dBFs, such that a digital full scale level would reach exactly the top of the scale. But 
since Pyramix uses Floating Point arithmetic, you might theoretically have signal levels above 0 
dBFs, so it may be useful to be able to display them (of course, at the output of the mixer, such a 
signal has to be converted back to an integer number, and would cause digital clipping, so care 
should be taken with signals at these levels).

Rulers Min

This sets the minimum level of the range displayed by the peak meter, and thus influences the 
accuracy and the resolution of the peak and VU meter. Signals lower than the minimum are not 
visible on the meter.

Height

This modifies the height (in pixels) of the VU meter plug-in window as it is displayed on the 
screen.

DSD Filtering options

In the specific case of a DSD session the VU meter offers three filtering options which allow you 
to make sure that your DSD signal is compatible to the AES recommendations concerning the 
high frequency dither noise content. These radio buttons let you choose one of three possible fil-
ters which will be applied to the DSD signal before it is measured by the level meter.

The 20k option applies a 20 kHz low pass filter to the signal, thus only the audible audio con-
tent is measured.

The 20k-50k option applies a band pass filter with a frequency range of 20 kHz to 40 kHz to the 
signal. According to the AES recommendation the signal level in this frequency range should 
not exceed -28 dB.
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The 40k-100k option applies a band pass filter with a frequency range of 50 kHz to 100kHz to 
the signal. According to the AES recommendation the signal level in this frequency range 
should not exceed -20 dB. 

Priority settings
The priority settings are accessed by clicking the Priority tab.

This selects the how much CPU time of the host PC can be consumed by the plug-in, and there-
fore influences the redraw speed and accuracy of the VU-meter. The higher the priority, the 
more CPU time is assigned to the plug-in.

Phase-Oscillo
This plug-in combines a phase meter and a X/Y oscilloscope.

The phase meter displays the phase of a stereo signal within the range of -1 to +1. a value of +1 
means that the left and right channel are completely in phase. A value of -1 means that the left 
and right channel are completely out of phase causing complete cancellation when they would 
be summed into a mono signal. A good stereo mix should be somewhere in between 0 and +1.

The oscilloscope gives you some information about the stereophony and the phasing of a stereo 
signal. A signal which is completely mono appears as a vertical line. If only the right channel 
carries a signal, it is displayed as a straight line at a 45° angle from the bottom left to the top 
right. If only the left channel carries a signal, it is displayed as a straight line at a 45° angle from 
the bottom right to the top left. If the left and right channel are out of phase, this would cause a 
horizontal line.
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A decent stereo mix would appear as a vertically shaped cloud as shown in the example below:

Phase-Oscillo configuration
The Phase-Oscillo plug-in has several buttons to configure it’s operation.

Oscilloscope button

This switches the oscilloscope display on and off. If set to off, only the phase meter is displayed.

Sample interpolation

When this switch is on, the samples of the signals displayed on the oscilloscope are intercon-
nected, resulting in an increased readability of the display.

Setup

This button opens the set-up pane with further options

Working Priority

Choose one of these switches to select the amount of CPU time of the host PC which can be 
consumed by the plug-in, and therefore influences the redraw speed and accuracy of the oscil-
loscope. The higher the priority, the more CPU time is assigned to the plug-in

Drop frame display

Depending on the chosen working priority of the Phase-Oscillo plug-in might not get enough 
CPU time to continuously redraw the display. The drop counter displays the amount of frames 
which could not be drawn because of lack of CPU time since the start of the actual Pyramix ses-
sion.
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Left and Right channel selector

If the plug-in is inserted on a bus with more than two channels (e.g. a surround bus or a multiple 
stereo bus), these two selectors allow you to select the appropriate channels for the left and right 
input of the plug-in. On a surround bus, you might for example select the left front and right 
front channels to be displayed on the Phase-Oscillo plug-in.

Surround Meter
Gives a very useful indication of energy distribution in a surround sound field.

The Surround Meter incorporates automatic gain ranging which maintains a meaningful display 
for a wide range of material. There are no settings to adjust!

DC Meter
Measures the DC content in the signal.
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Modulometer

The Modulometer is a faithful reproduction of the classic meter fitted to Nagra portable Tape 
recorders. 

Common operational practice to is set levels so the meter reads  (average) - 8 when recording 
speech. This is partly due to the modulometer's characteristics as a quasi peak meter (quasi 
because it has the ballistics of a mechanical meter) and it also reflects the caution required in 
location dialogue recording where a lost take can represent many thousands of dollars.  
Although not by any means desirable, a low level signal is better than one with distortion from 
peak clipping. Right-clicking anywhere on the window pops up a context menu. This has sev-
eral options which control the behavior of the Modulometer.

Reset

Restores the default settings

Presets

Offers the standard Preset options

Display (Frame / Sec)

Sets the display refresh rate

Release (dB / Sec)

Sets the Release time

Acceleration (dB / Sec)

Sets Acceleration rate
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Reference (dBFS)

Sets the Reference level in DeciBels Full Scale

Integration (ms)

Sets the Integration time in milliseconds

Hide

Hides the Modulometer

Function Generator
This oscillator can produce a Sine wave, a Pulse wave, a Triangular (Sawtooth) wave, DC and 
White or Pink Noise.
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Plug-in Automation

All Plug-in parameters in Pyramix can be fully automated dynamically. Please see 
Automation  on page 151.

Effects Snapshots 
Effect Settings can be easily stored and recalled by dragging them to/from libraries. 

Creating Effects Snapshots 

Hold Alt + Shift, then click and drag from a Plug-in window to the library where you want to 
store the settings, then release. A new item, of the type Mixer Snapshot, is stored in the library. 
The snapshot is given the name of the plug-in by default. The new item is automatically high-
lighted so, if you wish to change the default name, simply type the new name and hit Enter to 
confirm. The name of the snapshot can be subsequently changed by clicking on the name in the 
library, then entering the new name. 
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Optional Plug-ins

Optional Pyramix plug-ins. For operating instructions please see each plug-in’s guide.

Scopein TimeZone Time Compression

VB Aphro V1 Reverb

Algorithmix DeNoiser 

Algorithmix DeScratcher

Algorithmix DeNoiser + DeScratcher, Restoration Suite 

Minnetonka SurCode Dolby AC3 Encoder

Algorithmix Nova
Overview 

The Nova™ plug-in for the Pyramix rendering interface is an impressive weapon in the battle for 
cleaner recordings. Coughs, chair scrapes even mobile phone tones are all in its sights.

The Nova™ Plug-In enables audio data in the frequency domain to be modified simply and 
quickly. These modifications include interpolation of selected areas over the time- and/or fre-
quency line as well as gain modifications. The interpolation can also be restricted to certain gain 
ranges within the selected area, which is very useful if only a certain part of the data needs treat-
ment (e.g. one specific harmonic etc.) which cannot otherwise be selected. The Nova™ window 
is fully resizable for optimum compatibility with all screen resolutions.

Prosoniq MPEX2 Timestretch and pitch change
Overview

The MPEX2 algorithm for Pyramix has been developed with the German based company Proso-
niq, well known for their high quality digital audio algorithms.

MPEX stands for Minimum Perceived Loss Time Compression/Expansion. Incorporating this 
technology into Pyramix Virtual Studio enables users to adjust timing and pitch of existing 
material with outstanding results and ease of use.

Algorithm

Time Scaling (also known as 'Time Stretching', 'Time Compression/Expansion' and 'Time Cor-
rection') is the process of changing the length of a sound or sounds without changing its pitch. 
When a sound is transposed by playing it back at a different speed, e.g. when slowing down the 
playback speed of a tape recorder, it will play back at a different tempo but also at a different 
pitch. While this may be fine when tuning drum loops to match the speed of a recording it will 
make pitched sounds - like vocals - sound totally out of tune. Therefore it is desirable to provide 
a process that enables the duration and pitch of a recording to be changed independently from 
each other.
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Time Stretch and Pitch Change for Film Applications
There are three main categories of Cinema time stretching and pitch changing requirements:

1)       Conversion of audio rushes from 24 to 25 or 25 to 24 when their associated video or film 
has to be sped up or slowed down. The main reasons are:

a.       The shooting has been done with film AND video, so one part of the rushes or the other 
have to be sped up or slowed down.

b.       The telecine process to bring the film rushes to video for editing didn't preserve the origi-
nal speed, intentionally or by mistake.

c.       The shooting has been done on video at 25fps (intentionally or by mistake) and has to go 
to film.

Pyramix provides various solutions to this problem:

Batch conversion

of a whole media folder. Just select all media to stretch/squeeze / pitch change and select the 
menu Quick Convert > Prosoniq MPEX2 module. All media will be processed in one shot. 
Media will have to be re-synchronized in time with their video equivalent by using the refer-
ence "Clap".

In the case where all the media are already synchronized in time with their video equivalent 
(either manually or because they've been properly stamped while recording), then simply send 
all these media to their original timecode (time stamp) in a Pyramix project and select the menu 
item Project > Stretch / Pitch. All media will be properly stretched/squeezed and their position 
will be also correctly updated. The new original timecode (time stamp) can then be written back 
to the media by selecting the menu item Clips > Operations > Update Media Original TC, so 
these new media can now be used exactly as if they've been recorded and stamped at that new 
speed, allowing also auto-conformation or other timecode based processes. All information 
stored in the clips referencing these media in the timeline (like fades, sync points, gain curve, ...) 
are also stretched/squeezed properly. Optionally the media can be consolidated to convert only 
the required part

The two processes described above are necessary when a mix of different source material speed 
have to be "normalized". In the case where it is known from the beginning that the whole edit-
ing and mix will have to be stretched back to the other (original rushes) speed, Merging pro-
vides a very convenient solution in term of hard-disk space, conversion time and finally sound 
quality. The Virtual Transport Video Player allows playing the video editing at a different 
speed than the audio material allowing matching (for instance and in the majority of cases) a 
video running at 24 frames per second with an audio editing stamped at 25 frames per seconds. 
This avoids compressing the audio so it matches the video being played too fast (25fps instead 
of 24) but preferably run the video at the correct speed (24fps) and therefore the audio also.

Surround Post-processing

Conversion of a final mix from 24 to 25 for DVD/Video distribution of a film or 25 to 24 for film 
distribution of a video shot and edited movie.

Pyramix allows stretching/squeezing a whole surround mix by selecting the menu Project > 
Surround Post-processing and choosing the Prosoniq MPEX2 24/25 Time Stretcher module. 
This function stretches/squeezes a whole 5.1 mix without inter-channels phase artifacts thanks 
to the new Prosoniq MPEX2 algorithm. This function allows processing multiple stem surround 
mixes stem by stem. Due to artefacts introduced by most time stretching algorithms available 
until now, the normal procedure was to separate the dialogue stem and the music/effects/
ambiance stems, time-stretch them separately and remix them afterward. Although the Sur-
round Post-processing function allows this methodology, this is no longer required due to the 
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very high quality of the MPEX2 module. Therefore a complete mix can be stretched in one pass 
retaining maximum sound quality.

Time fit

Compression or expansion of a portion of audio to fit in a given time, generally dialogue, ADR, 
translation or Foley.

Pyramix provides three ways to stretch/squeeze a region of audio:

• Just select the region or clip to process and place the cursor at the position where the nearest 
region boundary should be extended to and select the menu Clips > Operations > Stretch. 
A dialog will then allow the boundaries to be precisely adjusted with the help of timecode 
entries, or simply click OK or press the Enter key to confirm the operation.

• Select the region or clip you want to process and copy it (Edit > Copy, or Ctrl C etc.). Select 
the region you want the copied region to fit into then simply use the command Edit > Fit 
Selection.

• Select the region or clip to process, select the menu Project > Render and choose the Proso-
niq MPEX2 module. 

A comprehensive interface then enables the time-stretch parameters to be precisely adjusted. In 
addition to time-stretching this interface also allows Pitch and Formant adjustments.

Quick Convert

The Prosonique MPEXII process can also be accessed by the Quick Convert function (Media 
Management Tab Window, Menu Convert > Quick Convert > Prosonique MPEXII
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VST / DirectX support

Direct X Plug-ins
DirectX plug-ins may be used in Mixer Input strips and also in the FX Rack Please 
see: MTRFxRack  on page 209

VST Plug-ins
To Load VST plug-ins in Pyramix you first have to tell Pyramix where they are. Go to Start > 
Programs > Pyramix > VST Plug-Ins Chooser. If you have Cubase or any standard VST pro-
gram you will see your VST plugs appear in the left window, select those you want to use in 
Pyramix and press the Copy to MT-VST Plugin Dir button. If nothing appears in the left win-
dow, you just need to have a folder containing all your VST plugins files (they are .dll file type) 
somewhere on your disk, hit the Change button at the bottom of the VST Plug-Ins Chooser win-
dow, browse your disks and select the folder containing the VST plugins. They will now be 
listed and recognized in Pyramix. 

Note: The VST plugins, like Direct-X plugins, are processed by the host CPU. Therefore, if you 
are intending to use VST or DX plug-ins intensively, dual Xeon processors are recommended.
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Mastering a Composition to CD-R

Pyramix can be used to set CD track Start, Stop, and Index Markers for CD-R Mastering, and a 
separate application called DiscWrite is provided to actually burn a CD-R.

CD Markers
CD Markers are much like other User Flags or Markers. To set a CD Start Marker (which indi-
cates the beginning of a CD track), place the Play Head at an appropriate CD track Start location 
and choose Cursors & Marks >Add CD Start Marker to Play Head; similarly, to set a CD Stop 
Marker (which indicates the ending of a CD track), place the Play Head at the appropriate CD 
track End location and choose Cursors & Marks > Add CD Stop Marker to Play Head. A 
named CD Index Marker can also be added using Cursors & Marks > Add CD Index Marker 
to Play Head. These CD Markers can be examined, named and changed in the Project Manage-
ment Panel’s Markers Tab (just as can regular User Markers).

In addition, CD track Start and Stop Markers can be added automatically to Grouped Clips in a 
Composition. To accomplish this, first make appropriate Groups of Clips which correspond to 
CD tracks. Then choose Cursors & Marks > CD Mark Groups from the Toolbar. Follow the 
directions to add the CD Markers.
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Project Processes

Dither
Whenever changes are made to digital audio signals such as mixing, altering gain, eq or reverb, 
the result is usually an increase in the number of bits. These extra bits have to be removed to 
suit the requirements of delivery and interconnect standards. If the bit depth is reduced by sim-
ply ignoring the extra bits (truncation) or even rounding the least significant bit up or down, the 
resulting error can give rise to audible distortion of low signal levels. Obviously, there is also a 
permanent loss of resolution. These effects are cumulative. I.e. If the signal is repeatedly pro-
cessed and bit reduced to shorter word lengths, there will be a significant and audible loss of 
accuracy in subtle, low level sounds. Human hearing makes use of this low level information in 
imaging and unless something is done to avoid the problem, space and clarity will be adversely 
affected.

In Pyramix all processing takes place in 32 bit floating point so, if signals are kept within this 
environment, there is no need for bit depth reduction until the final stage before output. Trun-
cation or rounding are undesirable but a single ‘dithering’ stage can reduce bit depth whilst 
maintaining low level linearity. This is achieved by adding a controlled amount of low level 
noise to the signal. Since there is no such thing as a free lunch, the trade off is a slightly 
increased level of noise. However, the noise can be ‘shaped’ to reduce its perceived audibility.

See also: Dithering  on page 57

It is important dithering is only applied once. 

Mixing Down Projects

Exporting a Composition to a File
Once you have finished editing your Composition, the complete Composition or any selected 
area can be exported to an audio file (or files). This is really the same as mixing down the Com-
position to a file instead of to an audio output.

1. Choose Project > Mix Down to open the Mix Down window.

2. In the Target Settings section, type in an appropriate file name under Record Name; choose 
the folder to which the file will be saved from the Media Folder drop-down menu (only 
previously mounted folders will be available as options); choose the bit depth /word length 
from the Resolution drop down; leave the One file per track box unchecked to make a sin-
gle multi-track audio file, or click it to generate separate audio files for each Track and 
choose the appropriate export file type from the Format pop-up list.

3. In the Record section, choose to export the Whole composition, or the area between the In 
and Out Markers with Between Marks or a previously made Region with Selection by 
clicking the appropriate radio button.

4. Choose the appropriate output bus as the source for the exported file. All output busses 
configured in your Mixer will be available in the Mix Source list box.

5. Click the Mix Down button to begin the process.
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Exporting Projects to CD Image Files
To export a previously Marked Composition to a CD-R image file:

1. Open the CD Tab window. Fill in all CD-R information as appropriate. Choose Project > 
Generate CD Image from the Toolbar. This opens the Generate CD Image window.

2. Choose an appropriate Image name and location for the file, make any other appropriate 
changes to the settings then click the Generate Image button.

Important!  if using SRC, dithering must only be turned on in the Generate CD Image window. 
Please turn dithering OFF in the Mixer to avoid double-dithering with deleterious consequences 
to the sound.

To generate a CD from pyramix you first generate a CD image file. This image file is used with 
the discwrite application to generate CD or DDP.

You can use the DDP import function in pyramix to import your DDP tape and generate a new 
CD image file. From this CD image file you can burn a CD or generate a new DDP tape.
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Burning a CD-R
DiscWrite is a separate application bundled with Pyramix Virtual Studio that is used to write 
the CD-R (or DDP) image file out to a CD-R disc (or DDP tape) unit. To burn a CD-R from a CD 
image file created above:

1. Launch DiscWrite. A normal Pyramix Virtual Studio installation will put a DiscWrite icon 
on the Desktop.

2. In the Image section, click the Open Image... button, then navigate to and select a previ-
ously created CD Image file (an .img file). 

3. In the Device section, click in the pop-up register to select a CD-R device. DiscWrite should 
recognize a previously configured CD-R device which is also recognized by the OS itself.

4. Also in the Device section, click on the Settings... button to open the CD-R Settings win-
dow. Set these as desired for the CD-R burning session. Please see the Pyramix Reference 
Guide for complete explanations of all these settings.

5. When all CD-R settings are adjusted as needed, click the Burn button in the Image section 
to actually burn the CD-R.

Red Book Compatible Masters
If the CD-R is to be used as a “Red Book” compatible master "Disc at Once" MUST be selected. 

Archiving Projects
Menu: Project > Archive This function copies the project and all used media to a single location. 
Optionally all media can be Consolidated, and referenced libraries can be archived as well.
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Consolidating Projects

Consolidating a Composition is a method of reducing the storage space used by Media files and 
of bringing all elements of the Composition together to move it to another machine or storage 
medium. The Consolidate function makes a selective backup of the media used in the Composi-
tion. Instead of backing up the whole of every media file referenced by the clips in a composi-
tion, Consolidate backs up only those parts of the media files that are referenced by the clip 
segments.

Target Settings
The Radio Buttons offer a choice of locations for the consolidated Composition.

Use Original Files Media Folder

The Consolidated Composition will be saved in the same location as the original files

Use Current Project Media Folder

The Consolidated Composition will be saved in the same location as the current Project Media

Use Custom Media Folder

The Consolidated Composition will be saved in a user selected location.
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Options
Handles

To allow for limited further editing of the Consolidated Composition, changing fade durations 
etc. extra material (if it exists), can be retained at each end of every clip, beyond that which is 
defined by the Composition EDL. Enter a value in seconds.

Format

This drop down list enables the Consolidated Composition to be saved in the same format as 
the original or to be converted to any supported format.

Generate Waveform

When checked, waveform files will be generated and saved with the Consolidated Composition

Use clip names to generate media

When checked, the original clip names are used for the newly generated media

Don’t optimize media for overlapping clips

Advanced Options
Skip generation if original media already exists on target drive

When checked new media will not be written where a version already exists on the target drive.

Delete original media (Use with care!)

When checked the original media files referenced by the consolidation are deleted after the con-
solidation is complete. N.B. Destructive!

Converting Projects

Changing Project Length / Pitch
Processes whole Projects. Offers Time Compression or Pitch Reduction of 4% (24fps to 25fps) or 
Time Expansion or Pitch Rise of 4.17% (25fps to 24fps)

Given an Origin Reference and a Ratio all clips of the project are stretched/squeezed and 
moved accordingly to the stretch ratio and origin reference. Optionally all media can be consol-
idated to process only the part of audio required by the clips. This function is available through 
the menu Project / Stretch and requires the Prosoniq MPEX2 authorization key to be entered.

Surround Post-Processing Projects
The Surround Source Stem can be selected from a list of available stems from all Surround bus-
ses.

Available processing plug-ins are:

Multiple File Export

Minnetonka AC3 (Dolby Digital) Encoder (to be purchased separately)

MPEX2 Cinema 24fps to 25fps or 25fps to 24fps Multi-channel Time Stretcher by Prosoniq 
(optional)
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Rendering Projects
The Render function available in menu Project > Render offers a choice of Rendering plug-Ins. 
Currently available plug-ins are:

Glitch and Pops finder

Pencil Tool
For retouching waveforms

MTRFxRack
Enables chains of up to eight VST and or Direct X plug-ins to be used as rendered processes.

Nova
An optional renovation suite plug-in by Algorithmix.

MPEX2
An optional Multi-channel Time Stretch / Pitch Scaling with Formant plug-in by Prosoniq

Cleaning Up Project media
Deletes all Media files in the selected folder which is not used in, or referenced by the current 
Project.

N.B. This operation is NOT reversible. There is no UNDO!
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Project Interchange

Import and Export are handled by InterChange. In the Project menu Import and Export open 
windows where a list of available InterChange plug-ins is presented.

Thus Project > Import and Project > Export open these windows:. 

Options will be grayed out if inapplicable to the selected plug-in or currently unavailable. For 
example, Export selection only is grayed out in the window above because there is no selection 
in the Timeline of the project.
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Akai DD / DR
AKAI disk import

Pyramix is capable of recognizing disks recorded in the Akai DD-Series format and importing 
their data. 

Preparing the system

Connect the Akai disk to your PC. Usually this will be done via a SCSI interface, but can also be 
a Magneto-Optical or a Jaz disk.

Project > Import opens the Project Interchange window choosing AKAI DD/DDR from the list 
opens the AKAI DD-Series File System Loader window

When the window is opened, Pyramix searches for available Akai disks and displays them in 
the upper left part of the window. Choose the disk you want to work with by selecting it with 
the mouse.

The Refresh Disks button restarts the search for available Akai disks.

The lower part of the window shows the data found on the selected Akai disk. Following the 
data structure of Akai disks this panel has three tabs named Project, Libraries and Audio Files.

Import Button

To import the data into your Pyramix session, simply select the desired data and click the 
Import button. The behavior is the same as ‘Quick Import’; All the files are imported and stored 
into a mounted media folder.When an Akai library is imported, a new Pyramix project library 
will be created.

Delete Button

Deletes selected files from the Akai media providing this is not write protected.
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Audio File import

Since Pyramix is capable of reading the audio data directly from an Akai disk, it is not necessary 
to import the actual audio files into a local Windows drive. Thus, when you click the Import 
button, this dialog box is displayed:

If the answer is No, only references to the audio files will be stored in the local Windows Media 
folder instead of copies of the actual audio data. The audio will play correctly but no waveforms 
will be displayed.

CD Import
Pyramix has comprehensive CD import functions. Project > Import opens the Interchange 
Import window. choose the appropriate destination option and choose CD Import

Device is a drop-down list of all suitable drives on the machine.

Read TOC reads the Table Of Contents on the CD and lists the tracks in the left hand pane.

If Read ISRC, UPCEAN and CD Text is checked this information will also be read if present.

Import Options If Import all contents is checked the whole disc will be imported. If Import 
selected tracks is checked only the tracks with a tick in their checkbox will be imported.

Select All and Deselect All do what they say.
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Info The Status line shows useful information about the process as it proceeds. The Track and 
Disc lines are progress meters. Track shows a growing blue bar as the track transfer proceeds 
and Disc shows progress of all selected tracks.

Media Options has three drop-down list boxes to select the Destination Drive, the Format the 
CD audio will be captured in and Waveform determines whether a waveform will be generated 
and, if so, WHILE recording or AFTER. The fourth line is a text entry box which allows a Clip 
Prefix to be set for all imported tracks. (default is CD Import) Checkboxes determine if the 
resulting clips will be placed in the Timeline, whether CD Markers will be added in the Time-
line and whether a Track Group will be added.

Clicking on the Import icon initiates the process.

Settings pops up a window with specific drive settings. These settings may be altered if 
required by clicking on an entry and typing a new value in the box.

CMX EDL
CMX Edls are a set of statement lines which typically look like this:

TITLE: An example of CMX EDL

001 TEST AA C 00:00:24:24 00:00:25:00 00:59:58:00 00:59:58:01

AUD 3 4

* Sine on all tracks

002 DAT12 AA C 20:18:18:07 20:18:21:13 01:02:40:02 01:02:43:08

* Introduction

003 TAPE1 AA C 01:15:07:07 01:15:11:13 01:02:43:13 01:02:47:19

004 TAPE1 NONE C 01:15:14:02 01:15:16:04 01:02:47:19 01:02:49:21

AUD 3 4
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005 TAPE1 NONE C 1000Hz 01:15:14:02 01:15:16:04 01:02:47:19 01:02:49:21

006 TAPE1 NONE C “A sound” 01:15:14:02 01:15:16:04 01:02:47:19 01:02:49:21

Pyramix will extract all the information regarding audio from these EDLs and then paste a set 
of clips into the current composition’s timeline.

There are many CMX formats which differ in details, Pyramix should be tolerant enough to 
accept most of them as long as edit lines fields are well separated by spaces or TABs.

Any errors encountered while parsing an EDL file are stored and reported after loading as 
much of the file as possible. Any non valid lines, missing media or media sampling rate mis-
matches are reported.

Media reconnection
The major problem encountered while importing an EDL is reconnecting to referenced media. 
Pyramix needs all referenced media to be present (mounted) when the import occurs. After the 
import, the newly created composition MUST be saved as a Pyramix project to keep the con-
nection between clips and media.

Media are searched while importing the EDL by Media Source name (or Reel name following 
the EDL terminology), and Source In and Source Out timecodes. So, to be reconnected, a clip 
needs to find in any media folder a media file with a Media Source name matching field #2 in 
the EDL, in the preceding example TEST, DAT12 or TAPE1, and where the original timecode 
and length match the Source In and Source Out field.

It often happens that the media is generated with a different Source (Tape, Reel) name than the 
EDL referencing it. For this purpose we have added a special keyword to the CMX language 
which allows Pyramix to replace one Reel name with another while parsing the EDL.

FIXREEL: DAT12 DAT012This preamble added at beginning of the file will replace all occur-
rences of the reel name DAT12 by DAT012. The preamble can be preceded by the comment 
asterisk (and a space or TAB) so the EDL remains compatible for import by other systems:

* FIXREEL: DAT12 DAT012

It is also possible to add the keyword MEDIANAME, FILENAME or FOLDERNAME at the end 
of this line to tell Pyramix, instead of the Source (Tape, Reel) name, to search for the Media 
name or the Media Filename:

* FIXREEL: DAT12 Ambiance43b MEDIANAME

* FIXREEL: DAT12 d:\pmxmedia\dat12\ambiance43b.wav FILENAME

or to search by TimeCode in the given mounted media folder (this is kind of a conformation to 
existing digitized material):

* FIXREEL: DAT12 d:\pmxmedia\dat12 FOLDERNAME

The keyword OFFSET followed by a timecode can be added at the end of the line to allow 
media without origin (original timecode, source timecode, time stamp) to be referenced, for 
example WAVE files.

* FIXREEL: DAT12 Ambiance43b MEDIANAME OFFSET 08:45:32:00

* FIXREEL: DAT12 d:\pmxmedia\ambiance43b.wav FILENAME OFFSET 08:45:32:00

This covers most cases of media reconnection and should help solve special cases of EDLs 
exported by exotic systems.
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Media reconnection failure

An imported clip whose media has not been retrieved or whose media is not at the same sam-
pling rate as the current project will be associated a ‘fake’ media.

It WILL NOT be possible to retrieve its media file after the import, but it will be possible to asso-
ciate a new media file in the standard way (Control key pressed while dragging a media file 
from a media folder).

CMX Autoconform
When an CMX EDL is not accompanied by audio files on disk an Autoconform can be per-
formed. A Digitizing Session is used to grab the audio referenced by the CMX EDL from an 
external machine (This may be operated under 9-pin control or simple time-code chase). The 
CMX EDL can then be imported into an Editing Project (as described above) to link to the digi-
tized media.

OMF
OMF Import supports both OMF1 and OMF 2 format.

When exporting OMF from another application, there is a choice of either embedding the audio 
files into the OMF file, or keeping them external as a link. Pyramix supports both approaches.

When importing an OMF file with embedded audio, Pyramix will ask if the user wants to 
extracts the media files. Please answer Yes to this question only the first time the OMF file is 
imported. If the same file is imported a second time, there's no need to extract the audio twice, 
simply mount the folder where it's been extracted to prior to importing the OMF file.

When importing an OMF file that references (links) to external audio files, the folder(s) that con-
tain theses files must be Mounted in Pyramix before importing the OMF file. (This also applies 
to Sonic Solution import).

Note: Known limitation: OMF import doesn't support 24bits files for now.

ProTools

Protools 5 InterChange with Pyramix 4.1
Importing and exporting Protools 5 sessions in Pyramix is accomplished via the InterChange 
architecture. This requires Pyramix 4.1 or higher and MacDrive 2000 or MacDrive 5 to be 
installed. MacDrive this is a product of Mediafour Corporation, please see:-

www.mediafour.com

Importing a Protools session

Pyramix supports Protools version 5.0 or 4.x. If you're using are more recent version of Protools, 
first export your session as a version 5.0 session in Protools with the menu "Save Session Copy 
in…". This will create a set of SDII files along with the new session.

Bring your session with the audio files into the Pyramix station by mounting the Mac HFS disk 
or inserting the cartridge in the appropriate reader. Windows and MacDrive support all SCSI 
disks or removable storage like Jaz, MO, removable hard-disks, CD-R, DVD, etc.

If your session comes on multiple CDs (or cartridges) you can copy all the files directly to a 
Pyramix workstation disk. In this case the PC disk has to be formatted as a NTFS volume. We 
recommend using NTFS for all disks.
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Create an empty project in Pyramix or open an existing one. 

Project > Import opens the Interchange - Import dialogue box. Select the appropriate import 
option from the three choices at the bottom using the radio buttons.

These are:

1. Replace the current project by removing all existing tracks, track groups and markers then 
creating new tracks, track groups and markers from the imported composition

2. Append the imported tracks at the bottom of current project tracks

3. Insert the imported tracks into the current project tracks

Then choose the ProTools module from the list. An explorer- style file dialog box Import Pro-
Tools Session will open, browse to the disk containing the Protools session, select it and click 
Open.

The Protools session should appear in your project timeline, creating new tracks if needed.

Create or load a mixing console, connect your tracks and work with your session.

Exporting a Protools session

Load the Pyramix project you wish to export as a Protools session and from the Project Menu 
select the appropriate Export option and the Protools module and click OK. 

Menu: Project > Export opens the Interchange - Export dialogue box. Select the appropriate 
export option from the two choices at the bottom using the radio buttons.

These are:

1. .Export whole composition including tracks, track groups and markers

2. .Export selection only

The latter choice will  only be available if there is a selection or selections in the timeline.

Then choose the ProTools module from the list and click Export. A dialog box, Export ProTools 
Session File will open.  The top of this dialogue box is concerned with file saving and enables a 
suitable destination folder to be chosen or created, a file name to be entered and gives the choice 
of saving ProTools Session *.* or All files *.* By default, the file name entry box contains the 
name of the Pyramix project.

At the bottom of the dialog box Export Settings choices are made. Drop down lists offer the 
choice of saving in ProTools 5.0 or 4.* Session formats and 16 bits or 24 bits. If you wish to 
reduce the amount of data to be exported, select the Consolidate checkbox. When this is 
checked, the 'handle' length can be selected in the  Handle  text entry box from 0 to 999999 
frames.

When you have selected the appropriate options and named the export file (or accept the 
default) click  Save to complete the export.

The destination disk can be any Mac HFS mounted in the system, Windows and MacDrive sup-
port all SCSI fixed disks or removable storage such as Jaz, MO, removable hard-disks, etc.

Important!  In the event that you wish to transfer the ProTools session back to a Mac station 
using a set of CDs or DVDs you should export your session to a PC disk formatted as a NTFS 
volume. Then archive the session file and all audio files in an archive (or a set of archives) and 
then burn an ISO CD or DVD (or a set of ISO CD or DVD) containing the archive(s).
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Copy this(ese) archive(s) into your Mac, extract all files and open your session in Protools.

Archives are used to bring Protools sessions and SDII files from a NTFS volume to a Mac disk 
via CDs or DVDs as there's currently no easy way to burn a HFS CD or DVD from a PC.
The best way to create an archive is to use StuffIt from Aladdin Systems as this type of archive is 
a standard on Mac. There's a Windows version available which preserves all important informa-
tion contained in the files to transfer.

You can download a version of StuffIt for Windows (current version is StuffIt Deluxe 7.5) at

www.aladdinsys.com

Tip: Archiving generally compresses the data to reduce disk allocation, but this process takes 
some time. If space is less an issue for you than time, you can go in StuffIt to the menu Edit / 
Options / Compression Page and set the Compression Level for StuffIt (.sit) archives to None. 
This will speed up the archiving process.

AES 31
Straightforward Import and Export in AES 31 format

DDP
Import DDP file.

Sonic Solutions
Straightforward Import in Sonic Solutions format.

Tascam Open TL
Straightforward Import and Export in Tascam Open TL format

XML
Straightforward Import and Export in XML format.

SACD EDL Export
Please see: DSD / SACD Guide

Report Printer
(includes EDL, Markers, CD TOC report sheet)

This program really needs a printer. Here is a way to add a printer when no physical printer 
exists:

1. Start the add new printer wizard. Start > Settings > Printers > add Printer

2. In the wizard choose local printer and deactivate automatically detect

3. Under "Use the following port” choose File

4. Select the printer that you will eventually use to print the file

5. The rest of the installation is the same as a standard printer installation

If you print a page test, a dialog will open and ask you the name of the file. Then enter the path 
where you want to write the file.
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Cue Sheet Printer
The Cue Sheet Printer offers comprehensive options for printing out a graphic representation 
of the Timeline. Cuesheets are frequently a contracted delivery requirement which takes much 
time and effort to produce.

Select Project > Export. This opens the Project Export window. Select Cue sheets printer and 
click on the Export button. (or simply double-click the Cue sheets printer entry) 

The CueSheet Printing window opens. (Shown with the Preview option selected.):
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Report
Print

Click this button to print the cue sheet(s) with the selected options. This opens the Print Options 
window unless the Orientation selected is different from the printer’s default. If it is the Paper 
Orientation conflict window pops-up with buttons which offer a choice of Select other report, 
Change Orientation, Force or Cancel. Force should make the printer change orientation for this 
print. Some printers will not accept this. If this is the case, see below.

Print Options Window

Offers the choice of which pages to print and the number of copies. Allows any installed printer 
to be selected and configured. If Force does not result in correct page orientation the printer 
page orientation can be changed by clicking Change then Select in the next screen which should 
give access to the Printer’s set up window with options dependant on the selected printer.

Preview

Adds a graphic preview of the Cue-Sheet(s) to the right-hand side of the window

Design

Opens the design software used to create the Cue-sheets. Please see the on-line documentation

Select

Opens a file browser. Saved Cue-sheets can be loaded for printing.

Sheets Arrangement
Horizontally and Vertically set the number of pages with the increment / decrement buttons. 
This also controls the time scaling.

Orientation
Portrait / Landscape

Toggle between vertical and horizontal page orientation.

Settings
TimeCode Format

Shows the TimeCode format which will be used on the cue-sheets from the choice in the drop-
down list. Frames, Samples, [ms] or CD Frames

Clip TimeCode

When checked, Clip Timecodes will be printed

Clip Name

When checked, Clip Names will be printed

Color

When checked, the cue-sheets will be printed in the colors used in the original project. (With a 
color printer)

Comments

When checked, Comments will be printed

Preview
Clip Borders
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When checked, clip borders are shown in the preview display.

Background
Black / White

Toggle the preview background color.
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Customizing the User Interface

Pyramix Virtual Studio allows considerable customization of the user interface. Apart from the 
usual Windows interface possibilities Pyramix has user defined Workspaces, customizable Key-
board Shortcuts and user defined Macros.

Workspaces
Workspaces are a method of saving many of the Pyramix Project Editing Panel settings, espe-
cially Track Header switches. Once saved a Workspace can be quickly recalled for future use.

Workspaces can be accessed via the pull down menu on the Pyramix Virtual Studio Window 
toolbar or via the Project Management panel tab.

New Workspaces can be added by clicking ‘Click here to add a new Workspace’ on the first line 
of the Tab Window. A text entry box opens where you type a name for the new Workspace. Hit-
ting Return places the new Workspace at the bottom of the list.

Workspaces may be re-named by clicking the name.

Workspaces can be deleted by selecting them and pressing the 'Delete’ key.

Applying a Workspace is done by double-clicking on the Workspace icon to the left of the 
name.or select the menu item Workspaces > Recall > Recall Workspace (X)

Parameters remembered by Workspaces are selectable per Workspace by clicking in the appro-
priate columns.

If the ‘Update on change’ column is set to ‘Yes’. The current state of all selected parameters is 
saved to the current Workspace when another Workspace is selected.

Customizing Keyboard Shortcuts
We strongly encourage you to learn the default Pyramix keyboard shortcuts. These have been 
used by audio professionals for over a decade, and are powerful, quick and efficient for audio 
editing and device control. However, if you are already familiar with another style of audio or 
video editing, you may wish to create your own Keyboard Shortcuts for various Pyramix trans-
port and editing functions.

To define your own Keyboard Shortcuts:

1. Choose View > Customize > Keyboard Shortcuts from the Toolbar. This opens the Key-
board Shortcuts window.

2. All menu Commands are grouped together into Tabs within this window. Select the Tab 
with whichever group of Command Functions you wish to add or change key assignments 
for.

3. Click on the appropriate Command so that it is highlighted.

4. Click in the Press new shortcut key box. The cursor will become a blinking bar.

5. Now press the desired Key or combination of Key and modifier (e.g. the Ctrl, Shift, Alt, 
etc.). These will appear in the Press new shortcut key box. Note that Pyramix will warn you 
if the chosen Key or combination is already assigned to another function.

6. Click the Assign button.

7. Continue assigning Keys to Commands until you are satisfied.
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8. Any set of user defined Keyboard Shortcuts can be saved as a Preset. To do so, click the 
Save Preset button, then name the Preset. Similarly, to recall a previously saved Preset, 
click in the Presets box and select it from the pop-up list. Note that several common Presets 
are shipped with Pyramix Virtual Studio.The Table will be saved in the system for the user 
currently logged in and will not affect any other user.

9. A table can be Saved or Loaded to a file so it can be taken to an other system. Just Click on 
the Save Table or Load Table button.

10. A table can be exported as a Text File along with some comments about commands. This is 
very useful since it enables you to print it as a command reference guide with your own 
keyboard shortcuts.

Example:

Many users with a video editing background will be familiar with the J, K and L keys assigned 
to Reverse Play, Stop and Play respectively. To make these assignments:

1. Choose View > Customize > Keyboard Shortcuts

2. Select the Internal Machine Tab

3. Click on the Reverse Play Command to select it.

4. Click in the Press new shortcut key box.

5. Type J (Notice there is no Key currently assigned.)

6. Click Assign

7. Click on the Stop Command to select it.

8. Double click the J in the Press new shortcut key box.

9. Type K 

10. Click Assign.

11. Repeat steps 7 to 10 substituting Play and L

12. Save the Preset.

User Macros
Macros are sequences of commands which can be invoked by a single keypress or combination. 
Macros can be a very powerful aid to productivity.

To define a new Macro:

1. Choose View > Customize > Macros from the Toolbar. This opens the Macros window.

2. Click the New Macro button, then name the Macro.

3. Various menu Command functions are grouped together into Tabs. Select the Tab with 
whichever group of Command Functions you wish to add to the Macro.

4. Click on the appropriate Command so that it is highlighted.

5. Press the << button to add this command to the Macro.

6. Repeat steps 3 to 5 to assign further Commands to the Macro until it is complete.

7. A Keyboard Shortcut can now call the new Macro. Follow the instructions in the previous 
section for assigning Keyboard Shortcuts. In this case, choose the Macro Tab within the 
Keyboard Shortcut window. Your new Macro will appear as an option inside this window.
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Application Specific Configuration

LTC sync

EXAMPLE - where a cinema projector must be the master
• Cinema projector follows mains (or is crystal controlled) and sends biphase signal 

to a Biphase -to LTC converter. (E.g. the Rosendahl BIF)

• Converter’s LTC output is directly fed to Pyramix LTC input

• Pyramix is set to "LTC sync" mode and will adapt it's own internal clock to sync to 
LTC whenever the Pyramix is set to lock and the external LTC is recognized to be 
playing at about 1x forward speed.

• Pyramix feeds it's own clock to the DA-88 (or similar machine used as an A/D con-
verter) via Wordclock.

• The DA-88 (or equivalent) is set to sync to external Wordclock

• The DA-88 in turn provides the Pyramix TDIF daughtercard input with digital 
audio data.

All LTC sync ballistics in the Pyramix software have been carefully designed to both allow a 
large locking range (-7 to +5%) while still exhibiting extremely low instantaneous jitter and more 
importantly a controlled maximum speed change slope - not more than about 25 PPM per ms 
(25 Parts Per Million/millisecond) - in order to make sure that any other digital audio equip-
ment connected to it's Wordclock output is provided with a smoothly changing clock speed (free 
of any abrupt speed changes). When used with Tascam digital multi-tracks such as the DA-88 
this in turn allows the TDIF input decoding circuitry in Pyramix to properly decode the digital 
audio data at all times without disruptions while the complete system follows the actual master 
speed changes.

Driving the pyramix with the LTC output of the DA-88 is maybe possible in some situations but 
will demonstrate several limitations which should not occur if you precisely follow the recom-
mended setup as described above. Keep in mind that the DA-88 does exhibit big instantaneous 
1000 PPM (0.1%) speed changes and this prohibits proper TDIF decoding at the other end.
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Menus - Project Menu

Many Pyramix menu entries are self-explanatory. Here, these are simply listed. Other menu 
entries are described here or elsewhere in this manual. For full descriptions of all menu entries 
please see the Pyramix Reference Guide.

New Create a new Editing Project or Digitizing session

New from Template Create a new Project based on a Template

Open Open an existing Editing Project or Digitizing session

Save Save current Project. If the project has never been saved, the Save As win-
dow will appear

Save As Save current Project with a new name

Save as Template Save current Project as a Template

Close Close the current Project. If the file has changed since last saved, the Save 
window will appear
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Information & Settings The Information Panel has fields for entering information related to  the cur-
rent project

Import... Opens the InterChange Import Manager

Export... Opens the InterChange Export Manager

Import from Tape (Capture) Allows media on external devices to be captured into the current Project

Export to Tape (Auto Edit) Allows the current composition to be exported to an external device

Archive Creates a copy of the current project with all associated media to another 
location

Consolidate Create an optimized set of media for the current project

Convert Convert the whole project to an other sampling rate

Stretch / Pitch Stretch or Pitch the whole project from 24fps to 25fps (4% time compression 
or pitch reduction) or 25fps to 24fps (4.17% time expansion or pitch rise)

Clean Up Media Delete all media not used by the current project

Render Render the project or current selection to a new Media File

Mix Down Mix the project or current selection down to a new Media File through the 
mixing console

Generate CD Image Generate a CD Image from the current project

Surround Post-processing Enables the current composition to be encoded in different Surround format 
such as AC3 or DTS

Exit To quit the application, choose Exit from the File menu. If there have been 
changes since the last time you saved the project, the system will prompt 
you to save your changes

Note: The Stretch / Pitch menu selection requires the optional Prosoniq MPEX2.
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Menus - Edit menu

The Edit menu in Pyramix contains the conventional Copy, Cut, and Paste commands, also 
options for undo and redo of previous edit operations and special edit commands for placing 
clips in the Pyramix Composition Editor. 

Undo clip(s) move Undo command changes to show the last edit action and cancels it when 
selected

Undo history > leads to a sub-menu with a list of all previous editing actions which can be 
undone
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Redo change source/fade in Redo command changes to show the last action undone and cancels it when 
selected

Redo history > leads to a sub-menu with a list of all editing actions which have been undone 
and can be redone

Delete Deletes the currently selected clip/selection

Cut Cuts the current selection from the project and saves it on the Clipboard

Copy Copies the current selection from the project and saves it on the Clipboard

Paste to Cursor Inserts what's on the Clipboard to the current cursor position

Paste & Place This command opens the Placement Tool to allow for more extensive place-
ment options

Paste to Original TimeCode Inserts what's on the Clipboard to the pasted clip's original source time code 
position

Paste to End of Selection Inserts what's on the Clipboard to the end point of the current selection

Fill Selection This command will substitute the Clipboard contents for the selected clip or 
region

Replace Selection This command will substitute the Clipboard contents for the selected clip or 
region and ripple following clips if there's a length difference

Loop Selection This command will substitute a loop of the Clipboard contents for the 
selected clip or region without changing sync on the track

Fit Selection This command allows inserted clips to be fit into specified regions on the 
timeline. This requires the Timezone Time compression/Expansion plug-in

Delete and Ripple Deletes the currently selected clip/selection, forcing a ripple to occur

Cut and Ripple Cuts the current selection from the project and saves it on the Clipboard, 
forcing a ripple to occur

Paste and Ripple Inserts what's on the Clipboard to the current cursor position, forcing a ripple

Insert Silence This command will insert blank space (silence) into to the current selection

Split This command uses the play cursor as a razor blade to split selected clips 
into two clips at the point where the play cursor crosses the selected clips

Trim The Trim handles allow you to shorten or extend the length of a clip by mov-
ing the head or tail relative to the rest of the clip

Stretch This allows a clip to be stretched or squeezed

Reverse This allows a clip to be fit into a selection on the timeline. The values of the 
Timezone plug-in will be set automatically to fit the clip into the selection

Normalize Apply the normalize process to the selected clip

Consolidate The Consolidate function will make a selective backup of the media seg-
ments in the Composition

Spread This command allows a space (silence) to be inserted between selected 
clips

Abut to selected This command abuts all clips between the Mark In and Mark Out on a track 
to a selected clip between the marks on the same track

Automatic Silence Removal This command opens the Automatic Silence Removal window
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Delete with Media Removes the current selected clip from the composition, and delete the 
associated media file

Update Media Original TC Updates  the Media Original TC for all selected clips with their TimeCode 
position in the composition. This operation modifies the Media and is not 
reversible

Source-Destination >

Auto-Edit Source to Destination

Executes the appropriate Source/Destination 2, 3 or points 
editing operation depending on the Gates status

Overwrite Source to Destination

Overwrites the content between the Destination Track Group 
Gates with the content between the Source Track Group Gates

Insert Source to Destination Inserts the content between the Source Track Group Gates to 
the Destination Track Group Gates

Replace Source to Destination

Replaces the content between the Destination Track Group 
Gates with the content between the Source Track Group Gates by 
rippling the Destination

Fit Source to Destination Replaces the content between the Destination Track Group 
Gates with the content between the Source Track Group Gates by 
stretching the Source

Auto Set Destination Gate In after Edit

When this option is checked (enabled), the Destination Gate In 
point is automatically set to the current Gate Out point after any 
Source-Destination operation

Auto Select Destination after Edit

When this option is checked (enabled), the Destination Track 
Group is automatically selected after any Source-Destination 
operation

Limit 1 Gate Sources to End/Beginning of Clip

When this option is checked (enabled), then the Source mate-
rial between the Source Gate and the end of the clip under the 
Gate instead of the whole track is copied to the Destination

3 Gates Auto-Edit does Overwrite

When this option is checked (enabled), then when 2 Gates are 
set in a Source and 1 is set in the Destination then AutoEdit per-
forms an Overwrite operation

3 Gates Auto-Edit does Insert

When this option is checked (enabled), then when 2 Gates are 
set in a Source and 1 is set in the Destination then AutoEdit per-
forms an Insert operation

Editing Modes > Insert Mode >
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Overwrite When checked, any clip placed so that it overlaps an existing clip will 
overwrite the part of that clip where the two overlap.

Insert Track When checked, any clip placed on a track will be inserted into the track 
and will ripple all other material on the track later in time (to the right) by 
the length of the clip being inserted.

Editing Modes > Remove Mode >

Remove When checked any selected material will simply be removed from the 
Timeline. Everything else will be left intact and in the same place.

Remove and Ripple When checked any selected material will be removed from the Timeline. 
Everything else to the right (after) the removed material will be Rippled 
(moved) to the left (earlier) to take up the space left by the removed 
material.

Editing Modes > Snap Mode >

Don’t Snap No snap mode set. This mode doesn't affect the behavior of objects 
placed on a track. Behavior follows the existing Insert and Remove 
modes.

Head to End This mode will cause the beginning of any clip placed on a track to snap 
to the end of the last clip on the track, abutting the head of the new clip 
to the end (tail) of the last clip.

Tail to Beginning This mode will cause any clip placed on a track to snap to the beginning 
of the first clip on the track, abutting the tail of the new clip to the head 
of the first clip.

Head to Nearest This mode will cause any clip placed on a track to snap the head of the 
clip to the nearest edit point or mark on the track. This includes the 
head or tail of existing clips on the track, as well as the Play Head Cur-
sor, Mark In, Mark Out, Named Markers, or CD Marks. The clip will 
interact with existing clips according to the Insert Mode setting. 

Tail to Nearest This mode will cause any clip placed on a track to snap the tail of the 
clip to the nearest edit point or mark on the track. This include the head 
or tail of existing clips on the track, as well as the Play Head Cursor, 
Mark In, Mark Out, Named Markers, or CD Marks. The clip will interact 
with existing clips according to the Insert Mode setting. 

Snap to Original Timecode This mode will cause any clip placed on a track to snap the 
head of the clip to the time location represented by the clips original 
timecode. The clip will interact with existing clips according to the Insert 
Mode setting.

Auto-Ripple When this option is checked (enabled) all Insert or Remove operations rip-
ple the rest of the track

Auto-Crossfade When this option is checked (enabled) the default cross-fade (defined in the 
Fade Editor Tab Window is applied to any Paste or Source-Destination oper-
ation

Enable Automation Cut/Copy/Paste

When this option is checked (enabled) all Cut / Copy / Paste operations also 
include automation tracks

Update Original TC on Move When this option is checked (enabled) the original TimeCode stamp of any 
copied/move selection is updated to the position it was in before the current 
move
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Snap > 

Snap Off When this option is checked (enabled), Snap mode is disabled

Snap to Edits When this option is checked (enabled), Snap mode is set to Edits

Snap to Scale When this option is checked (enabled), Snap mode is set to Scale

Snap to Feet Scale When this option is checked (enabled), Snap mode is set to Feet Scale

Snap to Bars & Beats Grid When this option is checked (enabled), Snap mode is set to 
Bars & Beats Grid

Snap Cursor When this option is checked (enabled), the Cursor is also snapped fol-
lowing the current mode

Snap Region Selection When this option is checked (enabled), the Selection is also 
snapped following the current mode

Snap Selection Head When this option is checked (enabled), Snap mode is set to 
Head of selection

Snap Selection Tail When this option is checked (enabled), Snap mode is set to 
Tail of selection

Snap Selection Sync Point When this option is checked (enabled), Snap mode is set to 
Sync Point of selection
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Fixed Cursor while playing When checked (enabled) Playhead Cursor remains stationary while playing 
at the position set in General Settings - Playback and the Tracks scroll 
from right to left.

Free Cursor while playing When checked (enabled) Playhead Cursor disappears when the screen 
boundary is reached. I.e. the Timeline is not redrawn.

Cursor Auto-Return after playing

When checked (enabled) Playhead Cursor returns to its starting position 
when playback stops

Show Ghosts When checked (enabled) shows a ghost image of clips on related virtual 
tracks

Show Media When checked (enabled) shows the full extent of the underlying digital media 
for a selected clip as a red line on the track above and below the selected 
clip with a grayed out image of the waveform when this is on

Used Media This command opens the Media folder(s), and highlights media that are used 
in the currently loaded project

TimeCode Resolution >

Frames Sets the < 1 second Cursor TimeCode display resolution to frames

Samples Sets the < 1 second Cursor TimeCode display to samples

[ms] Sets the < 1 second Cursor TimeCode display to display milliseconds
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CD frames Sets the < 1 second Cursor TimeCode display to display CD frames

Display as CD time Sets the TimeCode display to CD Track elapsed time (only available 
when CD Markers are present)

Waveform Display >

Larger Increase the size of the current waveform display

Smaller Decrease the size of the current waveform display

x1 Sets the magnification factor of the current waveform display to 1x

x2 Sets the magnification factor of the current waveform display to 2x

x4 Sets the magnification factor of the current waveform display to 4x

x8 Sets the magnification factor of the current waveform display to 8x

dB Sets the current waveform display to decibels

Auto-Scale Waveform

Sets the current waveform display to automatically display an optimal 
waveform

Show Full Waveform

Sets the current waveform display to display a waveform that is fully 
colored even at sample level (like peak display)

Show Waveform Origin

Sets the current waveform display to display a waveform that show 
also at sample level the 0dB origin

Show Dynamic Waveform

Sets the current waveform display to display a waveform that shows 
the dynamic range for each pixel

Hide Clip Name when Waveform Shown

Hides the clip names when the waveform is displayed

Zoom >

Fit in window Adjusts the horizontal magnification (zoom level) of the Project Editor 
panel to fit the selected clip or region

Previous zoom Restores the Project Editor Panel view to the previous zoom resolution 
and location

Zoom In Zooms in by a factor of 2x, centered around the middle of the Project 
Editor Panel

Zoom Out Zooms out by a factor of 2x, centered around the middle of the Project 
Editor Panel

Recall Preset >

Zoom 1 Recall Preset Zoom 1

Zoom 2 Recall Preset Zoom 2

Zoom 3 Recall Preset Zoom 3

Zoom 4 Recall Preset Zoom 4

Zoom 5 Recall Preset Zoom 5

Set Preset >

Zoom 1 Set Preset Zoom 1

Zoom 2 Set Preset Zoom 2

Zoom 3 Set Preset Zoom 3

Zoom 4 Set Preset Zoom 4
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Zoom 5 Set Preset Zoom 5

Auto Zoom Selection Project Editor Panel display automatically zooms-in to any 
selection made on the timeline

Tracks >

Show all Tracks Show (Unhide) all Tracks and Expand (Uncollapse) all Track 
Groups

Hide Tracks without selection Hide all tracks that have nothing selected

Fit View to >

Fit View to 1 Track Fit current View to 1 Track

Fit View to 2 Tracks Fit current View to 2 Tracks

Fit View to 4 Tracks Fit current View to 4 Tracks

Fit View to 8 Tracks Fit current View to 8 Tracks

Fit View to 16 Tracks Fit current View to 16 Tracks

Fit View to All Tracks Fit current View to All Tracks

Enlarge Track Size Enlarge current Track Size

Reduce Track Size Reduce current Track Size

Scroll Timeline

Scroll Timeline Left Scroll the whole Timeline to the left

Scroll Timeline Right Scroll the whole Timeline to the right

Scroll Timeline Up Scroll the whole Timeline up

Scroll Timeline Down Scroll the whole Timeline down

Scales / Toolbars >

Feet Adds a ruler calibrated in Feet below the Time ruler

Feet Settings Opens the Feet Settings window

Bars&Beats Adds a ruler calibrated in Bars&Beats below the Time ruler

Bars&Beats Settings Opens the Bars&Beats Settings window

Tempo Map Adds a Tempo map below the Time ruler

Windows / Tools >

Transport Displays the Transport Large Control

Mixer Displays the Mixer

Media Management Displays the Media Management folders

Global libraries Displays the Global Libraries

Fade Library Displays the Fade library

Information Displays the Information Window

On the Air Displays the On the Air Window

I/O Status Displays the I/O Status Window

Editor Tabs >

Overview Open Overview Tab window

EDL Open EDL Tab window

Document Libraries Open Document Libraries Tab window
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Tracks Open Tracks Tab window

Track Groups Open Track Groups Tab window

Playlists Open Playlists Tab window

Workspaces Open Workspaces Tab window

Selection Open Selection Tab window

Fade Editor Open Fade Editor Tab window

Markers Open Markers Tab window

CD Open CD Tab window

Notes Open Notes Tab window

Machines Open Machines Tab window

Media Management Open Media Management Tab window

Global Libraries Open Global Libraries Tab window

Customize >

Macro Editor Opens the Macros window (macro creation and management)

Keyboard Shortcut Editor Opens the Keyboard Shortcuts window (shortcut creation 
and management)

Interface Editor Opens the Interface Editor window (customize track headers)

General Settings Displays the General Settings Window

Mixer Settings Displays the Mixer Settings Window

Clips Menu
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Select >

Select All Select all clips on Timeline

Select All to Mark In Select all clips on Timeline, to the current Mark In Point

Select All between Marks Select all clips on Timeline, between current In/Out Marks

Select All from Mark Out Select all clips on Timeline, from the current Mark Out Point

Select Source Select all clips on current audio track

Deselect All Deselect all currently selected clips

Select Previous Clip Select clip to left of currently selected clip

Select Next Clip Select clip to right of currently selected clip

Add Previous Clip to SelectionApply selection to clip to left of currently selected clip

Add Next Clip to Selection Apply selection to clip to right of currently selected clip

Add all Preceding Clips to Selection

Apply selection to all clips preceding the currently selected clip

Add all Following Clips to Selection

Apply selection to all clips following the currently selected clip

Nudge >

Nudge to Previous Edit Nudges the selected clip to the left (earlier in time) to the previ-
ous edit points in the track or marks in the editor

Nudge to Next Edit Nudges the selected clip to the right (later in time) to the next 
edit points in the track or marks in the editor

Nudge to Left Nudges the selected clip to the left (earlier in time) by an 
amount equal to the current Nudge setting

Nudge to Right Nudges the selected clip to the right (later in time) by an 
amount equal to the current Nudge setting

Nudge to Left Custom Nudges the selected clip to the left (earlier in time) by an 
amount that can be entered with the keyboard

Nudge to Right Custom Nudges the selected clip to the right (later in time) by an 
amount that can be entered with the keyboard

Nudge to Left Custom in Bars/Beats

Nudges the selected clip to the left (earlier in time) by an 
amount that can be entered in Bars/Beats with the keyboard

Nudge to Right Custom in Bars/Beats

Nudges the selected clip to the right (later in time) by an 
amount that can be entered in Bars/Beats with the keyboard

Move Up Moves the selected clip or region up to the adjacent track 
above it

Move Down Moves the selected clip or region up to the adjacent track below 
it

Move Up with Fade Moves the selected clip or region up to the adjacent track 
above it. If there is another clip on the adjacent track at that loca-
tion, it will interact with it by crossfading

Move Down with Fade Moves the selected clip or region up to the adjacent track below 
it. If there is another clip on the adjacent track at that location, it will 
interact with it by crossfading
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Current Setting >

Nudge Setting 1 Apply Nudge Setting 1

Nudge Setting 2 Apply Nudge Setting 2

Nudge Setting 3 Apply Nudge Setting 3

Nudge Setting 4 Apply Nudge Setting 4

Nudge Setting 5 Apply Nudge Setting 5

Set Sync Point to Cursor Sets the selected clip’s Sync Point at the current cursor position

Send Sync Point to Cursor Sends (moves) the currently selected clip so that its Sync Point is aligned 
with the current position of the Play Cursor

Group Groups together all selected clips in the Timeline

Ungroup Ungroups members of a selected group clip in the Timeline

Lock Locks selected clips so that they can no longer be edited or moved in the 
Timeline

Unlock Unlocks selected locked clips so that they can be edited again

Lock Horizontal Drag When enabled, clips cannot be dragged horizontally (left to right)

Clip Gain Displays an audio fader to set the audio level for the selected clips

Mute Clip Mutes all selected clips

Edit Fade near Cursor Opens the Fade Editor with the audio fade located near the current Play-
head cursor position ready to be edited

Edit Fade near Mouse Opens the Fade Editor with the audio fade located near the current mouse 
cursor position ready to be edited

Fade In >

Fade Out >

X Fade >

Note: Sub-menu options for Fade In, Fade Out, and X Fade are the same. For brevity, only the 
Fade In sub-menu options are listed.

Fade In New Apply new Fade In

Fade In Edit

Default > Edit Fade In

Fade In Default  Apply Fade In Default

Fade In Default Curve  Apply Fade In Default Curve

Fade In Standard >

Fade In Power Linear Apply Fade In Power Linear

Fade In Tension LinearApply Fade In Tension Linear

Fade In dB Linear Apply Fade In dB Linear

Fade In Cosine Apply Fade In Cosine

Fade In Root Cosine Apply Fade In Root Cosine

Envelope >
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Envelope Reset Reset the gain envelope for the whole selection by deleting all 
automation nodes within the selection only on the track under the 
mouse cursor when Reset is chosen.

Envelope Reset Selection Reset the gain envelope for the whole selection by deleting all 
automation nodes within the selection.

Envelope Copy to Selection Copies the values of all automation nodes within the selection 
from the track under the mouse cursor when Copy to Selection is 
chosen to all other tracks in the selection

Envelope Punch Places four new automation nodes at the bounds of the selec-
tion on the track under the mouse cursor when Punch is chosen 
and opens the Punch Envelope window

Envelope Punch Selection Carries out the same operation as Punch but to all tracks in the 
current Selection.

Waveform >

Waveform follow Track Waveform display of the clip will always correspond to the setting for the 
entire track in the Track information and Settings panel

Waveform force Waveform clip will always show the waveform display regardless of the waveform dis-
play settings for the track

Waveform force Name clip will always show the clip name regardless of the waveform display set-
tings for the track

Generate Waveform Generate the waveform data for the selected clip

Selection Properties Opens the Selection Properties display window, which shows details con-
cerning the current selection

Properties Opens the Clip Properties display window, which shows details concerning 
the currently selected clip
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Menus - Tracks

New Audio Track Allows new audio tracks to be created on the Composition Editor

New Virtual Track Allows new virtual tracks to be created on the Composition Editor

Delete Removes the currently selected track from the composition editor

Delete to Last Deletes all tracks between the currently selected tracks to the last track on 
the Composition Editor

Auto-connect Automatically connect all tracks sequentially to any available mixer input

Select All Clips This command selects and highlights all clips on the selected track

Select All Clips to Mark In Selects all clips on the track from the beginning of the composition up to the 
mark in

Select All Clips between Marks  Selects all clips on the track between the Mark In and Mark Out

Select All Clips from Mark Out  Selects all clips on the track from the Mark Out to the end of the composi-
tion

Deselect All Clips Deselects all clips on the selected track

Ripple Launches the Ripple Tracks window
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Select Previous Track Group Selects the track group above the currently selected track group

Select Next Track Group Selects the track group below the currently selected track group

Duplicate Selected Track Group Duplicates the currently selected track group

Auto Create/Delete Track Groups When enabled allows Track Groups to be automatically created when clips 
insertion requires creation of new tracks

Select Previous Track Selects the audio track above the currently selected track

Select Next Track Selects the audio track below the currently selected track

Deselect Track Deselects the currently selected audio track

Auto Select Tracks The audio track is automatically selected on any click / move in its content

Synchronize Tracks & Strips The audio track and its associated mixing console strip are always selected 
together

Toggle Record Ready > (toggles between Rec Ready and Safe)

Toggle Record Mode > (toggles between Rec Ready, Auto-Punch Ready and Safe)

Note: The sub-menus for these two Toggle functions give access to up to 96 tracks
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Menus - Cursors and marks

Nudge Cursor > 

Nudge Cursor to Previous Edit Nudge Cursor to Previous Edit

Nudge Cursor to Next Edit Nudge Cursor to Next Edit

Nudge Cursor to Previous Clip Nudge Cursor to Previous Clips

Nudge Cursor to Next Clip Nudge Cursor to Next Clip

Nudge Cursor to Previous Clip Fade Nudge Cursor to Previous Clip Fade

Nudge Cursor to Next Clip Fade Nudge Cursor to Next Clip Fade

Nudge Cursor to Previous Marker Nudge Cursor to Previous Marker
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Nudge Cursor to Next Marker Nudge Cursor to Next Marker

Nudge Cursor to Previous CD Marker Nudge Cursor to Previous CD Marker

Nudge Cursor to Next CD Marker Nudge Cursor to Next CD Marker

Nudge Cursor to Left Nudge Cursor to Left

Nudge Cursor to Right Nudge Cursor to Right

Nudge Cursor to Left with Region Nudge Cursor to Left and update the nearest 
selection boundary to this location

Nudge Cursor to Right with Region Nudge Cursor to Right and update the nearest 
selection boundary to this location

Nudge Cursor to Left Custom Nudge Cursor to Left by an amount entered with 
the Keyboard

Nudge Cursor to Right Custom Nudge Cursor to Right by an amount entered with 
the Keyboard

Nudge Cursor to Left Custom in Bars/BeatsNudge Cursor to Left by an amount entered in 
Bars/Beats with the Keyboard

Nudge Cursor to Right Custom in Bars/Beats Nudge Cursor to Right by an amount entered 
in Bars/Beats with the Keyboard

Nudge Cursor to Previous Foot Nudge Cursor to the Previous Foot

Nudge Cursor to Next Foot Nudge Cursor to the Next Foot

Nudge Cursor to Previous Foot Frame Nudge Cursor to the Previous Foot Frame

Nudge Cursor to Next Foot Frame Nudge Cursor to the Next Foot Frame

Nudge Cursor to Previous Bar Nudge Cursor to the Previous Bar

Nudge Cursor to Next Bar Nudge Cursor to the Next Bar

Nudge Cursor to Previous Beat Nudge Cursor to the Previous Beat

Nudge Cursor to Next Beat Nudge Cursor to the Next Beat

Nudge Cursor to Previous Grid Step Nudge Cursor to the Previous Grid Step

Nudge Cursor to Next Beat Grid Step Nudge Cursor to the Next Grid Step

Nudge Marks > 

Nudge Mark In to Left Nudge Mark In to Left

Nudge Mark In to Right Nudge Mark In to Right

Nudge Mark In to Left Custom Nudge Mark In to Left by an amount entered with 
the Keyboard

Nudge Mark In to Right Custom Nudge Mark In to Right by an amount entered with 
the Keyboard

Nudge Mark In to Left Custom in Bars/BeatsNudge Mark In to Left by an amount entered in 
Bars/Beats with the Keyboard

Nudge Mark In to Right Custom in Bars/Beats Nudge Mark In to Right by an amount entered 
in Bars/Beats with the Keyboard

Nudge Mark Out to Left Nudge Mark Out to Left

Nudge Mark Out to Right Nudge Mark Out to Right

Nudge Mark Out to Left Custom Nudge Mark Out to Left by an amount entered with 
the Keyboard

Nudge Mark Out to Right Custom Nudge Mark Out to Right by an amount entered 
with the Keyboard
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Nudge Mark Out to Left Custom in Bars/Beats Nudge Mark Out to Left by an amount entered 
in Bars/Beats with the Keyboard

Nudge Mark Out to Right Custom in Bars/Beats Nudge Mark Out to Right by an amount 
entered in Bars/Beats with the Keyboard

Nudge Gates >

Nudge Gate In to Left Nudge Gate In to Left

Nudge Gate In to Right Nudge Gate In to Right

Nudge Gate Out to Left Nudge Gate Out to Left

Nudge Gate Out to Right Nudge Gate Out to Right

Goto TimeCode Opens the Goto TimeCode window, which allows the Play Cursor to be posi-
tioned to a specific TimeCode position

Goto Foot Allows the Play Cursor to be positioned to a specific Foot

Goto Beat Allows the Play Cursor to be positioned to a specific Beat

Cursor to Mark In Moves the Play Cursor to the Mark In

Cursor to Mark Out Moves the Play Cursor to the Mark Out

Cursor to Gate In Moves the Play Cursor to the selected track group Gate In

Cursor to Gate Out Moves the Play Cursor to the selected track group Gate Out

Cursor to Selected Marker Moves the Play Cursor to the Selected Marker

Cursor to Start of Selected Track  Moves the Play Cursor to the start position of the first clip on the selected 
track

Cursor to End of Selected Track  Moves the Play Cursor to the end position of the first clip on the selected 
track

Auto Center on Goto When enabled, the Project Editor will automatically center the display to the 
new Play Cursor position when the Goto Timecode command is used

Mark In to Cursor Moves the Mark In to the Play Cursor

Mark Out to Cursor Moves the Mark Out to the Play Cursor

Gate In to Cursor Moves the selected track group Gate In to the Play Cursor

Gate Out to Cursor Moves the selected track group Gate Out to the Play Cursor

Marks to Selection Moves the Mark Out to the current selection

Lock Marks Prevents the Mark In/Out points from being changed

Hide Marks Removes the Mark In/Out cursors

Add Marker to Cursor Adds a new Marker to the current Play Cursor Position

Delete Selected Marker Deletes the currently selected Marker

Move Selected Marker to Cursor  Moves the selected Marker to the current Play Cursor Position

Set > 
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Set Marker 1 Set the Marker #1  to the current Play Cursor Position

Note: Set Markers 2 - 10 not shown

Goto Marker 1 Set the Play Cursor position to Marker #1

Note: Goto Markers 2 - 10 not shown

Select Previous Marker Selects the previous Marker (left) of the currently selected Marker

Select Next Marker Selects the next Marker (right) of the currently selected Marker

Show Cursor Automatically centers the display of the Project Editor to the Play Cursor

Show Mark In Automatically centers the display of the Project Editor to Mark In current 
position

Show Mark Out Automatically centers the display of the Project Editor to Mark Out current 
position

Show Gate In Automatically centers the display of the Project Editor to the selected track 
group Gate In

Show Gate Out Automatically centers the display of the Project Editor to the selected track 
group Gate Out

Show Selected Marker Automatically centers the display of the Project Editor to the currently 
selected Marker

Add CD Start Marker to Cursor  Adds a CD Start marker at the Play Cursor position

Add CD Stop Marker to Cursor  Adds a CD Stop marker at the Play Cursor position

Add CD Index Marker to Cursor  Adds a CD Index marker at the Play Cursor position

Delete Selected CD Marker Deletes the currently selected CD Marker

CD Mark Groups Enables automatic creation of CD Markers Groups in the Project Editor
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Menus - Selection

Nudge to Left Nudges the selection to the left

Nudge to Right Nudges the selection to the right

Nudge Start to Left Nudges the selection start to the right

Nudge Start to Right Nudges the selection start to the left

Nudge End to Left Nudges the selection end to the right

Nudge End to Right Nudges the selection end to the left

Move Selection Up Moves the current selection to the track above its current position

Move Selection Down Moves the current selection to the track below its current position

Grow Selection Up Applies the current selection to the track above its current position

Grow Selection Down Applies the current selection to the track below its current position

Narrow Selection Up Removes the current selection from the track above its current position

Narrow Selection Down Removes the current selection from the track below its current position

Set Cursor to Selection Start Positions the Play Cursor to the start point of the current selection

Set Cursor to Selection Start with PrerollPositions the Play Cursor to the start point of the current selection, 
adding the defined Preroll value

Set Cursor to Selection Start with Preroll #2Positions the Play Cursor to the start point of the current selec-
tion, adding the defined Preroll  #2 value

Set Cursor to Selection Start with Preroll #3Positions the Play Cursor to the start point of the current selec-
tion, adding the defined Preroll  #3 value

Set Cursor to Selection End Positions the Play Cursor to the end point of the current selection

Set Selection Start to Cursor Positions the start point of the current selection to the Play Cursor position
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Set Selection End to Cursor Positions the end point of the current selection to the Play Cursor position

Select between Gates Positions sets the Selection between the selected track group Gates

Select Clip(s) under Cursor Selects the clip(s) currently in contact with the Playhead Cursor

Undo Selection Cancels the last selection command

Redo Selection Cancels (redo) the last Undo Selection command

Undo / Redo Selection Toggles between the last Undo / Redo Selection command
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Menus - Fade Editor

Open Editor Opens the Fade Editor window

Accept & Close Editor Approve changes to the fade and close Fade Editor window

Restore & Close Editor Restore fade to original state and close Fade Editor window

Restore Fade Restore fade to original state

Undo Fade Change Undoes the last parameter change

Previous Fade Select / Edit previous fade

Next Fade Select / Edit net fade

Xify Reset the current fade to a standard Power X fade

Show Faders & Control Show the Faders and Control Section of the Fade Editor

Show Parameters & Options Show the Parameters and Options section of the Fade Editor

Display & Zoom >

Fit Fade Zoom around the current Fade (Reset Zoom)

Zoom In Zoom in on graphic display

Zoom Out Zoom out on graphic display

Display & Zoom Options >

No Auto-Center Auto-Centering off

Auto-Center Fade Auto-Centering on
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Auto-Center Reference Point Auto Center on Reference Point

Free Zoom Follows only Zoom Reset, In and Out

Auto-Zoom Automatically Zooms around the current Fade after some oper-
ations

Auto-Zoom/Free Automatically Zooms around the current Fade but only when it 
enters the Fade Editor, thereafter, the Zoom is Free

Timeline Zoom Follows the Timeline Zoom factor

Zoom Preset 1 Recall Preset Zoom #1

Zoom Preset 2 Recall Preset Zoom #2

Zoom Preset 3 Recall Preset Zoom #3

Zoom Preset 4 Recall Preset Zoom #4

Zoom Preset 5 Recall Preset Zoom #5

Faders & Control >

Nudge Out Gain Less

Nudge Out Gain More

Nudge In Gain Less

Nudge In Gain More

Nudge Intercept Less

Nudge Intercept More

Nudge Asymmetry Less

Nudge Asymmetry More

Nudge Out Length Less

Nudge Out Length More

Nudge In Length Less

Nudge In Length More

Nudge Out Position Left

Nudge Out Position Right

Nudge In Position Left

Nudge In Position Right

Nudge In Media Left

Nudge In Media Right

Faders & Control Options >

Link Length Links length of Fade Out & In

Mirror Length Length of Fade Out and In will be changed symmetrically (cen-
tered)
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Link Position Links position of Fade Out & In

Fade Safe Ensures all following fades (to the right of the one being 
edited) are left intact while editing the current fade. 

Audition >

Audition X Fade

Audition X Fade with Ref

Audition Out with Curve

Audition Out without Curve

Audition Out after Fade

Audition Out with Curve with Ref

Audition Out without Curve with Ref

Audition Out after Fade with Ref

Audition Out Original Material

Audition In with Curve

Audition In without Curve

Audition In before Fade

Audition In with Curve with Ref

Audition In without Curve with Ref

Audition In before Fade with Ref

Audition In Original Material

Audition Options >

Audition Pre-Roll 1

Audition Pre-Roll 2

Audition Pre-Roll 3

Audition Post-Roll 1

Audition Post-Roll 2

Audition Post-Roll 3

Audition Speed 100%

Audition Speed 50%

Audition Speed 25%

Audition Solo

Audition Loop

Audition After Nudge

Memory >

Set Memory 1

Set Memory 2

Set Memory 3

Set Memory 4

Set Memory 5

Recall Memory 1

Recall Memory 2
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Recall Memory 3

Recall Memory 4

Recall Memory 5

Presets >

Load Default X Curve

Load Default X Preset

Save Default X Preset

Load Default Out Curve

Load Default Out Preset

Save Default Out Preset

Load Default In Curve

Load Default In Preset

Save Default In Preset
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Menus - Automation

Automation Off Automation system is disabled

Automation Play Automation system is set to playback any previously recorded automation 
data

Automation Write Automation system is set to playback any previously recorded automation 
data and record new automation data for all enabled controls

Automation Snapshot Creates an automation key frame at the current cursor position, for all cur-
rently armed automation controls

Automation Snapshot Range Places automation key frames at the currently defined In / Out cursor posi-
tions, for all currently armed automation controls

Delete Selected Points Deletes all automation points contained in the selected region

Cut Selected Points Cuts all automation points contained in the selected region

Copy Selected Points Copies all automation points contained in the selected region

Paste Points to Cursor Pastes all copied or cut automation points at the cursor on the selected track

Paste Points to Original TC Pastes all copied or cut automation points at the cursor on the selected track

Release Auto-Writing Releases all controls currently recording automation

Automation Tracks Opens the Automation Tracks window. This view allows the automation ver-
sions for a specific control to be displayed. Once the desired control has 
been located in the tree view, simply double-clicking on the control will 
update the Automation Track Versions window

Automation Settings Opens the Automation Settings pop-up window which allows automation 
parameters and settings to be defined
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Menus - Workspaces

Save >

Save Workspace 1 Save Workspace 1

Note: Save Workspace 2 to 9 omitted

Save Workspace 10 Save Workspace 10

Update Current Workspace Updates the current Workspace with current settings

Recall >

Recall Workspace 1 Recall Workspace 1

Note: Recall Workspace 2 - 9 omitted

Recall Previous Workspace Toggles backwards through the list of available Workspaces

Recall Next Workspace Toggles forwards through the list of available Workspaces
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Menus - Machines

Active machine >

Note: Active machine Sub-menus will reflect whichever machine is currently chosen as the 
active machine.

Toggle machines Toggle between installed machines

Stop Stop

Pause Pause

Play Play

Record Record

Fast Forward Fast Forward

Fast Rewind Fast Rewind

Scan Forward Scan Forward

Scan Rewind Scan Rewind

Start Goto Start

End Goto End

Play Reverse Play Reverse

Play 1/2 Play 1/2

Play 1/2 Reverse Play 1/2 Reverse

Play 1/4 Play 1/4

Play 1/4 Reverse Play 1/4 Reverse

Play 1/16 Play 1/16

Play 1/16 Reverse Play 1/16 Reverse

Play 2x Play 2x

Play 2x Reverse Play 2x Reverse

Play 4x Play 4x

Play 4x Reverse Play 4x Reverse

Toggle Play/Stop Toggle Play/Stop

Toggle Play/Pause Toggle Play/Pause

Toggle Play/Record Toggle Play/Record

Goto TimeCode Goto TimeCode

Loop On/Off Loop On/Off
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Auto-Chase External Machine Automatically set the Internal Machine to Chase any active 
External Machine

Internal Machine

Stop Stop

Pause Pause

Play Play

Record Record

Fast Forward Fast Forward

Fast Rewind Fast Rewind

Scan Forward Scan Forward

Scan Rewind Scan Rewind

Start Start

End End

Punch >

Punch Selection Punch Selection

Punch Selection with Preroll Punch Selection with Preroll

Punch Selection with Preroll #2Punch Selection with Preroll #2

Punch Selection with Preroll #3Punch Selection with Preroll #3

Auto-punch with Preroll Auto-punch with Preroll

Auto-punch with Preroll #2 Auto-punch with Preroll #2

Auto-punch with Preroll #3 Auto-punch with Preroll #3

Remake last Punch (In only) Repeat last Punch operation (Punch In only)

Remake last Punch (In - Out) Repeat last Punch operation

Play Selection Play Selection

Loop Selection Loop Selection

Play between Marks Play between Marks

Loop between Marks Loop between Marks

Play between Gates Play between selected track group Gates

Loop between Gates Loop between selected track group Gates

Audition >

Audition Pre Audition Pre

Audition Pre (Preroll #2) Audition Pre (Preroll #2)

Audition Pre (Preroll #3) Audition Pre (Preroll #3)

Audition Audition
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Audition (Pre/Postroll #2) Audition (Pre/Postroll #2)

Audition (Pre/Postroll #3) Audition (Pre/Postroll #3)

Audition Post Audition Post

Audition Post (Postroll #2) Audition Post (Postroll #2)

Audition Post (Postroll #3) Audition Post (Postroll #3)

Audition Gate In Pre Audition selected track groups Gate In Pre

Audition Gate In Pre (Preroll #2) Audition selected track groups Gate In Pre (Preroll #2)

Audition Gate In Pre (Preroll #3) Audition selected track groups Gate In Pre (Preroll #3)

Audition Gate In Audition selected track groups Gate In

Audition Gate In (Pre/Postroll #2) Audition selected track groups Gate In (Pre/Postroll #2)

Audition Gate In (Pre/Postroll #3) Audition selected track groups Gate In (Pre/Postroll #3)

Audition Gate In Post  Audition selected track groups Gate In Post

Audition Gate In Post (Postroll #2) Audition selected track groups Gate In Post (Postroll #2)

Audition Gate In Post (Postroll #3) Audition selected track groups Gate In Post (Postroll #3)

Audition Gate Out Pre Audition selected track groups Gate Out Pre

Audition Gate Out Pre (Preroll #2) Audition selected track groups Gate Out Pre (Preroll #2)

Audition Gate Out Pre (Preroll #3) Audition selected track groups Gate Out Pre (Preroll #3)

Audition Gate Out  Audition selected track groups Gate Out

Audition Gate Out (Pre/Postroll #2) Audition selected track groups Gate Out (Pre/Postroll #2)

Audition Gate Out (Pre/Postroll #3) Audition selected track groups Gate Out (Pre/Postroll #3)

Audition Gate Out Post  Audition selected track groups Gate Out Post

Audition Gate Out Post (Postroll #2) Audition selected track groups Gate Out Post (Postroll 
#2)

Audition Gate Out Post (Postroll #3) Audition selected track groups Gate Out Post (Postroll 
#3)

Goto TimeCode Goto TimeCode

Loop On/Off Loop On/Off

Hard Chase Hard Chase

Soft Chase Soft Chase

Store Chase Offset Store Chase Offset

Cursor Auto-Return after playing  Auto Return On/Off

External Machine
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Stop Stop

Pause Pause

Play Play

Record Record

Fast Forward Fast Forward

Fast Rewind Fast Rewind

Scan Forward Scan Forward

Scan Rewind Scan Rewind

Start Goto Start

End Goto End

Goto TimeCode Goto TimeCode

Loop On/Off Loop On/Off

Nudge +1 frame Nudge +1 frame

Nudge -1 frame Nudge -1 frame

Set Loop In Set Loop In

Set Loop Out Set Loop Out

Goto Loop In Goto Loop In

Goto Loop Out Goto Loop Out

Eject Eject

Chase Cursor On/Off Chase Cursor On/Off

Enable Record On/Off Enable Record On/Off

Record Ready V1 Record Ready V1

Record Ready A1 Record Ready A1

Note: Record Ready A2 - A7 omitted

Record Ready A8 Record Ready A8

Goto Locator 1 Goto Locator 1

Note: Note Goto Locator 2 to 9 omitted

Goto Locator 10 Goto Locator 10

Set Locator 1 Set Locator 1

Note: Set locator 2 to 9 omitted

Set Locator 10 Set Locator 10
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Menus - Macro

The Macro menu gives access to a large number of pre-programmed Macros, also to the Macro 
Editor Please see User Macros  on page 222

Menus - Settings 

The Settings menu brings together all the Settings windows and the customization windows.

Menus - Window

The Window menu maintains a list of open projects and enables switching between them. It 
also enables multiple open project windows to be arranged on screen, Tiled or Cascaded
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Menus - Help

The Help Menu gives quick on-line access to this manual and others. About pops up a Window 
with the Pyramix logo and details about the registered user and software version.
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Remote Controllers

Hardware remote control is accomplished via MIDI. Templates are supplied for some popular 
controllers or you can map your own control surface to Pyramix. For full details, please see the 
Pyramix Reference Guide
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Optimizing Pyramix

Use Templates
The supplied Templates have settings appropriate to their purpose and are the fastest way of 
optimizing Pyramix. However, the following information should help when deciding what set-
tings to use when creating your own projects and templates.

Pyramix File Format .PMF
We strongly recommend the use of the native .PMF format for a number of reasons.

The first issue is the size limitation of the WAV and BWF formats. These are LIMITED TO 2 GB 
in size by design (they use 32 bit signed, which gives a total of 2 to the power of 31 Bytes addres-
sable = 2'147'483'648 Bytes precisely). 

2GB may sound a lot but a little elementary arithmetic will show it is easy to exceed this limit 
when using higher sample rates and bit depths for multi-track recordings of real-world dura-
tions.

AIFF is slightly better in the sense that it is "only" LIMITED TO 4 GB (it uses 32 bit unsigned, 
which gives a total of 2 to the power of 32 Bytes addressable = 4'294'967'296 Bytes precisely.

PMF uses 64 bit addressing which would probably allow 128 tracks to be recorded for about 
10,000 years (If you can afford the disks!), which should be more than enough for any practical 
applications.

The second advantage of the Pyramix File Format for large multitrack projects is that it is not 
"sample-interleaved" but "block-interleaved". Which means that instead of (as with WAV, BWF 
and AIFF) recording on disk one sample of channel 1, then 1 sample of channel 2, and so on to 1 
sample of channel n, .pmf was designed from day one to optimize disk access by recording a 
quite large block of samples for each channel in a sequence. Typically 64 kB of channel 1, then 64 
kB of channel 2, etc, finally 64 kB of channel n.

This setting (default 64 kB) can be changed by the user to one of four alternative values in the 
Record Block Size section of the General Settings window under the Playback tab. However, 
the alternatives are really only applicable to certain RAID and Network-Attached-Storage set-
ups and, unless you have considerable knowledge and experience, the default setting should be 
used.

One File Per Track option
Found in the Settings > Project Information and Settings window on the Record page, The 
"one file per track" option should always be chosen (checked) whenever more than 2 tracks of 
recording are contemplated as there is a rather high potential performance penalty that can 
occur with all the sample-interleaved file formats (E.g.WAV and AIFF) on playback, when not 
all tracks of a multi-channel recording are used or played in their original sync relationship on 
the timeline. This is because with other, interleaved, formats the hard disk head will still have to 
go through all the bits of all the channels, even if only 1 or 2 tracks of that file are used at a given 
point in time.

DSP optimization
At the core of the Mykerinos cards is a very powerful Trimedia VLIW (Very Long Instruction 
Word) processor. This functions as a kind of DSP chip and can do a lot of things including 
implement quite large real-time audio mixer topologies. However even this very powerful chip 
has its
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limits and while it is more than adequate in implementing say a 48 input strips by 16 output bus 
configuration, it cannot be expected to implement a full "matrix mixer" of say 64 inputs by 64 
outputs with a full independent multiply/add + individual delay on each matrix node on what 
would be a 64 x 64 = 4096 nodes, while also taking care of all the other housekeeping tasks such 
as locking with ultra low jitter to external clocks, managing time code, record streams, playback 
streams, not to mention possible FX such as EQ, Dynamics, Reverb, etc. Therefore Pyramix 
offers a few DSP saving modes in the Settings > Mixer Settings, General page such as:

Player / Recorder mode

Transforms the mixer's full nodal matrix topology into a "diagonal" topology where only the 
direct paths are computed (i.e. Input 1 to Output 1, Input 2 to Output 2, Input n to Output n)

As one might expect, such a mixer topology optimization  reduces the complexity of a 64 x 64 
sized mixer from 4096 nodal computations down to just 64 computations, which is a dramatic 
DSP processing saving feature and allows Pyramix to accommodate very large player/recorder 
track counts. This will be further increased in future versions by software releases planned after 
V4.1 from a current maximum channel count of 64 to 128.

Disable Punch in / Punch Out

is another DSP processing saving function that, as it name indicates, disables concurrent record 
stream management whenever no Punch recordings are required during certain phases of a 
project's life. This might save another couple of % of DSP load.

Disable Mixdown

is similar to the above. Disables concurrent Master outputs possible extra paths used for record-
ing as mixdowns.
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Appendix I Mouse Modifier Keys

This table shows the valid modifier keys which can be used in conjunction with some mouse 
operations

Main Editor

Left Mouse Button

Click In the TimeCode Scale
Set Cursor to the mouse None

Set Mark In to the mouse Shift

Set Mark Out to the mouse Ctrl

Set New Marker to the mouse Ctrl + Shift

Click In the Bars & Beats Scale
Set Cursor to the mouse None

Adjust tempo to the end Shift

Adjust tempo for the current portion Ctrl

Adjust tempo for the current Beat Ctrl + Shift

Click In the Tempo Map
Create a new tempo portion Ctrl

Click In the Track headers zone
Repeat action for the same button on all tracks Shift

Click In the Clips zone (anywhere)
Draw a region to zoom in Alt

Dyna-Zoom Z

Draw a region to select None

Draw a region to select clips completely Shift

Extend/Reduce the current region to this track E

Invert No Selection mode for Track Groups Q

Invert Auto Select Tracks Q

Click In a Clip handle
Move only the clip handle under the mouse (no groups) Shift

Move only the envelope point under the mouse (no groups) Shift

Click In a Clip
Add remove clips to the selection Shift

Drag the selection (to a library) Shift + Alt

Move selected clips None
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Move selected clips with auto-crossfade Ctrl

Slide the underlying media of a clip Ctrl + Shift

Slide a clip over its underlying media Ctrl + Alt

Move selected clips constrained in time Ctrl + Shift + Alt

Cutter C

Duplicate clip D

Duplicate clip constrained in time F

While moving
Auto-crossfade while moving clips Ctrl

Force crossfade while moving clips lower handle Ctrl

Detach crossfade while moving clips middle handle Ctrl

Don't merge Envelope points Ctrl

Constrain Envelope in time V

Constrain Envelope in value H

Don't merge Automation points Ctrl

Constrain Automation in time V

Constrain Automation in value H

Select only what is under the mouse (no groups) Shift

Select all tracks Ctrl + Shift

Select and limit selection the clips boundaries Ctrl + Alt

Snap Sync Point S

Snap Head H

Snap Tail T

Audition while moving (Scrubbing) A

Double-click in a Clip
Selection Properties

Clip Properties Ctrl

Double-click in a fade
Edit the fade in the Fade Editor

Double-click in an envelope point
Reset the envelope point

Reset only the envelope point under the mouse (no groups) Shift

Middle Mouse Button
Edit crossfade Ctrl

Create & Edit crossfade Ctrl + Shift

Select between edits None

Enlarge selection between edits Shift

Right Mouse Button
Contextual Menu None

Clip Gain Ctrl
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On dropping a fade or crossfade from a library
Apply to whole group Shift

Overview

Left Mouse Button
Draw a region to zoom in Alt

Drag the current composition (to a library) Shift + Alt

Notes

Left Mouse Button
Drag the notes (to a library) Shift + Alt

Media Folder

Left Mouse Button
Replace media for target clip(s) Ctrl
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Appendix II I/O Daughter-card Options

ADAT Optical I/O
The ADAT Optical daughter card offers 16 channels of audio input and 16 channels of audio 
output, 8 channels per optical connection. From top to bottom of the card, it has two digital 
optical input connectors (Inputs A and B) and two digital optical output connectors (Outputs A 
and B).

The signal format of optical connectors Input A and Output A can be set inside the Pyramix 
software to operate in either ADAT or S/PDIF mode. When in ADAT mode, there are 8 discrete 
audio channels carried per each optical connector. S/PDIF mode has 2 channels per optical con-
nector.

Note: in SPDIF mode the maximum sampling rate is limited to 48 kHz

AES/EBU I/O
The AES/EBU daughter card offers 24 channels of I/O over 12 AES/EBU input and output 
pairs. Connection is via three DB-25 connectors, One on the main card attached to the Mykeri-
nos and two more on a separate bracket connected via internal ribbon cable to the main card. 
An optional break-out cable can be ordered seperately which connects to the DB-25 connector 
and terminates in 8 XLR connectors which may be used to connect to standard AES/EBU stereo 
inputs and outputs. AES daughter cards are available with or without 8 channels of SRC (sam-
ple rate conversion)

Dual DC I/O
The Dual DC offers up to 12 inputs and outputs at 32kHz, 44.1kHz or 48kHz sampling rates on 
a single board. All converters are 24 bit. Connection is via 2 DB-25 connectors. One, on the main 
card attached to the Mykerinos, carries the analog I/O and the second, on a separate bracket, 
carries four AES/EBU Input and Output stereo pairs. There are four analogue Line outputs and 
four analogue Line Inputs, two of which may be switched to accept Mic or Line level inputs. 
These have Mic pre-amps and 48V phantom powering. The analogue Line level I/O is adjust-
able over a 24dB range to accommodate all standard studio levels. Optional break-out cables 
can be ordered separately which connect to the DB-25 connectors and terminate in 8 XLR con-
nectors.

The Dual DC is the most cost-effective I/O daughter card for Pyramix users. It is an ideal I/O 
solution for mixed analog/digital requirements, as encountered in Broadcast production, and 
Video post-production environments. It allows direct connection of up to two dynamic or con-
denser microphones, typically for quick and easy voice-over recording.

Note: the Dual DC I/O daughtercard is not HDTDM bus compatible and can not be used in a 
multiboard setup.

MADI I/O
The MADI daughter card offers 56 channels of 24 bit bi-directional I/O, and up to 64 channels 
in MADI-X (MADI Extended) format. It can be ordered either in a BNC coaxial version or an 
optical duplex SC version. Both versions are fitted with a standard Wordclock BNC I/O connec-
tor, which can be programmed in the Pyramix software as a Wordclock In or Out signal.

SDIF I/O
The Mykerinos SDIF daughter board is specially designed for multi-track DSD recording. It 
offers 8 channels of DSD digital input over 8 unbalanced, 75 Ohm terminated BNC connectors 
and 8 channels of DSD digital output over 8 unbalanced, 75 Ohm BNC connectors.One channel 
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of DSD signal is transported at the bit-rate of 2.82 MHz through each BNC connector. SDIF-2 
and SDIF-3 format are fully supported for DSD transport (selected under software control)

With one Mykerinos board, it is only possible to use one DSD Input and Output channel. To 
have the full range of 8 I/O channels, a second Mykerinos board is required to provide sufficient 
DSP power.

TASCAM TDIF
The TASCAM TDIF daughter card offers 24 channels of I/O over 3 Tascam TDIF connections. 
Connection is via three DB-25 connectors, One on the main card attached to the Mykerinos and 
two more on a separate bracket connected via internal ribbon cable to the main card.

TASCAM TDIF I/O Option
A TASCAM TDIF format optionbracket may be added to the ADAT I/O daughtercard and pro-
vides is available for 8 channels of TDIF I/O. The TDIF bracket connects to a socket on the 
ADAT card only. This daughter card cannot be used in multi-board systems (since it utilizes the 
HTDM connector).
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Appendix III Optional Features

Pyramix DSD / SACD

Interfacing
DSD transmission works well with either AES-EBU or SDIF interfaces. Most converter manu-
facturers use SDIF. Only dCS does SDIF and AES-EBU.

A further issue is the existence of two different AES-EBU supported DSD formats. The so called 
"Sony" and one named "P3D." Merging Technologies support both of these. If you need to inter-
face to both AES/EBU and SDIF two cards will be required.

Wordclock settings.
In DSD mode it is imperative Pyramix wordclock settings correspond with the requirements of 
the converters employed. To date all the DSD compatible converters we have tested generate 
and expect wordclock at the standard nominal rate. I.e. 44.1kHz.

Failure to set Pyramix to expect only 44.1kHz in DSD operation will prevent proper locking to 
the external source and therefore prevent correct decoding of the DSD bitstreams, resulting in 
very loud noise on its outputs. Check the setting via:

View > Mixer Settings :  I/O & Sync tab

make sure that the "Wordclock is Input at 44.1k x 2" checkbox is NOT checked when operating 
in DSD mode.

To verify Pyramix is correctly locked to incoming Word clock:

Left-click on the red 'LED' in the Sync: WordClock box (bottom right of Pyramix screen in the 
status bar). This will open the I/O status window The green LEDs indicate active inputs and 
there will be a red LED in front of the chosen sync source if this is locked.

Right-click on the same (Sync: WordClock) red 'LED'. Select, Debug > Input Check. This win-
dow will enable you to check that Pyramix is effectively locked at the correct frequency.

Time-code Sync
Required if you intend to use LTC (Linear TimeCode) or VITC (Vertical Interval TimeCode) to 
synchronize Pyramix to external equipment.

Cue Sequencer
The Cue Sequencer is a live playout system

A Cue is defined as a Track Group and all the Tracks and clips it contains. All Track Groups in 
the composition appear in the Cue Sequencer list and are called a Cue. 

Cues can be re-ordered in the Cue Sequencer list view by drag and dropping lines or groups of 
lines.

Double-clicking on a Cue selects its first track in the Editor.
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Cue Parameters
Cues have the following parameters:

Name: Same as the Track Group name

Notes: free notes typed by the user

Event: An event number (from 1 to 96) can be associated to any cue. This 
event number can be mapped to a keyboard shortcut with the Key-
board Shortcut Editor or mapped to a MIDI message with any 
Remote Controller. When triggered this event Starts the Cue.

Automation: A Cue can use automation on the mixer channels connected to its 
tracks. A mixer channel can be controlled by only one Cue.

Start: To Play a Cue.

Pause: To pause the playback of a Cue.

Stop: To Stop the playback of a Cue.

Start Offset: An offset can be applied to a Cue so the starting point is not the 
beginning of the first clip of the Cue but a point before (negative 
Start Offset value) or after (positive Start Offset value).

Current Time: Elapsed time since the Cue as been started

Remaining Time: Remaining playback time of a Cue.

Cue Status
Cues have the following Status:

Disabled (White): The sequence has to be reset to enable all Cues.

Ready (Pink): The Cue is enabled and ready to play.

Playing (Green): The Cue is playing, it can be paused or stopped.

Paused (Yellow): The Cue is paused, it can be un-paused (return to playing from 
current position) or stopped.

Done (Grey): The Cue finished playing. It can be played again without having to 
be reset.

Cue Sequencer Control
The Cue Sequencer is controlled the following way:

Safe Mode: When in safe mode, the Cue Sequencer window is maximized and 
all Keyboard shortcuts except those related to the Cue Sequencer 
are disabled. The Cue Sequencer TimeCode counter is colored in 
red when not in Safe Mode.

Reset Show: All Cues have to be reset before starting to play the sequence. 
When pressing this button all Cues are reset to the Ready State 
(Pink Color) and the time is reset to 00:00:00:000.

Stop Show: To Stop the sequence playout

Start Show: To Start the sequence playout.

Previous: To set the focus to the previous Cue.

Next: To set the focus to the Next Cue.

GO !: To Start the currently selected Cue and select the next one.
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Appendix IV 9 - Pin connection

PC RS-232 Serial Port to External Sony P2 RS-422 Controller
The RS-232 ports of a standard PC are slightly different from the RS-422 format used for the 
Sony P2 protocol. We recommend the use of an external RS-232/RS-422 adapter. One exampleis 
the Antona ANC 6090 which can be ordered from your Merging sales representative under the 
item number MRS422. This adapter is intended to be connected directly to the serial port of 
your PC (either COM1 or COM2) with the other end used to connect a standard Sony P2 RS-422 
cable. As both connectors on the adapter are Female DB9, beware of the orientation and please 
check that the printed indication "RS-232" is connected to the PC COM port

Connecting an RS422 device using a direct cable
(without RS-232 / RS-422 adapter)

For emergency use and for short distances, a direct cable may be used. However, Merging Tech-
nologies does not guarantee the correct function of an external controller if this cable is used. 
Different cables are required depending on whether Pyramix is controlled by a master device or 
is controlling a slave device .

Direct Cable for a Master Device
This pinout should work in most of the cases where Pyramix is controlled by a Master device 
(check on your controller if the RS422 connector has to be male or female). It has been tested 
with various mixers such as Sony DMX-R100, Soundcraft Spirit, Soundtracs DPC II and DS3, 
and various other Sony P2 protocol capable controllers:

The RS422 standard is not implemented consistently on all devices, so the cable pinouts may 
differ. Please consult your controller's user guide for appropriate connector cabling.

Function

GND

Pin #

1

Function

DCD/RLSD
Rx
Tx
DTR
GND
DSR
RTS
CTS 
RI

2
3
4
5
6
7
8
9

Rcv -
Xmit +
GND
N.C.
GND
Rcv +
Xmit - 
GND

Shield Shield

Pin #

1
2
3
4
5
6
7
8
9

RS422 Male (or Female) DB9 RS232 Female DB9
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Direct Cable for a Slave Device
This pinout should work in most of the cases where Pyramix is controlling a Slave device.

The RS422 standard is not implemented consistently on all devices, so the cable pinouts may dif-
fer. Please consult your controller's user guide for appropriate connector cabling.

Function

GND

Pin #

1
2
3
4
5
6
7
8
9

Rcv -
Xmit +
GND
N.C.
GND
Rcv +
Xmit - 
GND

Shield

RS422 Male (or Female) DB9

Function

DCD/RLSD
Rx
Tx
DTR
GND
DSR
RTS
CTS 
RI

Shield

Pin #

1
2
3
4
5
6
7
8
9

RS232 Female DB9
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Index

A
Absolute Sources in EDL View 108
Active Machine 140
Adding and Deleting Tracks 97
Adding Plug-ins 56
Adding Strips 55
Akai DD / DR 211
Alternate Backup 64
Angudion 186
Archiving Projects 206
Assumptions 7
Audio Connections 14
Audition after Nudge settings 66
Auto Collapse 122
Auto Cross-fade 85
Auto Crossfade Mode 41
Auto Deglitching 124
Auto Hide 122
Auto Mute 122
Auto Record Ready 122
Auto Silence Removal 46
Auto Solo 122
Auto-chase 140
Autoconforming 145
Auto-Crossfade 66
Auto-Crossfade By Default 42
Automatic Deglitching 68
Automation 104, 151

Off 104
Play 104
Write 104

Automation in editing and libraries 158
Automation Menu 250
Automation Modes 151

Auto-Write 151
Isolate 151
Play 151
Record 151

Automation Settings 152
Automation Trim 156
Auto-Monitoring 68
Auto-Saving 64
Aux Bus 54

B
Basic Strip 50
Boards & Keys 75
Burn-in Window 74
Burning a CD-R 206
Bus Tools 171
Bus Tools Sections 172
Buttons 50

C
Cabling Pyramix 14
CD 132
CD Import 212
CD Mark Groups 135
CD Markers 203
CD Red-Book Validation 139
CD Text 138
CD Text fields 134
Changing or re-entering a Key 16
Channel Direct Outputs 58
Chasing 73
Clean up Media after recording 85
Cleaning Up Project media 209
Clip Fade Commands 42
Clip Information Only Fields 124
Clip Properties 39
Clip Selection 39
Clips and Compositions 35, 36
Clips in a Composition 36
Clips Menu 234
CMX Autoconform 215
CMX EDL 213
Composition Information and Settings Toolbar 101
Computer 10
Consolidate 112
Consolidating Projects 207
Context Menus 17
Control Points 36
Controllers Tab 86
Conventions 7
Convert 116
Converting Projects 208
Copy 44
Copy and Paste 40

Clip 41
Creating and Configuring Mixers 52
Creating Effects Snapshots 159
Cue Sequencer 266
Cue Sequencer Control 267
Cue Sheet Printer 218
Cursors and marks 240
Customizing the User Interface 221
Cut 44
Cut and Ripple 45
Cutter 43

D
Daughter Card Settings 91
Daughter-cards 13
DC Meter 195
DC Removal 118
Default Mixer 58
Default Projects Location 70
Default Templates Location 71
Delay 50, 184
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Delay Compensation 173
Destination Wordlength 118
Digital Audio Synchronization and TimeCode 12
Digitizing Sessions 144
Direct X Plug-ins 56, 202
Disable Mix Down 88
Disable Punch in/out 88
Display and Editing of Automation Data 155
Display Blocks 99
Display Envelope 100
Display Waveform 99
Dither 204
Dithering 118
Dithering Window 57
Document Libraries 109
Dragging Clips into a Composition 40
DSD Peak Filter 93
DSP Time Saving 88
Dual Monitors 95
Duplicate Selection 43
Dynamic-Meter 188
Dynamics 181

E
Edit Commands 44
Edit menu 226
Editing 36, 38
Editing Automation data 157
Editing Modes 43
Editing Tab 65
EDL 108
Effects Snapshots 159, 198
Enabling Pyramix 16
Entering Keys 16
European Monitoring 68
Exclusive Show 122
Export to a File 204
Exporting Projects to CD Image Files 205
External Audio D/A-A/D Converter Boxes 13
External Effects 55
External Machines 141
External TC reader 72

F
Fade Editor 125

Faders & Control Section 128
Parameters & Options Section 128

Fade Editor Menu 246
Fade In 45
Fade library location 66
Fade Out 42
Fader 50
Fast Forward 103
Filter 113
Fixed Cursor Settings 67
Fixed or Moving Playhead Cursor 101

Flanger 185
Flatten track numbers 84
Free Markers 122
Free Zoom 122
Function Generator 197

G
Gain WIndow 38
Gain window 38
Gate colors 148
General Settings 63
General Tab 63
Ghost Track 138
Glitch and Pops finder 209
Goto Beginning 102
Goto End 102
Graphic EQ 181
Group Normalize 117
Group Recorded Clips 85
Grouping Clips 37
Groups 52

H
Hard Chase 103
Hard Disk Space Requirements 10
HDTDM 13
Help Menu 257

I
I/O Assignments 55
I/O Busses 52
Import Key 16
Importing Audio Files 33
Increment take number 85
Input Assignment 50
Input Format 90
Input Strips 52
Insert Silence 45
Installing Pyramix 16
Internal Return Busses 52
Introduction 7
ISRC 135

J
Joystick Panner 59

K
Keep Cursor 122
Keep in default library 85
Keyboard Shortcuts 221

L
Layout Tab 69
Level Meter 91
ix Virtual Studio User Manual
272



User Manual:   Index

Pyram
Library Menu 109
Locations Tab 70
Locking Clips 37
Loop Play 103
LTC Generator 72
LTC reader 72

M
Machines Menu 252
Machines Tab 76
Machines Tab Window 140
Macro Menu 256
Macros 222
Managing Media Folders 35
Manual Digitizing 145
Markers 49, 131
Markers / Tracks Sync 102
Markers Locked 122
Master Automation Controls 154
Mastering Peak/Vu Meters 187
Mastering to CD-R 203
Media Information Only Fields 125
Media Management 114
Media Management Menus 115
Media Offset 125
Media option 84
Media reconnection 214
Media Type 84
Menus 224
Meter Alignment level 92
Meter Decay integration time 92
Meter Permanent Overload 92
Meter Permanent Peak 92
MIDI Connections 15
Mix Bus 53
Mixer and Plug-in Snapshots 158
Mixer Components 50
Mixer Configure 55
Mixer Context Pop-up menu 56
Mixer Presets 58
Mixer Settings 87

General 87
I/O & Sync 89

Mixer Snapshots 158
Recalling 158
Saving 158

Mixer Surround Components 59
Mixing/Monitoring/Aux Buses 52
Modulometer 196
Monitor Bus 54
Monitoring 90
Mono Mix 53
Mount / Create 35
Mounting Media Drives 33
Mouse Modifier Keys 261
MT Security Settings 16
Multi-board installation 13

Multiple CDs or versions in one Project 139
Multiple Mix Busses 53
Mykerinos 9, 259
Mykerinos Back-plate 14
Mykerinos Board Installation 13
Mykerinos Daughter Card Settings 91

N
Native Plug-ins 56
Navigation 101
Noise Shaping 58, 118
Normalize 45
Notes

Tab window 139
Nudge settings 65

O
Offset 104
OMF 215
Operating System 11
Optional Plug-ins 199
Original Timecode 125
Other Applications 11
Output Mode 90
Overview 107

P
Parametric EQ 180
Paste 44
Paste & Fit 45
Paste & Place 45
Paste and Ripple 45
Paste to Cursor 44
Paste to Cursor and Ripple 45
Paste to Original TC 45
Paste to Selection 45
Pause 103
PDF (Probability Density Function) 57
Peak and Overload Hold Time 92
Peak level indicator 92
Peak/Vu Meters 187
Peak-Meter 188
Pencil Tool 209
Permanent Mount 35
Permanently Mounted Media Folders 71
Phase Invert 124
Phase-Oscillo 193
Place on new tracks 85
Placement Tool 48
Play 31, 103
Play Head Position 101
Playback Buffer setting 68
Playback Stall indication 68
Playback Tab 67
Player/Recorder Mode 88
Playlists 86
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Plug-in Automation 198
Plug-Ins 177
Plug-ins

Common Master Section 177
Position/Speaker Control 61
Post Processing 85
Power Management 11
Pre/Post Roll Settings 67
Pre-Anticipation 176
Preferred Outputs 90
Program and Project Settings 62
Program Window 94
Project Editing Panel 95
Project Interchange 210
Project Management Panel 96
Project Menu 224
Project Window 95
Prompt for name after recording 32
Prosoniq MPEX2 Properties 118
ProTools Interchange 215
PS3 52
Pull-Down 88
Pull-Up 88
Pyramix audio file format 31
Pyramix Card and Software Set 9
Pyramix Guides 8
Pyramix Turnkey 9
Pyramix Virtual Studio Board I/O 9
Pyramix Virtual Studio Overview 9

Q
Quick Convert 116
Quick Export 116
Quick Import 116
Quiet if creation failed 84

R
Record Block Size 68
Record button 103
Record Name 32, 85
Record Punch In (Auto) 31
Record Ready (Manual) 31
Record Tab 83
Recording Audio into a Pyramix Virtual Studio
Project 31
Recursive 35
Region Selection 40
Regions 35
Rel. box 38
Removing Mixer Presets 58
Removing Strips 55
Rendering 209
Report Printer 217
Reset List 35
Reverse 116
Rewind 103

Rotary Controls 50

S
Sample Rate Conversion 34
Samplerate Converter Properties 117
Sampling Rate 87
Save Fade 131
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